VirtualBox

Ticket #15527 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Mouse Cursor Hidden -> duplicate of #7945.

Reported by: kingbeandip Owned by:
Component: guest additions/x11/graphics Version: VirtualBox 5.0.22
Keywords: mouse integration capture cursor Cc:
Guest type: Linux Host type: Windows

Description

On my machine the mouse cursor is invisible (clicking, hover events, dragging, etc all work, but I cannot see the cursor) when the VM captures the mouse. This happens both when Mouse Integration is turned off, and when I attempt to assign a second mouse to the VM (in the Devices menu). Mouse integration works normally, but this prevents me from dedicating a mouse to the VM.

I am using an Intel i5 processor, and Linux Guest Additions are fully installed and working. 3D Acceleration is enabled. The problem is extremely finicky when Acceleration is disabled, and I have been able to get the mouse capture to work until I reboot the VM. I have never been able to get it to work with acceleration enabled, though it does depend slightly on the guest.

Host: Windows 10 Pro Guest 1: Ubuntu 16.04 (captured mouse always invisible) Guest 2: Ubuntu 16.04 with Cinnamon 3 GUI (captured mouse always invisible) Guest 3: Kubuntu 16.04 (captured mouse only invisible when mouse integration is turned on)

Other information: This problem is not new to VirtualBox 5.0.22. I have also seen in forums some people comment about this problem in VirtualBox 4.x, but the bug was supposedly resolved.

Attachments

VBox.log Download (103.7 KB) - added by kingbeandip 4 years ago.

Change History

Changed 4 years ago by kingbeandip

comment:1 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from USB to guest additions/x11/graphics
  • Summary changed from Mouse Cursor Hidden to Mouse Cursor Hidden -> duplicate of #7945.

Duplicate of #7945.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use