VirtualBox

Ticket #15423 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Kernel modules fail to compile on latest RHEL 6.8 kernel

Reported by: GabrielVlasiu Owned by:
Component: other Version: VirtualBox 5.0.18
Keywords: Cc:
Guest type: other Host type: Linux

Description

  CC [M]  /var/lib/dkms/vboxhost/5.0.18-1.centos6g/build/vboxnetflt/linux/VBoxNetFlt-linux.o
/var/lib/dkms/vboxhost/5.0.18-1.centos6g/build/vboxnetflt/linux/VBoxNetFlt-linux.c: In function ‘vboxNetFltLinuxPacketHandler’:
/var/lib/dkms/vboxhost/5.0.18-1.centos6g/build/vboxnetflt/linux/VBoxNetFlt-linux.c:939: error: implicit declaration of function ‘vlan_tx_tag_present’
/var/lib/dkms/vboxhost/5.0.18-1.centos6g/build/vboxnetflt/linux/VBoxNetFlt-linux.c:949: error: implicit declaration of function ‘vlan_tx_tag_get’
make[2]: *** [/var/lib/dkms/vboxhost/5.0.18-1.centos6g/build/vboxnetflt/linux/VBoxNetFlt-linux.o] Error 1
make[1]: *** [/var/lib/dkms/vboxhost/5.0.18-1.centos6g/build/vboxnetflt] Error 2
make: *** [_module_/var/lib/dkms/vboxhost/5.0.18-1.centos6g/build] Error 2
make: Leaving directory `/usr/src/kernels/2.6.32-642.el6.x86_64'

# uname -r 2.6.32-642.el6.x86_64

Changing vlan_tx_tag_get to skb_vlan_tag_get and vlan_tx_tag_present to skb_vlan_tag_present allowed kernel module to be built and function. Maybe changeset 58845 should also include RHEL 6.8.

Change History

comment:1 Changed 4 years ago by frank

Duplicate of #15411.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use