VirtualBox

Ticket #15418 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

guest addtions: Ubuntu 16.04 Server, error message about libXrandr on Guest Additions start-up -> fixed in releases higher than 5.0.20

Reported by: FranzS Owned by:
Component: guest additions Version: VirtualBox 5.0.20
Keywords: X.Org, XFree86, shared libraries, libXrandr, Guest Additions Cc:
Guest type: Linux Host type: Windows

Description

I get an error message "BoxClient: error while loading shared librarie" in my syslog:

May 14 16:22:41 fortuna vboxadd[837]: Starting the VirtualBox Guest AdditionsInstalling the Window System drivers
May 14 16:22:41 fortuna vboxadd[837]: Could not find the X.Org or XFree86 Window System, skipping.
May 14 16:22:41 fortuna vboxadd[837]: /usr/bin/VBoxClient: error while loading shared libraries: libXrandr.so.2: cannot open shared object file: No such file or directory
May 14 16:22:41 fortuna vboxadd[837]:  ...done.
May 14 16:22:41 fortuna systemd[1]: Started vboxadd.service.

As I took a closer look i found out that this libXrandr is usually only available in systems that have an X Server. But this is not the case in my Machine which is even detected one row above where it say's "Could not find the X.Org or XFree86 Window System, skipping." Therefore i think this is a little bit strange that on the one hand the System detects that there is no X Server and directly afterwards want to use a library that is used for X Servers.

Even during the installation it seems to be properly detected that there is no X Server.

I did the installation like this:

sudo mount /dev/sr0 /media/cdrom/
sudo apt-get install -y dkms build-essential linux-headers-generic linux-headers-$(uname -r)
sudo /media/cdrom/VBoxLinuxAdditions.run --nox11

This was the output, clearly saying that "Could not find the X.Org or XFree86 Window System, skipping."

But still got the Message in the syslog

Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.20 Guest Additions for Linux............
VirtualBox Guest Additions installer
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox DKMS kernel modules ...done.
Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules ...done.
Doing non-kernel setup of the Guest Additions ...done.
Starting the VirtualBox Guest AdditionsInstalling the Window System drivers
Could not find the X.Org or XFree86 Window System, skipping.
 ...done.

Change History

comment:1 Changed 4 years ago by FranzS

Please see also the following thread in the Support Forums:

 https://forums.virtualbox.org/viewtopic.php?f=3&t=77685

comment:2 Changed 4 years ago by michael

  • Summary changed from guest addtions: Ubuntu 16.04 Server, VBoxClient: No X.Org but dependency to libXrandr?? to guest addtions: Ubuntu 16.04 Server, error message about libXrandr on Guest Additions start-up -> fixed in releases higher than 5.0.20

This error is purely cosmetic and everything still works as intended. I have added code to silence the error message though.

comment:3 Changed 3 years ago by FranzS

I've installed 5.0.22. The same error still appears

May 17 19:07:42 fortuna systemd[1]: Starting vboxadd.service...
May 17 19:07:43 fortuna vboxadd[5128]: Starting the VirtualBox Guest AdditionsInstalling the Window System drivers
May 17 19:07:43 fortuna vboxadd[5128]: Could not find the X.Org or XFree86 Window System, skipping.
May 17 19:07:43 fortuna vboxadd[5128]: /usr/bin/VBoxClient: error while loading shared libraries: libXrandr.so.2: cannot open shared object file: No such file or directory
May 17 19:07:43 fortuna vboxadd[5128]:  ...done.
May 17 19:07:43 fortuna systemd[1]: Started vboxadd.service.

comment:4 Changed 3 years ago by FranzS

Okay, changed my opionion! It seems to be fixed!

Jun 22 08:24:39 fortuna systemd[1]: Starting vboxadd-service.service...
Jun 22 08:24:39 fortuna kernel: [   14.152215] VBoxService 5.0.22 r108108 (verbosity: 0) linux.amd64 (Jun 16 2016 13:43:22) release log
Jun 22 08:24:39 fortuna kernel: [   14.152215] 00:00:00.000274 main     Log opened 2016-06-22T06:24:39.709412000Z
Jun 22 08:24:39 fortuna kernel: [   14.152286] 00:00:00.000399 main     OS Product: Linux
Jun 22 08:24:39 fortuna kernel: [   14.152308] 00:00:00.000426 main     OS Release: 4.4.0-22-generic
Jun 22 08:24:39 fortuna kernel: [   14.152329] 00:00:00.000447 main     OS Version: #40-Ubuntu SMP Thu May 12 22:03:46 UTC 2016
Jun 22 08:24:39 fortuna kernel: [   14.152358] 00:00:00.000468 main     Executable: /opt/VBoxGuestAdditions-5.0.22/sbin/VBoxService
Jun 22 08:24:39 fortuna kernel: [   14.152358] 00:00:00.000469 main     Process ID: 1266
Jun 22 08:24:39 fortuna kernel: [   14.152358] 00:00:00.000469 main     Package type: LINUX_64BITS_GENERIC
Jun 22 08:24:39 fortuna kernel: [   14.156490] 00:00:00.004574 main     5.0.22 r108108 started. Verbose level = 0
Jun 22 08:24:39 fortuna systemd[1]: Started vboxadd-service.service.

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use