VirtualBox

Ticket #15326 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

After upgrading to 5.0.18 Guest Additions some Linux windows appearing as black rectangles -> duplicate of #15417.

Reported by: PAE-PRO Owned by:
Component: guest additions/x11/graphics Version: VirtualBox 5.0.18
Keywords: Cc:
Guest type: other Host type: other

Description

I have VB running on a Windows 10 PC as host. I upgraded from 5.0.16 to 5.0.18.

After updating a Linux Mint 17.3 Cinnamon VM to Guest Additions 5.0.18 applications such as Chrome and GitKraken now come up as black rectangles. These are front of screen so other windows are hidden behind them and the VM is unusable. Some windows such as the terminal and the file explorer are OK. 3D support is switched on.

Attachments

VBox.log Download (151.7 KB) - added by PAE-PRO 4 years ago.
Vbox.log file

Change History

Changed 4 years ago by PAE-PRO

Vbox.log file

comment:1 Changed 4 years ago by JoeBanna

Not fixed in 5.0.20.

Guess we stay on 18 until fixed.

comment:2 Changed 4 years ago by JoeBanna

Oops, I meant we stay on 16.

comment:3 Changed 4 years ago by attila77

+1

comment:4 Changed 4 years ago by frank

PAE-PRO, you have 3D enabled but you configured only 12 MB of VRAM. This configuration is not expected to work. What happens if you use 128 MB VRAM?

Other reporters: Please attach VBox.log files.

comment:5 Changed 4 years ago by michael

See also #15417.

comment:6 Changed 4 years ago by DogSHlT

yes mine to 5.0.20 host windows 10 virtualbox guest ZorinOS black as fuck.

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

You set the VRAM to 12 MB which is not sufficient if 3D is enabled. Increase it to at least 128 MB or better 256 MB. VBox 5.0.22 contains a warning for this setting.

comment:8 Changed 3 years ago by michael

  • Component changed from guest additions to guest additions/x11/graphics
  • Summary changed from After upgrading to 5.0.18 Guest Additions some Linux windows appearing as black rectangles to After upgrading to 5.0.18 Guest Additions some Linux windows appearing as black rectangles -> duplicate of #15417.

Actually I doubt that this is fixed. I prefer to close it as a duplicate of #15417. (Feedback welcome either way.)

See also the wiki page on X11 guest 3D contributions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use