VirtualBox

Ticket #15307 (reopened defect)

Opened 2 years ago

Last modified 3 months ago

VirtualBox wakes sleeping laptop

Reported by: ethan_webspc Owned by:
Priority: minor Component: other
Version: VirtualBox 5.0.16 Keywords: power
Cc: Guest type: Linux
Host type: Windows

Description

Running VirtualBox for Homestead Vagrant (so Linux virtual machine) on Windows 10. Shut laptop or press power button and laptop goes to sleep. Shortly thereafter it wakes. Also reported here:  https://forums.virtualbox.org/viewtopic.php?f=6&t=69723

Running powercfg -lastwake I get:

Wake Source Count - 1
Wake Source [0]
    Type: Wake Timer
    Owner: [PROCESS] \Device\Harddisk\Volume5\Program Files\Oracle\VirtualBox\VBoxSVC.exe

VBox v. 5.0.16 Homestead v. 0.4.2 Vagrant 1.8.1

I think this is VBox, but I could open reports on these other services as well.

Attachments

VBoxSVC.log Download (29.6 KB) - added by msd 12 months ago.
virtualbox log

Change History

comment:1 Changed 2 years ago by ethan_webspc

ASUS Zenbook UX305F - that may also be relevant.

comment:2 follow-up: ↓ 8 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Most likely a duplicate of #8298. This will be fixed in the next major release.

comment:3 Changed 22 months ago by 15327

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Hello,

I am using VirtualBox Version 5.1.2r108956 on a Windows 10 machine and I am experiencing the very same problem above: computer wakes up from standby at various times, does nothing, goes back into standby and wakes up again (checked eventlog to see what's happening).

"powercfg -lastwake" reports:

Aktivierungsverlaufsanzahl - 1
Aktivierungsverlauf [0]
  Aktivierungsquellenanzahl  - 1
  Aktivierungsquelle [0]
    Typ: Aktivierungszeitgeber
    Besitzer: [PROCESS] \Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VBoxSVC.exe

Additionally event log contains an entry "Power-Troubleshooter", which states, that the system has been reactivated due to wake timer: http://abload.de/img/vboxsvc_eventlog_entrcsk8u.jpg

(Messages are localized since I am using a German version of Windows 10 Professional; the corresponding English message of the code-block can be found in the ticket above)

As a workaround I now disabled Wake Timers for this Windows 10 set up and will report back whether it worked or not.

comment:4 Changed 22 months ago by Sygmoral

The issue does seem to go away when I set Power Options > Advanced settings > Sleep > Allow wake timers to Disable (on Windows 10).

Before that, I used to circumvent the issue by unplugging the power cord to my laptop when I put it to hibernation. Not sure why that actually worked, as the Wake Timers setting was identical for On battery and Plugged in.

comment:5 Changed 21 months ago by Aylon

I can report the exact same issue whereas it just seemed to have started a couple of weeks ago. However, as it does affect my main computer which is supposed to be waking up on scheduled tasks. Hence i cannot disable that option as in the previous suggestion. Has there been any further suggestions or fixes?

Host: Win 10 pro VB Version 5.1.2 r108956 Guest: Ubuntu (64-bit)

comment:6 Changed 19 months ago by cremor

I have the same problem with version 5.0.28

comment:7 Changed 13 months ago by LaravelCoder

I have this same problem on Windows 10 Pro (version 1607 build 14393.0) hosting Laravel 5.4 Homestead.

I've never seen my computer act like this before. Even after I manually put it to sleep, it then continually wakes, sleeps, wakes, sleeps forever.

C:\WINDOWS\system32>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Wake Timer
    Owner: [PROCESS] \Device\HarddiskVolume4\Program Files\VirtualBox\VBoxSVC.exe

It's super annoying and is affecting my ability to sleep as a human too because I can hear the computer wake up in the next room. :(

C:\Program Files\VirtualBox>vboxmanage --version
5.1.14r112924

Unfortunately, the recommendation mentioned by @15327 and @Sygmoral ("Power Options > Advanced settings > Sleep > Allow wake timers to Disable") did NOT solve the problem for me.

Last edited 13 months ago by LaravelCoder (previous) (diff)

comment:8 in reply to: ↑ 2 Changed 13 months ago by LaravelCoder

Replying to frank:

Most likely a duplicate of #8298. This will be fixed in the next major release.

Hi @frank, it seems that the releases between 12 months ago and now have not fixed this bug.

I see that this ticket's "Owned by" field is blank. I wonder what the process is for someone to take ownership of it.

In the meantime, if you have any suggestions for workarounds, I'd appreciate it. Thanks. ☺

comment:9 Changed 13 months ago by frank

Sorry, I don't have any suggestions or workaround. First of all we need to be able to reproduce the problem which we are currently not. I assume that this problem depends on the installed hardware. Please attach the VBoxSVC.log file (from c:
Users
USERNAME\.VirtualBox) to this ticket. Regarding the process for resolving tickets: Usually the "owned by" field is not set. Support for in this bugtracker is provided on a best-effort basis.

Changed 12 months ago by msd

virtualbox log

comment:10 Changed 12 months ago by msd

I believe I encountered this exact bug(?) last night. My VBoxSVC.log is attached to the ticket. However, the vagrant VM was still running when I tried to hibernate my PC, so I am not exactly sure if this is a bug or expected behaviour.

comment:11 follow-up: ↓ 12 Changed 4 months ago by zingmars

Seems to be a duplicate of https://www.virtualbox.org/ticket/14789.

I can confirm that this bug still exists on VirtualBox 5.2.6. It seems to happen while the manager is open. I guess one way would be to either close the window before going to sleep, or disabling wake timers entirely.

comment:12 in reply to: ↑ 11 Changed 3 months ago by SpideySpirit

Replying to zingmars:

Seems to be a duplicate of https://www.virtualbox.org/ticket/14789.

I can confirm that this bug still exists on VirtualBox 5.2.6. It seems to happen while the manager is open. I guess one way would be to either close the window before going to sleep, or disabling wake timers entirely.

I to can also confirm this bug still exists on VirtualBox 5.2.6. I am investigating the cause, however, disabling wake timers is not an option for me. I'll be back....

comment:13 Changed 3 months ago by szx

I have the same problem with VirtualBox 5.2.7 and a headless Ubuntu VM on Windows 10. When the computer goes to sleep it wakes up immediately and keeps doing this in a loop.

From event viewer:

SleepTime 2018-02-17T09:46:23.193493600Z

WakeTime 2018-02-17T09:47:26.354798000Z SleepDuration 939 WakeDuration 854 DriverInitDuration 552 BiosInitDuration 1176 HiberWriteDuration 9319 HiberReadDuration 0 HiberPagesWritten 877345 Attributes 25601 TargetState 4 EffectiveState 5 WakeSourceType 6 WakeSourceTextLength 11 WakeSourceText VBoxSVC.exe WakeTimerOwnerLength 67 WakeTimerContextLength 0 NoMultiStageResumeReason 0 WakeTimerOwner \Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VBoxSVC.exe WakeTimerContext

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use