VirtualBox

Ticket #15293 (closed defect: obsolete)

Opened 4 years ago

Last modified 21 months ago

Can't start VM after configuring host only network

Reported by: HackerBaloo Owned by:
Component: network/hostif Version: VirtualBox 5.0.16
Keywords: hostonly VERR_INTNET_FLT_IF_NOT_FOUND Cc:
Guest type: other Host type: other

Description

Running Windows 7 sp1 on the host, a 64-bit Debian (wheezy) server with first network adapter connected to hostonlyif - "VirtualBox Host-Only Ethernet Adapter"

Steps to reproduce:

  1. Setup my Debian VM (see above)
  2. Start it - it works
  3. Run my script test.py (attached), that tears down and sets up the hostonly configuration I would like, using vboxmanage
  4. Try to start vm again - fails with error, see below
  5. Uninstall VirtualBox
  6. Install VirtualBox
  7. Note that the Hostonly configuration is still there
  8. goto 2, and repeat as many times as you like

I would also like to point out that a lot of related defects have been closed after people have tried another version, but the thing is, it always works after reinstall, but the issue is still not fixed. So I believe this way to reproduce could be a nice opportunity to finally solve this problem.

Error message when it fails: Failed to open/create the internal network 'HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter' (VERR_INTNET_FLT_IF_NOT_FOUND).

Perhaps related: https://www.virtualbox.org/ticket/15103 https://www.virtualbox.org/ticket/15060

Tested with 5.0.10, 5.0.12, 5.0.14, 5.0.16, 5.0.17-106359

Attachments

PCT_a360b8b2-2983-45b6-a91d-e6e2d53a32e7-2016-04-07-09-39-08.log Download (32.9 KB) - added by HackerBaloo 4 years ago.
VBox.log
test.py Download (1.8 KB) - added by HackerBaloo 4 years ago.
The python script that configures the host only network

Change History

Changed 4 years ago by HackerBaloo

VBox.log

Changed 4 years ago by HackerBaloo

The python script that configures the host only network

comment:1 Changed 4 years ago by HackerBaloo

I have been able to narrow it down a bit further. If I start out with both hostonly and dhcp configured, with the settings found in test.py. And a VM using hostonly, all I have to do to break it is:

VBoxManage hostonlyif remove "VirtualBox Host-Only Ethernet Adapter" VBoxManage hostonlyif create

you could think, that a restart would help. It doesn't. But uninstall/install works, even without restart.

So, I think a work around is to not recreate the adapter, just use:

netsh interface ip set address name="VirtualBox Host-Only Network" static 192.168.56.1 255.255.255.0

to reconfigure it, instead of:

VBoxManage hostonlyif ipconfig "VirtualBox Host-Only Ethernet Adapter" --ip 192.168.56.1 --netmask 255.255.255.0

which does not always work, see https://www.virtualbox.org/ticket/8796#comment:20

comment:2 Changed 21 months ago by aleksey

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use