VirtualBox

Ticket #15209 (closed defect: fixed)

Opened 21 months ago

Last modified 19 months ago

windows 7 host network offline with 5.0.16 => Fixed in SVN

Reported by: mmcknc Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 5.0.16 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Hi guys,

I just upgraded to 5.0.16 from 5.0.14. The upgrade went smooth, but as soon as I tried to start a client machine (Windows 10), the network interface on the host went down. All connections were lost.

This halted the client vm from starting since it's on a network drive.

I tried this several times with the exact same behavior until I had to back down to 5.0.14. As soon as I backed down, the client vm started without issue.

Attachments

VBox.log Download (141.9 KB) - added by scottinaz 21 months ago.
VBox.log - host networking stopped after VM was started

Change History

comment:1 Changed 21 months ago by frank

Please attach a VBox.log file of a 5.0.16 VM session.

comment:2 Changed 21 months ago by frank

Cannot reproduce. Do you have any VBox.log file of a 5.0.16 VM session available?

comment:3 Changed 21 months ago by mmcknc

Unfortunately, no. We were in a rush to get things up and running again we didn't take time to capture any logs.

comment:4 Changed 21 months ago by frank

  • Priority changed from blocker to major

comment:5 Changed 21 months ago by scottinaz

I am seeing the same issue. The host networking seems to stop on 5.0.16 shortly after starting a VM. I tried disabling jumbo frames in the host NIC config and the network hasn't dropped. Could there be something wrong handling large MTUs? Attaching VBox.log created when the networking failed with 9 KB jumbo frames. The host and VMs work fine with 9 KB jumbo frames set running 5.0.14.

Changed 21 months ago by scottinaz

VBox.log - host networking stopped after VM was started

comment:6 Changed 21 months ago by frank

  • Priority changed from major to critical

comment:7 Changed 21 months ago by frank

scottinaz, your VBox.log file does not show any configured network device (neither E1000 nor PCnet). Is this the correct VBox.log file?

comment:8 follow-up: ↓ 10 Changed 21 months ago by scottinaz

frank, I have the VM network card set to virtio-net and it is using bridged adapter attached to the single NIC in the host. Setting the VM to E1000 or PCnet doesn't seem to make a difference.

I checked the windows system log and it is reporting this from NDIS:

The network interface "Intel(R) Ethernet Connection I217-V" has begun resetting. There will be a momentary disruption in network connectivity while the hardware resets. Reason: The network driver detected that its hardware has stopped responding to commands. This network interface has reset 5 time(s) since it was last initialized.

I upgraded the drivers on the host to "Intel(R) Network Connections Software Version 20.7" and am still seeing the same issue.

It seems the problem happens with the VM using the bridged adapter and jumbo packets enabled on the host NIC. There aren't any issues using the NAT adapter, but my NIC will reset if I change the VM settings to bridge adapter while it is running. I haven't seen any network problems with jumbo packets disabled.

Could it be related to this: https://www.virtualbox.org/ticket/15140?

comment:9 Changed 21 months ago by frank

Oh I see. I forgot the virtio-net device. Yes, my only guess is indeed that the problem must be related to #15140. We need to reproduce this problem...

comment:10 in reply to: ↑ 8 Changed 21 months ago by aleksey

Replying to scottinaz:

Could it be related to this: https://www.virtualbox.org/ticket/15140?

This is definitely a possibility. Could you try both build 105933 and build 105935? One of these drops jumbo packets over 2K (just like 5.0.14), while another disables dynamic re-allocation of buffer pool.

comment:11 Changed 21 months ago by scottinaz

Hi,

I am seeing the NIC reset the same way with 105933. I am not seeing the resets in 105935, but my VMs have no network connectivity with the bridged adapter. NAT adapter works fine and jumbo packets don't seem to make a difference. The card in the VM shows a link but doesn't actually get out, even with a static IP set.

comment:12 Changed 21 months ago by aleksey

Thanks a lot for testing! Could you try build 105969 and build 105971? They both should solve the issue, but they may differ in performance.

comment:13 Changed 21 months ago by scottinaz

The network seems to be fine on both builds with jumbo packets enabled. I'm not able to test performance that well but they seemed okay copying things over the network.

comment:14 follow-up: ↓ 15 Changed 21 months ago by kenterfie

My network settings broken after update from 5.0.14 -> 5.0.16. I cant uninstall the NDIS bridge. Also deactivate does not work. Im on Windows 10 x64. I think the update has changed some rights, because i get some errors which say i have not enough rights or are rights related. It happens directly after update. I have a backup from one day before without problems.

My Log  https://forums.virtualbox.org/download/file.php?id=20918

The problem is also discussed on  https://forums.virtualbox.org/viewtopic.php?f=1&t=76598

Small notice. I have tried both 5.0.17 builds above and nothing fixed the problem.

Last edited 21 months ago by kenterfie (previous) (diff)

comment:15 in reply to: ↑ 14 Changed 21 months ago by aleksey

Replying to kenterfie:

Small notice. I have tried both 5.0.17 builds above and nothing fixed the problem.

Your problem appears to be unrelated to jumbo frames, that's what both builds aim to fix (the difference being only in dynamic-vs-static allocation of buffers). Your problem seems to have more to do with driver installation. Could you run 'VBoxBugReport <vm_name>' and send the resulting archive to me at aleksey dot ilyushin at oracle dot com?

Last edited 21 months ago by aleksey (previous) (diff)

comment:16 Changed 20 months ago by aleksey

  • Summary changed from windows 7 host network offline with 5.0.16 to windows 7 host network offline with 5.0.16 => Fixed in SVN

comment:17 Changed 20 months ago by dbDesigner

I think we solved this!! Upgraded from 4.3.26 (stable) to version 5.0.16 on a Windows 7x64 Host. Guests using Bridged LAN adapters started frequently disconnecting from the Host LAN and we also could not ping the Host at times. As soon as we logged into a non-responsive Guest on the Host itself, the user could re-connect afterwards with Remote Desktop, but obviously users were not happy with frequent disconnects. We upgraded all Guest additions to latest version - No Luck. Upgraded Pro 1000 LAN Driver in XP Guests - No Luck.

Then we saw the driver for the onboard Intel(R) 82579LM Gigabit LAN on the Host was dated 2008, so we downloaded the latest driver from the Intel Site and installed it (Now Dated 2015/08/18 - Version 12.15.30.0). The driver could not be upgraded, so we uninstalled the old driver and installed the new driver. We rebooted the Host and restarted all VMs. After a week of hell with all users on our case, this week so far four days and all smooth running! Not using the NDIS driver as suggested by some. Also not using Jumbo frames.

comment:18 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.18.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use