VirtualBox

Ticket #1500 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Trying to start a saved vm with old version of the kernel module breaks it when next time starting with right version

Reported by: betelgeuse Owned by:
Priority: major Component: host support
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Using VirtualBox 1.6.0 on a Linux host.

Steps to reproduce:

  1. Accidentally boot into an old kernel with vboxdrv-1.5.7
  2. Try to restore a saved Vista VM
  3. Get a screen about the driver being too old
  4. Boo into the normal kernel
  5. Try to start the saved vm

Results:

Get a dialog saying Spawning session... and it's stuck at 0%

Change History

comment:1 Changed 6 years ago by frank

I cannot reproduce this here. But your problem might be (accidently) related to another locking problem we are currently working on.

comment:2 Changed 6 years ago by michiel

I have a similar problem, the "spawning session" being stuck at 0%, although in my case it's not caused by a kernel mixup.

frank, what is the locking issue you're referring to? Is it a ticket?

In my case, the saved session is actually restored but the VirtualBox window is stuck with the 0% modal dialog above it and stops responding to any input and requires killing.

Working on Linux Fedora 8.

comment:3 follow-up: ↓ 5 Changed 6 years ago by frank

  • Component changed from other to host support

comment:4 Changed 6 years ago by cnangel

some problem like this, i use windows xp that Get a dialog saying "Spawning session"... and it's 0% rate of progress

comment:5 in reply to: ↑ 3 Changed 6 years ago by clusty

Replying to frank: I got the same problem. A fix I observed is to start the VM with VBoxSDL, which seems to "unlock" the machine.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Works fine here, fixed some time ago.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use