VirtualBox

Ticket #14981 (closed defect: fixed)

Opened 15 months ago

Last modified 15 months ago

Failed to load unit 'hda' when restoring guest session

Reported by: jms Owned by: pentagonik
Priority: major Component: other
Version: VirtualBox 5.0.12 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

VirtualBox version: VirtualBox VM 5.0.12 r104815 linux.amd64 with latest guest additions installed (5.0.12) Host: LINUX_64BITS_UBUNTU_15_10, 32GB RAM Guest: Windows 10 64bit, 4GB RAM

When trying to restore guest session of Win10 a message window appears with following error message:

Failed to load unit 'hda' (VERR_SSM_LOADED_TOO_LITTLE).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I can start guest by discarding saved state and starting from beginning, but error will repeat every time when I try to restore. I think this started after update to 5.0.12 (from 5.0.10).

Attachments

VBox.log.zip Download (29.1 KB) - added by jms 15 months ago.
Guest log file
VBox.log Download (208.0 KB) - added by rafd 15 months ago.
Ubuntu guest failing to load saved state
VBox.2.log Download (104.5 KB) - added by rafd 15 months ago.
Windows 7 guest successfully loading saved state
VBox.log.2.zip Download (28.7 KB) - added by jms 15 months ago.
VBox_1st_after_login.txt Download (100.9 KB) - added by jms 15 months ago.
VBox_2nd_after_login.txt Download (176.3 KB) - added by jms 15 months ago.
VBox.3.log Download (173.7 KB) - added by jms 15 months ago.
Log file with version 5.0.13-104900
VBox.4.log Download (176.8 KB) - added by jms 15 months ago.
Log file with version 5.0.13-104913

Change History

Changed 15 months ago by jms

Guest log file

comment:1 Changed 15 months ago by devsk

I get the error during starting a saved Windows 10 VM but the error is (VERR_SSM_STRUCTURE_MAGIC) instead.

comment:2 Changed 15 months ago by rafd

I get the same error text, but with a different VERR reason:

Failed to load unit 'hda' (VERR_INVALID_PARAMETER).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Host is Gentoo Linux amd64, guest is Ubuntu Linux i386.

The guest was started last night, along with a Windows 7 guest; after saving the state of both VMs, I hibernated my machine as always. This morning I resumed the Ubuntu guest first, getting the error above; then I skeptically tried Windows 7, which surprisingly resumed just fine; so I tried once again Ubuntu, getting the same error.

Looking at the log I see also VERR_SSM_LOADED_TOO_MUCH after the first VERR_INVALID_PARAMETER.

I don’t know if this is relevant at all or not (“hda” makes me think of an issue with the first virtual IDE hd), but I see mentioned a screen resolution of 1152x769, while I set all my VMs to 1152x768. After discarding the saved state that I can’t load I’ll see if I really made the guest 1px taller than intended, or if this is an off-by-one error in VirtualBox.

Changed 15 months ago by rafd

Ubuntu guest failing to load saved state

Changed 15 months ago by rafd

Windows 7 guest successfully loading saved state

comment:3 Changed 15 months ago by rafd

I just confirmed that the guest screen resolution is correct; I really did inadvertently make it 1152x768.

I attached the logs for the two guests I resumed this morning; hopefully this will help you find any differences. Their configuration is fairly similar, though one is using KVM and the other Hyper-V acceleration, and the Windows 7 guest has over 5 times the amount of RAM of the Ubuntu guest (4 vs .75 GB).

The guests were both running last night when I suspended both, simultaneously.

I forgot to mention, I’m running 5.0.12 r104815, installed just a few days ago (upgraded from 4.3.x).

comment:4 Changed 15 months ago by pentagonik

The saved state handling should be fixed since r104839. Please give this test build a try:

https://www.virtualbox.org/download/testcase/VirtualBox-5.0.13-104845-Linux_amd64.run

comment:5 Changed 15 months ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

Changed 15 months ago by jms

comment:6 Changed 15 months ago by jms

I uninstalled 5.0.12 and installed that test build, I didn't update guest additions.

I still can't load saved Windows10 session, error message is same as in opening message. I attached new log file.

comment:7 Changed 15 months ago by frank

jms, are you able to reliable reproduce this error with the 5.0.13 test build? So far we try to reproduce but are not successful.

comment:8 Changed 15 months ago by jms

I tried again with 5.0.13 and I noticed that this issue could be related to state of guest.

Again I uninstalled 5.0.12 and installed 5.0.13, I can see in dmesg that 5.0.13 modules are loaded:

vboxdrv: Found 8 processor cores
vboxdrv: TSC mode is Invariant, tentative frequency 2691447265 Hz
vboxdrv: Successfully loaded version 5.0.13 (interface 0x00240000)
vboxpci: IOMMU not found (not registered)
vboxdrv: ffffffffc11d1020 VMMR0.r0
vboxdrv: ffffffffc071f020 VBoxDDR0.r0
vboxdrv: ffffffffc0015020 VBoxDD2R0.r0

I first started Windows10 guest session from scratch and saved session right after I logged in to my corporate account (VBox_1st_after_login.txt). I was able to start this saved session without any problem. Then after this saved session's login process proceeded further by starting all applications Skype for Business etc (all icons are visible at Windows notification area). I saved this "complete" session. This session was not able to start, error message is like following (VBox_2nd_after_login.txt):

Failed to load unit 'hda' (VERR_SSM_STRUCTURE_MAGIC).

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
ConsoleWrap
Interface: 
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

So for me it seems that the state of guest operating system could have an impact to this issue. I can not reproduce this with my Windows7 guest.

Last edited 15 months ago by jms (previous) (diff)

Changed 15 months ago by jms

Changed 15 months ago by jms

comment:9 Changed 15 months ago by pentagonik

Please try one of these newest build available here which should fix the issue.

(Frank: Better always update the testbuilds wiki page)

Last edited 15 months ago by frank (previous) (diff)

comment:10 Changed 15 months ago by jms

Unfortunately problem still exists in latest test build. I installed package VirtualBox-5.0.13-104900-Linux_amd64.run. Log file is attached. Error message copied from error dialog:

Failed to open a session for the virtual machine Win10.

Failed to load unit 'hda' (VERR_SSM_LOADED_TOO_LITTLE).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Changed 15 months ago by jms

Log file with version 5.0.13-104900

comment:11 Changed 15 months ago by pentagonik

Another testbuild 104913 is available here: https://www.virtualbox.org/wiki/Testbuilds

comment:12 Changed 15 months ago by jms

Problem exists with test build VirtualBox-5.0.13-104913-Linux_amd64.run too. This time error message was:

Failed to open a session for the virtual machine Win10.

Failed to load unit 'hda' (VERR_SSM_STRUCTURE_MAGIC).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Like before, I created saved session (which I tried to restore) using this same build 104913. Log file is attached.

Changed 15 months ago by jms

Log file with version 5.0.13-104913

comment:13 Changed 15 months ago by Tim T ASP

May be related to #15001.

comment:14 follow-up: ↓ 16 Changed 15 months ago by frank

Thanks for the additional logs. The latest test builds contain a fix which should finally fix this problem.

comment:15 follow-up: ↓ 18 Changed 15 months ago by jarvin

I disabled audio and then re-enabled again as per this forum advice to no avail until I switched Intel HD Audio over to ICH AC97, now the restoring the saved state works.

It is 100% reproducible on my Windows 10 host (Intel i7 machine, VBox 5.0.13 test build) for Fedora 23 64 bit and Ubuntu Gnome 15.10 64 bit, in both directions, meaning switching to Intel HD Audio gives errors on a state restore, and switching to ICH AC97 works okay on state restore.

So, this is just the Intel HD Audio driver issue!

comment:16 in reply to: ↑ 14 Changed 15 months ago by jms

Replying to frank:

Thanks for the additional logs. The latest test builds contain a fix which should finally fix this problem.

Latest test build (5.0.13-104993-Linux_amd64) fixes this issue, I can't reproduce the error any more. Thank you for your help.

comment:17 Changed 15 months ago by frank

jms, thank YOU for the extensive tests and providing several log files, that was VERY helpful!

comment:18 in reply to: ↑ 15 Changed 15 months ago by frank

Replying to jarvin:

I disabled audio and then re-enabled again as per this forum advice to no avail until I switched Intel HD Audio over to ICH AC97, now the restoring the saved state works.

It is 100% reproducible on my Windows 10 host (Intel i7 machine, VBox 5.0.13 test build) for Fedora 23 64 bit and Ubuntu Gnome 15.10 64 bit, in both directions, meaning switching to Intel HD Audio gives errors on a state restore, and switching to ICH AC97 works okay on state restore.

So, this is just the Intel HD Audio driver issue!

Which test build did you test? Please make sure to test 5.0.13 >= 104993!

comment:19 Changed 15 months ago by jarvin

Tested Intel HD Audio regarding the state restore against VBox 5.0.13.105046. It works!

Many thanks!

comment:20 Changed 15 months ago by pentagonik

  • Status changed from assigned to closed
  • Resolution set to fixed

Great, thanks for testing! Closing this defect.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use