VirtualBox

Ticket #14975 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

OSX guests: Audio output lost from 5.0.10 to 5.0.12

Reported by: socratis Owned by: pentagonik
Component: audio Version: VirtualBox 5.0.12
Keywords: Cc:
Guest type: OSX Server Host type: Mac OS X

Description

All of my OSX clients lost their audio output in the upgrade from 5.0.10 to 5.0.12. That includes, 10.5, .6, .7, .8, .9, .10 and .11 clients, which means everything under the radar.

Log comparison reveals nothing suspicious, except some log entries at the very, very end (after the "End of statistics"). I've included them just for kicks. They're from a 10.8 client, but they're all pretty much the same.

Comparison of the "system_profiler" output reveals nothing. Honestly. They're identical. I've not included them, it doesn't make sense.

Source code comparison between 5.0.10 and .12 reveals some pretty big changes in the Audio part of the tree (/src/VBox/Devices/Audio).

Attachments

VBox_logs-AudioProblem-5.0.12.zip Download (54.4 KB) - added by socratis 3 years ago.
VBox logs for 5.0.10 and 5.0.12
VBox.log.zip Download (22.8 KB) - added by lkj 3 years ago.
Mac10.9-VBox.log.zip Download (50.3 KB) - added by socratis 3 years ago.
With 5.0.14 it's even worse. It now freezes the whole VM! The VM has to be forced quit. Attached is the log files for 5.0.12 and 5.0.14 just for comparison. Client: OSX 10.9.5.
Screen Shot 2016-01-25 at 11.35.49 AM.png Download (64.0 KB) - added by lkj 3 years ago.

Change History

Changed 3 years ago by socratis

VBox logs for 5.0.10 and 5.0.12

Changed 3 years ago by lkj

comment:1 follow-up: ↓ 2 Changed 3 years ago by lkj

Added log for OSX 10.6.8 guest, OSX 10.11.2 host.

comment:2 in reply to: ↑ 1 Changed 3 years ago by socratis

Replying to lkj:

Added log for OSX 10.6.8 guest, OSX 10.11.2 host.

Thanks for the verification Lou...

comment:3 Changed 3 years ago by lkj

Anytime.

comment:4 Changed 3 years ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

comment:5 Changed 3 years ago by lkj

Just tested 5.0.13r104971 for a different problem. Audio is working at least for me on an OSX 10.6.8 guest but the sample rate/pitch is wrong.

comment:6 Changed 3 years ago by lkj

Audio is broken again with 5.0.13r105025

Changed 3 years ago by socratis

With 5.0.14 it's even worse. It now freezes the whole VM! The VM has to be forced quit. Attached is the log files for 5.0.12 and 5.0.14 just for comparison. Client: OSX 10.9.5.

comment:7 Changed 3 years ago by lkj

On my OSX 10.11.3 Host running VB 5.0.14, my OSX 10.6.8 guest does not freeze but it has no audio out. I have no doubt it does on socratis' hosts.

comment:8 Changed 3 years ago by pentagonik

Does the freeze only happen when running an OS X guest?

comment:9 follow-up: ↓ 10 Changed 3 years ago by pentagonik

And: What happens if you disable audio for that guest?

comment:10 in reply to: ↑ 9 Changed 3 years ago by socratis

Replying to pentagonik:

Does the freeze only happen when running an OS X guest? And: What happens if you disable audio for that guest?

So far it doesn't happen with Windows (*>98) guests, Ubuntu 12.04, Mint 17, Fedora 20, SciLinux 6.5, OS/2 4.5, only with OSX guests, all of OSX guests. It happens as soon as you go System Preferences, Sound, Input (count 2 seconds... freeze).

It does not happen if audio is disabled in the VM settings.

Oh, BTW, host is also 10.9.5, forgot that...

comment:11 Changed 3 years ago by pentagonik

Ok, thanks for the information. We'll try to reproduce that.

comment:12 Changed 3 years ago by pentagonik

Please give our latest test build a shot, which you can find here: https://www.virtualbox.org/wiki/Testbuilds

This should resolve the issue. The fix also will be included in our next upcoming maintenance release.

Thanks!

comment:13 follow-up: ↓ 17 Changed 3 years ago by lkj

the pitch is wrong. also, not sure if it's related but iTunes won't launch. OSX 10.11.3 host OSX 10.6.8 guest.

Last edited 3 years ago by lkj (previous) (diff)

comment:14 Changed 3 years ago by pentagonik

The pitch was correct with 5.0.10 though?

comment:15 Changed 3 years ago by lkj

i actually don't remember. It was wrong in previous version where audio was working but I don't remember which version. sorry. socratis may know.

comment:16 Changed 3 years ago by lkj

minor issue btw. the test builds are all labeled r105196 however the guest additions inside the package is labeled r105195. That made me download the separate GA .iso. Turns out, they are one and the same.

comment:17 in reply to: ↑ 13 Changed 3 years ago by socratis

Replying to pentagonik:

This should resolve the issue. The fix also will be included in our next upcoming maintenance release.

Yes, I can verify that it is fixed. There is a minor issue where the "input volume" is not taken into account, but that's a minor problem compared to the freeze. And it has never worked as intended as far as I can remember.

Replying to lkj:

the pitch is wrong. also, not sure if it's related but iTunes won't launch.

and pentagonik:

The pitch was correct with 5.0.10 though?

I tried going back to different versions, as back as 4.3.6 and the pitch has always been wrong. Sometimes you may get it right, but it's a rarity. For example, if you go to the most basic of tests, System Preferences, Sound, Sound Effects. Change the "Alert sound". If you click twice or more fast enough, the alert comes out OK. If there's a delay of more than about two seconds, the sound "cracks". This is NOT scientific or repeatable evidence...

BTW, iTunes launches fine. Tested on 10.6.8, 10.8.5 and 10.11.2 guests (I consider it a wide enough sample). I have a suspicion about this. Have you set your guest serial number to something other than "0"? But I guess that's not a discussion for this ticket...

comment:18 Changed 3 years ago by lkj

Actually I have never used a serial number in my 10.6.8 guest and iTunes has launched in the past. None the less I added the SN. from my current iMac but it made no difference.

I thought I remembered the pitch being correct sometime in the past but I could remember that incorrectly.

I'm uploading a screen from Console about the iTunes error since that is easiest for me.

Edit: I forgot to mention the fact that the pitch was always wrong isn't very comforting.

Last edited 3 years ago by lkj (previous) (diff)

Changed 3 years ago by lkj

comment:19 follow-ups: ↓ 20 ↓ 21 Changed 3 years ago by puddnhead7

I have an Kubuntu 14.04 Guest running on VirtualBox 5.0.14 OSX 10.10.5 host. The pitch issue, always higher, has been consistently present for the past several versions. I _think_ the problem started with 5.0.10, but would only manifest when coming out of powersave. Will try 5.0.15 test build.

comment:20 in reply to: ↑ 19 ; follow-up: ↓ 22 Changed 3 years ago by lkj

Replying to puddnhead7:

I have an Kubuntu 14.04 Guest running on VirtualBox 5.0.14 OSX 10.10.5 host. The pitch issue, always higher, has been consistently present for the past several versions. I _think_ the problem started with 5.0.10, but would only manifest when coming out of powersave. Will try 5.0.15 test build.

You realize your post has absolutely nothing to do with OSX guests on OSX Hosts losing audio???

comment:21 in reply to: ↑ 19 Changed 3 years ago by puddnhead7

Replying to puddnhead7:

I have an Kubuntu 14.04 Guest running on VirtualBox 5.0.14 OSX 10.10.5 host. The pitch issue, always higher, has been consistently present for the past several versions. I _think_ the problem started with 5.0.10, but would only manifest when coming out of powersave. Will try 5.0.15 test build.

The 5.0.15 test build didn't fix the pitch issue, but I found this which did fix it:  http://www.withoutthesarcasm.com/fixing-audio-in-linux-guests-virtualbox/ My guess is that the same issue (the AC97 driver polls clock speed and gets an inaccurate number) is behind the OSX guest pitch issues. Not sure how to fix on there.

comment:22 in reply to: ↑ 20 ; follow-up: ↓ 23 Changed 3 years ago by puddnhead7

Replying to lkj:

Replying to puddnhead7:

I have an Kubuntu 14.04 Guest running on VirtualBox 5.0.14 OSX 10.10.5 host. The pitch issue, always higher, has been consistently present for the past several versions. I _think_ the problem started with 5.0.10, but would only manifest when coming out of powersave. Will try 5.0.15 test build.

You realize your post has absolutely nothing to do with OSX guests on OSX Hosts losing audio???

You're right, it's not an exact match. There are three different problems under this thread:

  1. Guest OS hangs when sound is in use.
  2. Audio stops working in Guest OS.
  3. Audio works in Guest OS, but with a pitch shift.

There seems to be some correlation between the client version and all three of the problems, so they're likely related in _some_ way. In the case of my post, the symptom (incorrect pitch) is identical, the host OS's are identical (OSX) and while guest isn't OSX, it's unix based so it wouldn't be surprising if the guest sound drivers share significant code. More points of data = better ability to potentially understand the problem. The AC97 sound driver has pitch problems because it checks the CPU clock and gets a spurious answer. That seems a pretty good starting point to figure out why the same symptom happens to OSX guests running under the same host. It wouldn't be a shock if clock issues affected audio driver and/or system stability, ja?

comment:23 in reply to: ↑ 22 Changed 3 years ago by socratis

Replying to puddnhead7:

You're right, it's not an exact match. There are three different problems under this thread:

Hmm, actually no. It's not a thread (like in the forums), it's a bug report. A very specific bug report. With one problem reported.

  1. Guest OS hangs when sound is in use.

That didn't happen when the report was filed, only with a intermediate build afterwards, which again was fixed. And sound didn't even have to be used. Only access to the settings. Plus, I don't remember you mentioning that your guest hung.

  1. Audio stops working in Guest OS.

I hope that by "stops" you mean doesn't work at all, not that it works up to a point and then gives up.

  1. Audio works in Guest OS, but with a pitch shift.

The pitch in OSX guests is lower. Yours is higher. Not the same.

More points of data = better ability to potentially understand the problem.

Or add to the signal/noise ratio and steer you in a different direction, disorient the developers.

The AC97 sound driver has pitch problems

Well, that's part of the problem with your report. The OSX guests, for which the report was filed, does not use the AC97 driver, but the Intel one. Having sound problems is too generic of a symptom. I'm pretty sure it's not the same source. For example, this report can be closed with the test build available. Yours can't. I still haven't been bothered enough to search for an existing, pitch related, bug report, or open a new one.

Last edited 3 years ago by socratis (previous) (diff)

comment:24 Changed 3 years ago by frank

  • Status changed from assigned to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 5.0.16. This release contains several fixes for Mac OS X guests.

comment:25 Changed 3 years ago by lkj

FWIW, the pitch is still wrong in my OSX 10.6.8 guest which is the only OSX guest I have. Running OSX 10.11.3.

comment:26 Changed 3 years ago by frank

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:27 Changed 3 years ago by pentagonik

Does this still occur for you using VBox 5.0.22?

comment:28 Changed 3 years ago by socratis

Oops, I missed the notification on this one. I tried it with 5.0.26 this morning and it works OK-ish. The sound is working (input/output) but it's a little "cracked".

comment:29 Changed 3 years ago by socratis

Revisiting old bugs. I think this one should be marked as "closed"-"fixed", not "reopened".

comment:30 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use