VirtualBox

Ticket #14919 (new defect)

Opened 5 years ago

Polycom CX600 gets call from Computeraudio when starting VM with ICH AC97 controller

Reported by: Andy1971 Owned by:
Component: audio Version: VirtualBox 5.0.10
Keywords: Polycom CX600 audio Computeraudio AC97 HDA Cc:
Guest type: all Host type: Windows

Description

Since VirtualBox-5.0.2-102096 I have a strange behavior with my Polycom CX600 phone connected via USB to the my host system (Windows 7).

As soon as a VM is started and the VM BIOS is loading, the phone shows me silently a call to "Computeraudio". Every real call to my phone then only is knocking on like the phone is busy.

As soon I stop the VM, the "Computeraudio" call is interrupted and the phone works again like it should.

In VirtualBox-5.0.0-101573 and older versions everything works fine.

Every Version since VirtualBox-5.0.2-102096 have the same behavior, including the actual version VirtualBox-5.0.10-104061.

I tried a little bit around with some settings and found out that this doesn't happen when the audio controller is not set to "ICH AC97". Intel HD Audio and SoundBlaster 16 doesn't produce this behavior, but I get no sound out of my Linux guests with these two audio controllers (especially tested with Knoppix LiveDVD 7.6 for repeatable results).

Another check was what happen when I disconnect the phone USB cable from the host. When the guest was already started and the phone shows already the "Computeraudio" call, the call is interrupted as soon as I disconnect the USB cable. After connecting it again, the phone dosn't show the "Computeraudio" call again (until reboot the VM). When I disconnect the cable before starting the VM and plug it in after the VM was started, no "Computeraudio" call is shown. The phone works normally.

Because of this behavior starts before the guest OS is loading, I think this is independent of it. Nevertheless I checked out lsusb but there are no USB devices shown, except the input device and the USB root hubs.

I will attach four log files (for Version 5.0.0 and 5.0.2 one with ICH AC97 and one with Intel HD Audio controller). And if it works, also an picture of the phone screen.

Attachments

Logfiles_and_Picture.zip Download (146.7 KB) - added by Andy1971 5 years ago.
Logfiles and the picture of the phone

Change History

Changed 5 years ago by Andy1971

Logfiles and the picture of the phone

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use