VirtualBox

Ticket #14846 (new defect)

Opened 6 years ago

Last modified 3 years ago

VBoxManage Error about Machine XXX is not currently running and Machine XXX is really running in Windows Task Manager

Reported by: aZtk-laga Owned by:
Component: other Version: VirtualBox 5.0.10
Keywords: vboxmanage, machine not running, controlvm savestate, controlvm shutdown Cc:
Guest type: other Host type: Windows

Description

Hi, I'm trying to launch the command "vboxmanage controlvm XXX savestate" (or controlvm XXX poweroff) after to have been executed succesfully, about 15 or 20 minutes before <if you try to reproduce this issue I explain but starting the VM follow by shutting down inmediatly via commands curiosely it works fine..>, the command "vboxmanage startvm XXX --type headless" (as well as without headless modifier) from a Scheduled Task of Windows Task Scheduler. I'm involved whith this issue for several days, perhaps two weeks... I've tried all I know about it... It seems to be that transcurred some minutes from starting the machine, she (the machine) disappears from the runnig list machines as I can positively test: just now I have my three-VBoxHeadlexx processes plus one VBoxSVC process running on my Windows 7 x64, and if I run "vboxmanage list runningvms" I get no machines running message. So, when I try to run "vboxmanage controlvm XXX savestate" manually or through a Scheduled Task, I get a no running machine with that name in the first case, or a 0x01 code in the Windows Task Scheduler saying "the command-task finished but with warnings". Thanks for support and best regards.

Change History

comment:1 Changed 6 years ago by DanWM

I am seeing the same problem. I am starting a VM (guest OS is Debian) from Windows 10's Task Scheduler, using a task that runs using the same authentication that I am logged in as. The machine does start. However, I *never* see the machine listed by VBoxManage list runningvms, and cannot shut it down using VBoxManage from either an interactive command line or a scheduled task.

I have tried starting the VM using both VBoxHeadless and VBoxManage startvm --type headless. No difference that I can detect.

I did notice that VBoxSVC remains running while the VM is running. When running VBoxManage, a *second* instance of VBoxSVC runs briefly. From what I have read about the architecture, this may be the source of the problem - shouldn't VBoxManage be communicating with the already-running instance of VBoxSVC?

comment:2 Changed 5 years ago by Incanus

Same problem on Windows Server 2012 and VirtualBox 5.1.8r111374. Tried starting using both VBoxManage startvm myvm --type headless and VBoxHeadless -s myvm -v on. VM never appears in VBoxManage list runningvms listing and other VBoxManage commands like VBoxManage controlvm myvm acpipowerbutton return "Machine myvm is not currently running" error.

Edit: Just to clarify, the vm starts correctly, I've verified that by accessing page served by a webserver running on the vm. The problem is that I have no way to stop it correctly, since VBoxManage thinks it's not running.

Last edited 5 years ago by Incanus (previous) (diff)

comment:3 Changed 4 years ago by mcandre

I am seeing the "is not currently running" error presenting to command line applications while the guest is rebooting, causing scancodes to fail to send over VBoxManage, for Darwin guests.

In the future, could VirtualBox model rebooting state better, and wait for the guest to resume a running state before failing VBoxManage commands early?

comment:4 Changed 3 years ago by expert_vision

If anyone wants to start a VM with an USB device attached via Task Scheduler, it won't work. The VM will start but USB devices won't get attached. Toe make it work, put the command in in a batch file

VBoxManage.exe startvm OpenVPN --type headless

and add the batch file as an action to the Task Schedule.

Any future commands will still say the VM is not running, but at least the USB devices are attached.

Edit: Never mind. It doesn't work when you restart. It only works when you run the task manually from the Task Scheduler. Ugh

Last edited 3 years ago by expert_vision (previous) (diff)

comment:5 Changed 3 years ago by xariswon

I'm seeing this issue as well. I'm running a 64-bit Linux server guest on a Windows 10 Pro host. The virtual machine is started via VBoxManage as a process at boot (using NSSM). I currently have no other virtual machines running, but Task Manager still shows 3 instances of VBoxHeadless, along with one instance of VBoxSVC. My server appears to be running normally (my site is still accessible) but VBoxManager still reports that the VM is not running.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use