VirtualBox

Ticket #14831 (closed defect: fixed)

Opened 20 months ago

Last modified 16 months ago

cfgm dump running video in firefox after upgrading from 5.0.8 to 5.0.10

Reported by: ...don Owned by:
Priority: major Component: other
Version: VirtualBox 5.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

OpenSuse Linux host running kernel 3.17.2 Widows 10 guest AMD video card Upgraded from VirtualBox 5.0.8 to 5.0.10 System hangs viewing video files (i.e viewing news clip in Firefox) - appears to be a 100% cpu loop. Reverted to VirtualBox 5.0.8 and problem cleared up. Has happened to two different systems.

Attachments

VBox.log Download (305.2 KB) - added by ...don 20 months ago.
VBox log
VBox.zip Download (62.4 KB) - added by wouterk__ 18 months ago.
VBox.2.zip Download (72.8 KB) - added by ...don 17 months ago.

Change History

Changed 20 months ago by ...don

VBox log

comment:1 Changed 20 months ago by frank

Please attach the complete VBox.log file. Use zip or gz to compress it.

comment:2 Changed 18 months ago by wouterk__

I've been experiencing something similar:

A few months ago I upgraded VirtualBox from vs. 5.0.8 to 5.0.10. Since then, whenever any YouTube video starts in Flash Player in Pale Moon (a Firefox fork) in a Windows 7 guest, this guest crashes immediately (BSOD/Guru meditation).

Since the problem wasn't fixed in VirtualBox 5.0.12, I've now done some research to pinpoint the problem:

The crash occurs under the following circumstances:

  • Hardware: Asus M5A97 R2.0 motherboard + AMD FX-6350 CPU + Radeon HD 6450 GPU.
  • Host OS: Windows 7x64 SP1 (fully up-to-date)
  • VirtualBox: 5.0.10 and 5.0.12 (the versions of the guest additions and extension pack don't seem to matter)
  • Guest OS: Windows 7(x86/x64) SP1 (I've got several of these guests: some with, some without the infamous platform update KB 2670838: no difference)
  • Flash Player version: irrelevant. (I've tried 18.0.0.324, 20.0.0.267, and some really old ones (15-something etc.).)
  • Browser: Pale Moon 25.8.1(=latest version) and Firefox <=36.0.4.

I've tried to change various hardware-related settings in the guest, so far to no avail:

The log file I'm attaching (saying something about a "Guru Meditation") pertains to VBox 5.0.12 (with its own extension pack installed) + a Win7x64 guest + guest additions 5.0.12 + Flash Player 20.0.0.267 + Pale Moon 25.8.1 (brand-new profile, no further add-ons)+  https://www.youtube.com/watch?v=mqMrSROG0G0 .

Changed 18 months ago by wouterk__

comment:3 Changed 18 months ago by frank

Thanks for the VBox.log file. Could you try the following: Shut down your VM, then execute the

VBoxManage setextradata VM_NAME VBoxInternal/CPUM/IsaExts/AVX 0

and the start the VM as usual. Does this make any difference?

Oh, of course replace VM_NAME by the name of your VM.

Last edited 18 months ago by frank (previous) (diff)

comment:4 Changed 18 months ago by wouterk__

I did as you asked: I shut down the VM, ran VBoxManage (and verified that the change had got through to the ExtraData section of the vbox file), then restarted the VM and followed the same test procedure: No difference: same crash. Let me know if you need the VBox.log file of this crash too.

Changed 17 months ago by ...don

comment:5 Changed 17 months ago by ...don

Still an issue after upgrading to 5.0.14. Additional log file attached.

comment:6 Changed 17 months ago by frank

don, I see that you have the 5.0.10 Guest Additions installed. According to the log your guest triggers a triple fault which would lead to a reboot on a (non-virtualized) host. It also looks to me that your guest raises a 0x0000001E BSOD. This could happen inside the system but it could also happen inside the VirtualBox Guest Additions kernel driver. So, is there any improvement if you upgrade the Guest Additions from 5.0.10 to 5.0.14? If not, does it help if you disable 3D in the VM settings?

comment:7 Changed 17 months ago by wouterk__

It seems I've finally fixed my problem:

First of all I should mention that upgrading to VirtualBox 5.0.14 + Pale Moon 26.0.0 + Flash Player 20.0.0.286 did not fix the problem.

However, yesterday I came across this thread:  http://forum.palemoon.org/viewtopic.php?t=10875.
To summarize:
The last few days, "all" Pale Moon users have started experiencing serious problems with the YouTube site, due to a policy change by YouTube concerning user agent strings.
One solution is to replace Pale Moon 26.0.0's default user agent override for YouTube ("Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.9) Gecko/20100101 Goanna/2.0 Firefox/31.9 PaleMoon/26.0") with "Mozilla/5.0 (Windows NT 6.1; rv:2.0) Goanna/20160120 PaleMoon/26.0.0".

So I decided to test whether this change also fixes my problem, and indeed it does: the VM no longer crashes!

So I've now been able to upgrade my "production machine" to VirtualBox 5.0.14. (Previously I was stuck with 5.0.8, because the crashes didn't occur just on youtube.com itself, but also on any site embedding a YouTube clip, which was of course unworkable.)

I'm still not sure to what extent my crashes had the same cause as the OP's crashes.
One thing is certain though: VirtualBox 5.0.10 changed something that triggered my crashes, which might point to a more general problem.
So if you want to investigate this issue further, I'll be happy to assist in any way I can. But if you feel you've got better things to do, that's fine with me too.

comment:8 Changed 17 months ago by frank

Hard to say how to continue. It seems that your change prevents the crash inside the VM. It is still not clear if this is a VirtualBox bug at all because the guest raised a triple fault -- this happens if the operating system has a serious problem.

However, I'm still not sure if the original reporter had the same problem as he never attached the comple VBox.log file.

comment:9 Changed 17 months ago by wouterk__

I have to correct my previous post in one significant respect:
The new user agent string makes YouTube use HTML5 instead of Flash Player.
So it's only HTLM5 that goes well: when I force YouTube to use Flash Player (via  https://addons.mozilla.org/en-US/firefox/addon/youtube-flash-video-player/), the VM still crashes immediately.
Actually I'm quite happy about being able to ditch Flash Player (at least for YouTube), but this does mean that the problem with Flash Player still exists.

Incidentally, the original reporter did provide a complete log file, at least with his second post 10 days ago (that wasn't me!), and you even responded to that.

comment:10 Changed 17 months ago by wouterk__

Some more discoveries:

1.
I now understand why Flash Player only seemed to crash in Pale Moon (any version) and Firefox <=36.0.4, not in Firefox >=37.
It's very simple: by default Firefox >=37 doesn't actually use Flash Player, but HTML5 for YouTube.
But when I force the latest Firefox (44.0) to use Flash Player for YouTube (by means of the addon I mentioned before), there's an immediate crash as well.
So it's very simple: Flash Player crashes the VM, HTML5 doesn't, irrespective of which browser I'm using.

2.
Starting a Flash Player video doesn't just crash the VM on YouTube, but also on dailymotion.com and twitch.tv.
So this more or less absolves YouTube too.

All in all, the finger is pointing at Flash Player even more strongly now.
Perhaps VirtualBox 5.0.10 changed something that "pushes Flash Player over the edge", at least with my hardware and VM setup.
Still, I'm not sure if it's worth investigating further: Flash Player seems to be dying anyway - and for good reasons, it seems...

comment:11 Changed 16 months ago by frank

You said that the version of the VirtualBox Guest Additions doesn't matter. But as this problem was apparently introduced with VBox 5.0.10: Do you have the same problem if you run your guest with VBox 5.0.14 Guest Additions 5.0.8 installed?

comment:12 Changed 16 months ago by wouterk__

To answer your question, I've made some new tests:

Common test conditions:

  • No Extension Pack installed.
  • Latest Pale Moon (26.1.1).
  • Latest Flash Player (20.0.0.306).

Then, with Guest Additions 5.0.8 installed in the virtual machine, the version of VirtualBox itself determines what happens:
5.0.8: no crash
5.0.10: crash
5.0.14: crash

And if VirtualBox itself is 5.0.8, there are no crashes whatsoever, not even with Guest Additions 5.0.10 or 5.0.14.

So I stand by what I wrote earlier: VBox 5.0.10 itself (not its Guest Additions or Extension Pack) seems to have introduced something that is causing these crashes.

comment:13 Changed 16 months ago by frank

Thank you for these tests. Finally we are able to reproduce the problem. We are investigating...

comment:14 Changed 16 months ago by frank

We think we fixed the problem. Here is an openSUSE 13.2 package and the Windows package is part of the most recent test builds. Could you confirm that it works for you?

comment:15 Changed 16 months ago by wouterk__

Windows test build 5.0.15-105805 fixes my problem (with all the Guest Additions I've tested: 5.0.8, 5.0.14 and 5.0.15-105796).
So thanks very much for fixing this!

comment:16 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use