VirtualBox

Ticket #14578 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Unable to select network adaptor that has TCP/IP disabled. => Fixed in SVN

Reported by: p0rkjello Owned by:
Priority: major Component: network
Version: VirtualBox 5.0.4 Keywords:
Cc: Guest type: all
Host type: Windows

Description

I used a bridge connection to a physical adapter that has TCP/IP disabled. This allows me to use the adapter on the Guest exclusively.

Version 5.0.4 does not list the adapter if TCP/IP is disabled.

Change History

comment:1 Changed 2 years ago by p0rkjello

I used a bridge connection to a physical adapter that has TCP/IP disabled. This allows me to use the adapter on the Guest exclusively.

Version 5.0.4 does not list the adapter if TCP/IP is disabled. This has worked on all previous versions.

comment:2 Changed 2 years ago by vushakov

  • Component changed from other to network

comment:3 Changed 2 years ago by Zimonia

I have been able to replicate this problem Virtualbox 5.0.4

Once TCP/IP is disabled / removed from network adapter / network properties the device is no longer visible / available / listed in Virtualbox.

comment:4 Changed 2 years ago by LastWord

I confirm the same issue.

I have three physical network adaptors and for two of them in their properties TCP/IP is disabled (I need it to use three ISPs at the same time on the same PC).

And since I updated from 5.0.2 to 5.0.4, I no longer see the same two physical network adaptors in my guests' configurations.

Also my guests which use the two mentioned physical network adaptors halt during startup with error messages regarding the absence of the physical network adaptors with which they previously perfectly started before upgrade.

Version 5.0.6 did not fix this issue.

I downgraded back to version 5.0.2 to fix this for myself.

comment:5 Changed 2 years ago by jbhur

Version 5.0.6

Host - Windows 7 x64

Same behaviour noted. Host's physical network adapters are unavailable for guests' bridged network configurations unless TCP/IP is bound.

comment:6 Changed 2 years ago by knebelau

Same here for me and all colleagues on Versions greater than 5.0.2

comment:7 Changed 2 years ago by LastWord

No luck with version 5.0.8 either.

comment:8 Changed 2 years ago by VMTom

Hi, Same problem over here with 5.0.8 on Windows 10 host. (it is working fine on MAC OS X though)

comment:9 Changed 2 years ago by VBoxBugs

Same problem: adapter working on 5.0.2, not working on 5.0.4, 5.0.6, 5.0.8

comment:10 Changed 2 years ago by yaplej

Just upgraded to 5.0.8 and found this problem. It really stinks.

comment:11 Changed 2 years ago by t33wurst

Same here.... :( Waiting for a bugfix - trying 5.0.2 meanwhile...

comment:12 Changed 2 years ago by mannRi

Just noticed this ticket, I also have the same problem using 5.0.8 on Win7 x64. I'll try like some suggested to go back to 5.0.2. A fix would be highly appreciated.

comment:13 Changed 2 years ago by zpneun

Same here with 5.0.6 on Windows 10 host. As soon as I disable TCP/IP on host, the network adapter vanishes from bridged network's list of available Adapters.

comment:14 Changed 2 years ago by sdsmis

Still same problem with 5.0.10 on Windows 7 Pro x64 host, multiple guests. Using Intel 82567LM (built-in motherboard adapter) and Intel CT desktop adapter. Either adapter, when set to bridged mode, disappears after upgrading to any version beyond 5.0.2. NAT mode connections still work fine. Specific error message when trying to start a guest after upgrade: "Could not start the machine XYZ because the following physical network interfaces were not found: Intel(R) Gigabit CT Desktop Adapter (adapter 1) You can either change the machine's network settings or stop the machine."

comment:15 Changed 2 years ago by t33wurst

After upgrading "Windows 10" to "Windows 10 - Version 1511", Virtualbox 5.0.2 does not start anymore. Who can confirm this?

comment:16 Changed 2 years ago by likudio

I can confirm the issue as well. :(

/* Meanwhile I found a go-around:

  1. Enable TCP/IP to the Host adapter, connect to wireless network, get a host IP
  2. Select the WiFi Adapter as bridged.
  3. Start the guest machine, let the guest get an IP from the network.
  4. Go back in host, disable TCP/IPv4

(but when you restart/save the machine, it won't start again b/c it won't find the adapter anymore).

*/

Hope this will get fixed soon.

comment:17 follow-ups: ↓ 19 ↓ 20 ↓ 21 Changed 2 years ago by aleksey

Please try build 104375

comment:18 Changed 2 years ago by LastWord

Thank you, Aleksey. Build 104375 (with filename VirtualBox-5.0.51-104375-Win.exe) solved the issue with bridged networking for me.

comment:19 in reply to: ↑ 17 Changed 2 years ago by Todd

Replying to aleksey:

Yes, build 104375 fixes the missing bridged adapter issue where the adapter does not have TCP/IP bound in the host. Thanks Aleksey.

I can't use this version though, because networking performance is lower...I guess because it's a test-build.

Last edited 2 years ago by Todd (previous) (diff)

comment:20 in reply to: ↑ 17 Changed 2 years ago by Brettt

Replying to aleksey:

Please try build 104375

Confirming that this has resolved my issue also. Thanks for working on this over the weekend Aleksey.

comment:21 in reply to: ↑ 17 Changed 2 years ago by sdsmis

Replying to aleksey:

Please try build 104375

Nice! Confirmed, this has fixed the bridged adapter disappearing problem I have been having with all versions since 5.0.2. Thank you!

comment:22 Changed 2 years ago by GOSH

Build 104375 has fixed problem with PHYSICAL adapter, But I have same issue with OpenVPN TAP V9.21.1 under Windows 10 x64. Same thing on Windows XP x32... Even worse, on build 104375 TAP adapter is unvisible for VirtualBox in all cases. With TCP/IP configured as well.

Last edited 2 years ago by GOSH (previous) (diff)

comment:23 Changed 2 years ago by aleksey

GOSH,

It looks like you have "VirtualBox NDIS6 Bridged Networking Driver" disabled in OpenVPN TAP adapter properties. Try to enable it.

comment:24 Changed 2 years ago by GOSH

Aleksey,
I've double checked. The problem is exactly as I described it above.
I understand that presence of active "VirtualBox NDIS6 Bridged Networking Driver" should be a main trigger to make adapter "bridgeable" for VirtualBox. But it's not work.
Furthermore, on builds 104061 and 104456 the main trigger is presence of active TCPIP, despite on "VirtualBox NDIS6 Bridged Networking Driver".

Last edited 2 years ago by GOSH (previous) (diff)

comment:25 Changed 2 years ago by aleksey

GOSH, apparently OpenVPN TAP adapter didn't identify itself neither as physical nor as virtual device. Build 104644 provides a workaround. Please try it out.

comment:26 Changed 2 years ago by GOSH

Aleksey,
Build 104644 work like a charm! Thank you very much!

comment:27 Changed 2 years ago by aleksey

  • Summary changed from Unable to select network adaptor that has TCP/IP disabled. to Unable to select network adaptor that has TCP/IP disabled. => Fixed in SVN

comment:28 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use