VirtualBox

Ticket #14574 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

VirtualBox 5.0 not working on windows server core

Reported by: zarzarel Owned by:
Priority: major Component: other
Version: VirtualBox 5.0.4 Keywords:
Cc: Guest type: all
Host type: Windows

Description

Hello,

VirtualBox version 5.0 does not run on Windows server core, failing with VERR_MODULE_NOT_FOUND when starting VBoxHeadless.exe. The faulting module is VBoxDD.dll which tries to import dsound.dll which is not available on Windows Server Core installations. Providing a dsound.dll from a full windows installation fails from hardening checks (dsound.dll is not signed). Changing sound driver to none or null has no effect.

Change History

comment:1 Changed 2 years ago by frank

Thanks for the report. Could you check if the latest Windows test build (>= 102660) fixes your problem?

comment:2 Changed 2 years ago by zarzarel

Yes, the problem is fixed, VBoxHeadless runs again :)

Thanks.

comment:3 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use