VirtualBox

Ticket #14571 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

VBoxService writes a worng pid value in the pid file

Reported by: hykwok Owned by:
Priority: major Component: guest additions
Version: VirtualBox 5.0.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

VBoxService (/usr/sbin/VBoxService) writes a wrong pid value in the pid file (/var/run/vboxadd-service.pid) so the Linux system could not kill the service during shutdown or reboot. For example, when I uses "ps -ax" command, the pid of VBoxService is 1702 but the pid value in the file is 1698.

Attachments

vbox_error.png Download (20.3 KB) - added by hykwok 2 years ago.
Example of the pid value checking
vbox_505.png Download (22.1 KB) - added by hykwok 2 years ago.
Testing result for the latest 5.0 Additions test build (102651)

Change History

Changed 2 years ago by hykwok

Example of the pid value checking

comment:1 Changed 2 years ago by frank

Thanks for the report. This should be fixed in the latest 5.0 Additions test build (>= 102651) which you can find here. Could you confirm that?

Changed 2 years ago by hykwok

Testing result for the latest 5.0 Additions test build (102651)

comment:2 Changed 2 years ago by hykwok

I have tested the latest 5.0 Additions test build (102651) and the problem is fixed.

comment:3 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use