VirtualBox

Ticket #14563 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Symbolic links with `..` result in `protocol error` on vboxsf + 5.0.4

Reported by: scoates Owned by:
Component: shared folders Version: VirtualBox 5.0.4
Keywords: Cc: sean@…
Guest type: Linux Host type: Mac OS X

Description

When creating a symlink that contains .., we're seeing "protocol error" messages. For this example /vagrant is none on /vagrant type vboxsf (rw,nodev,relatime).

cd /vagrant ; mkdir test ; cd test ; ln -s ../Vagrantfile .
ln: failed to create symbolic link `./Vagrantfile': Protocol error

This also happens when linking .. and not into the root. It does not happen when linking .. outside of the vboxsf system. This happens for us on 5.0.4r102546 but not on 5.0.0r101573.

It may be related to the following:

https://www.virtualbox.org/ticket/14463

https://www.virtualbox.org/ticket/14153

Note: if the symlink is made on the host FS (and not created on the VM), it seems to behave normally/correctly.

Host for our tests is Mac OS X 10.10, guest is Debian Jessie.

Change History

comment:1 Changed 4 years ago by scoates

Also worth noting: I can successfully create symlinks on the vboxsf filesystem that do not contain ..

comment:2 Changed 4 years ago by cama900

Just wanted to add my voice to this. Took me hours to figure out the problem because it occurred by trying to run npm install, not just making symlinks

comment:3 Changed 4 years ago by scoates

FWIW, mine happened when doing an automated-at-provisioning git checkout (which happened to contain ../ symlinks).

comment:4 follow-up: ↓ 5 Changed 4 years ago by sunlover

Fixed in https://www.virtualbox.org/download/testcase/VirtualBox-5.0.5-102721-OSX.dmg

Please test whether this build it works for you. Thanks.

comment:5 in reply to: ↑ 4 Changed 4 years ago by frastel

Replying to sunlover:

Fixed in https://www.virtualbox.org/download/testcase/VirtualBox-5.0.5-102721-OSX.dmg

Please test whether this build it works for you. Thanks.

I had the same problem.

My setup:

  • VirtualBox Version 5.0.4
  • OS X 10.10.5
  • docker-machine version 0.4.1
  • Vagrant 1.7.4

Symlinks are working again with your posted 5.0.5 testversion. Looks good to me!

comment:6 Changed 4 years ago by scoates

Confirmed. Works for me on 5.0.5r102721. Thanks! Looking forward to 5.0.5-actual

comment:7 Changed 4 years ago by aleksandrvin

Works for me. Macbook Pro Mid 14, 10.10.5

comment:8 Changed 3 years ago by justink

Any timeline when 5.0.5 will be shipped? This bug is affecting us, we can't run npm install (because it uses relative symbolic links).

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

VBox 5.0.6 contains the fix.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use