VirtualBox

Ticket #1455 (new defect)

Opened 6 years ago

Last modified 17 months ago

VRDP Guest OS mouse doesn't track RDP client mouse

Reported by: krister Owned by:
Priority: minor Component: RDP
Version: VirtualBox 1.6.0 Keywords: VRDP mouse
Cc: Guest type: other
Host type: other

Description

Host OS: OpenSolaris Nevada 85 Guest OS: OpenSolaris Indiana RC2a

When connecting to VirtualBox using an RDP client the mouse in the guest OS isn't tracking the mouse of the machine where I run the RDP client. I tried this both on the host machine itself with rdesktop and connecting from a remote host. I see two mouse pointers, one black (the mouse pointer of the host running the RDP client) and one white (the mouse pointer of the guest OS). The guest OS mouse pointer is accelerated compared to the RDP client mouse pointer. By tweaking the mouse pointer acceleration setting in the guest OS slightly I managed to get the mouse to track better.

Change History

comment:1 Changed 6 years ago by sunlover

You have to install the Guest Additions for Indiana.

comment:2 Changed 6 years ago by frank

To explain this a little bit more: VirtualBox emulates a pointing device with relative mouse coordinates. To get the host mouse cursor in sync with the guest mouse cursor, the guest additions are required (for every guest you are trying to execute, not only for Solaris).

comment:3 Changed 6 years ago by frank

  • Component changed from other to RDP

comment:4 in reply to: ↑ description Changed 5 years ago by yamass

I Have the same problem although I've installed the guest additions successfully.

VBox Version: 2.0.4
Guest OS: Ubuntu 8.10
Host OS: Ubuntu 8.04 server

comment:5 Changed 5 years ago by brihuega

I have exactly the same behaviour with VirtualBox 2.1.0, even with Guest Additions. It's really annoying and it avoid me to work with VRDP. My host is ArchLinux and the guests are OpenSuse and ArchLinux (with and without Additions). I cannot track mouse cursor, connecting Linux rdesktop client or even from the Windows XP client. I tried to change screen sizes between the remote and local machines but don't work. Also tried to change mouse speed, but don't helps.

comment:6 Changed 5 years ago by SpecialAgent

Hi,

I have the solution to this problem. Install the guest additions in the same version as VirtualBox is running on the host and update your /etc/X11/xorg.conf with vbox drivers/settings and reboot/restart X-Server.

Here is an example:

Section "Device"
	Identifier	"Configured Video Device"
	Driver		"vboxvideo"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"vboxmouse"
	Option		"CorePointer"
EndSection 

Section "Screen"
	Identifier	"Default Screen"
	DefaultDepth	16
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

The mouse is running perfectly then, but the video output through RDP is rather slow and my keyboard (through RDP) has no PIPE symbol... that sucks a bit.

My host: Debian 5.0 Lenny My guest: Kubuntu 8.10 (with KDE 4.2) VBox: 2.1.4 (additions installed and running)

I hope that helped!

comment:7 Changed 5 years ago by brihuega

It has been solved on my openSUSE 11.1 after upgrading to VBox 2.1.4 and reinstall the guest additions. On previous releases it was not solved. It seems to be related to the mouse integration, that was working bad, and also is solved in this release.

comment:8 Changed 5 years ago by byoung

Same issue found in Both 3.0 and 3.0.2 with Fedora 11 Host and Mandiva 2009 guest. Latest guest editions were freshly installed, but did not resolve issue. xorg.conf appears to correctly configured for vbox. If it matters client was KRDC 4.2.4. The two mice track so bad that rdp is unusable....

comment:9 Changed 17 months ago by WT

This is still an issue as of 4.2 Really? This is 5 years old? This is a major issue for those of us who are not local the the machine.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use