VirtualBox

Ticket #1454 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Ubuntu Hardy freezes when starting a virtual machine -> fixed in SVN/1.6.2

Reported by: webwurst Owned by:
Priority: blocker Component: other
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I uninstalled the previous version of VirtualBox and installed version 1.6.0 (32bit) for Ubuntu Hardy. Installation seemed fine and i added my user to the vboxusers.

After starting a new created machine my ubuntu desktop freezes. No mouse movement or graphic updates in the cpu-monitor. only a reset works.

I turned off cdrom, disk, audio, network, serial, usb, shared, remote, but problem persists.

Attachments

VBox.log Download (26.5 KB) - added by ACMarina 6 years ago.
ACMarina's VBOX Log

Change History

comment:1 Changed 6 years ago by sandervl73

Have you enabled hardware acceleration? If so, try to disable it. Do you have a VBox log file that you can attach here? If not, what kind of cpu do you have?

comment:2 Changed 6 years ago by webwurst

Yes, hardware acceleration was enabled. I disabled it and then it worked fine.. But VirtualBox 1.5.x worked on this machine with hardware acceleration.

Cpu is: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz

comment:3 Changed 6 years ago by sandervl73

That's indeed strange. We'll need to investigate this.

comment:4 Changed 6 years ago by Milos_SD

I have the same problem on Ubuntu Hardy, Virtual Box 1.6.0 on Intel Core2Duo 6550 CPU. VT-x was working on 1.5.6. Please fix this ...

comment:5 Changed 6 years ago by cornbread

same issue hardy with amd processor. hardware used to work now doesn't.

comment:6 Changed 6 years ago by sandervl73

Do any of you have the KVM kernel module enabled by any chance?

comment:7 Changed 6 years ago by webwurst

Yes, that's it. Kvm-module was loaded. But VirtualBox gave no error.. The previous Version checked that and gave a message.

$ sudo rmmod kvm_intel $ sudo rmmod kvm

-> After that you can use hardware acceleration.

comment:8 Changed 6 years ago by sandervl73

That's strange. With a 32 bits Linux host it shouldn't really matter. I fixed the KVM check yesterday for 64 bits hosts. Did you enable the PAE option in your VM config?

comment:9 Changed 6 years ago by kaspernielsen

Maybe it is the general Ubuntu Hardy freeze problem that a lot of people is seeing.  http://ubuntuforums.org/showthread.php?t=765510

comment:10 Changed 6 years ago by karolbe

The same here on Ubuntu Hardy with Intel T7200 CPU. 1.5.6_OSE works fine with VT-x, the 1.6.0 version always crashes. KVM with VT-x worked fine. I admit that I have kvm module loaded, but nevertheless it shouldn't crash like this.

comment:11 Changed 6 years ago by sandervl73

  • Summary changed from Ubuntu Hardy freezes when starting a virtual machine to Ubuntu Hardy freezes when starting a virtual machine -> fixed in SVN/1.6.2

It will crash like this because KVM and VirtualBox can't coexist.

comment:12 follow-up: ↓ 13 Changed 6 years ago by ACMarina

I'm running Hardy and have the same problem. Any time I start a virtual machine it's only a matter of time until I get a full system freeze, and the only way out is the power button. No KVM, no dual core, and Hardy runs just fine if I don't start a virtual machine..

comment:13 in reply to: ↑ 12 Changed 6 years ago by sandervl73

Replying to ACMarina:

I'm running Hardy and have the same problem. Any time I start a virtual machine it's only a matter of time until I get a full system freeze, and the only way out is the power button. No KVM, no dual core, and Hardy runs just fine if I don't start a virtual machine..

Could you provide some more information? Is this a regression or have you never used another version of VBox before? Attach your VBox log to the defect please.

comment:14 Changed 6 years ago by ACMarina

Which log file would you like for me to attach? The install log?

comment:15 Changed 6 years ago by sandervl73

This one: ~/VirtualBox/vm_name/Logs/VBox.log

Changed 6 years ago by ACMarina

ACMarina's VBOX Log

comment:16 Changed 6 years ago by ACMarina

Well, I found that if I disabled ACPI it worked for about 12 hours, and then it froze again for no reason..

Anything?

comment:17 Changed 6 years ago by frank

Any logfile available from the freeze?

comment:18 Changed 6 years ago by ACMarina

No different from the one I've already attached. Whatever is happening is freezing everything, so it's not getting a chance to write it to the log..

comment:19 follow-up: ↓ 22 Changed 6 years ago by philo

Just for information : I have also the same problem with Fedora 8 :

Linux 2.6.24.5-85.fc8 #1 SMP Sat Apr 19 12:39:34 EDT 2008 i686 i686 i386 GNU/Linux.

It works only if i disable VT-x option. The computer is a Dell Inspiron 9400 Core Duo (first generation) with a SATA disk

It works with the 1.5.7 version of VirtualBox. I have also the kvm intel module. The computer hangs very earlier in the boot phase of the guest.

I try 'Bactrack 2' and 'Fedora 9 preview' with the same result.

comment:20 Changed 6 years ago by philo

Sorry, but in my precedent message, i would write that it works with 1.5.7 and VT-x enable. With 1.6.0 and VT-x enable, the PC freezes.

Regards

comment:21 Changed 6 years ago by ACMarina

VT-x is disabled in my case, and I don't have a dual-core processor so that's a no-go as well..

comment:22 in reply to: ↑ 19 Changed 6 years ago by sandervl73

Replying to philo:

It works only if i disable VT-x option. The computer is a Dell Inspiron 9400 Core Duo (first generation) with a SATA disk

It works with the 1.5.7 version of VirtualBox. I have also the kvm intel module. The computer hangs very earlier in the boot phase of the guest.

So did you disable the KVM module? In 1.6.0 you absolutely need to do that, because the check for its presence is broken.

comment:23 Changed 6 years ago by ACMarina

No KVM module for me!

comment:24 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use