VirtualBox

Ticket #14532 (new defect)

Opened 7 years ago

Last modified 7 years ago

Cannot access webcam over getUserMedia()

Reported by: Michael Heuberger Owned by:
Component: USB Version: VirtualBox 5.0.2
Keywords: webcam Cc:
Guest type: Windows Host type: Linux

Description

When booting Windows 10 with the latest Edge within Virtual Box 5.0.2 from Ubuntu 15.04 I cannot access the Webcam within Edge.

Beware, it works fine when the website uses a Flash plugin. There the webcam shows up. But NOT when it's being loaded through the getUserMedia() API. It's a native Javascript function most modern browsers implement.

I have the drivers installed. Let me repeat: it works fine through Flash, but not via JavaScript. Can you please look at it? This is blocking the development of www.videomail.io where I need to test it for the latest Edge.

Many thanks!

Change History

comment:1 Changed 7 years ago by sunlover

Please attach VBox.log of the VM where you tried to access the webcam via getUserMedia. Also a testcase which shows the problem is required.

Without these two items it is unlikely that someone will looks at this issue.

comment:2 Changed 7 years ago by tomtomtom

Hello, we are also facing the same problem, using ubuntu through virtualbox. the camera works in cheese, but when opening the website which has the "getusermedia", no camera is seen (the browser, though, does request a permission to use the camera)

did you manage to solve it? did anyone else faced the same problem?

Thanks! Tomer

comment:3 Changed 7 years ago by frank

tomtomtom, please see comment 1. As long as you don't provide the requested information you will not get help.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use