VirtualBox

Ticket #14531 (closed defect: fixed)

Opened 2 years ago

Last modified 23 months ago

VirtualBox 4.3.30 GURU_MEDITATION with Kernel 4.2.0

Reported by: MikeGreene Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.3.30 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I compiled kernel version 4.2.0 (Gentoo) and recompiled VB modules. When starting my Windows 32 bit VM I get Guru Mediation and when starting Windows 10 64 bit VM it locks up host system. I dropped back to using kernel 4.1.6 and do not have the problem.

Attachments

VBox.log.1 Download (223.2 KB) - added by MikeGreene 2 years ago.
VB Log of Windows 7 VM
config_4.1.6 Download (93.0 KB) - added by MikeGreene 2 years ago.
kernel 4.1.6 config file
config_4.2.0 Download (94.9 KB) - added by MikeGreene 2 years ago.
kernel 4.2.0 config file
patch_vbox_4.3_linux_4.2 Download (881 bytes) - added by frank 2 years ago.
Fix for VBox 4.3.30 on Linux 4.2 kernels
VBox.log_with_patch Download (217.0 KB) - added by MikeGreene 2 years ago.
Log with patch
VBox.log.3_with_patch Download (67.3 KB) - added by MikeGreene 2 years ago.
Log with patch, lock up of host system

Change History

Changed 2 years ago by MikeGreene

VB Log of Windows 7 VM

comment:1 follow-ups: ↓ 2 ↓ 4 Changed 2 years ago by frank

Cannot reproduce on Linux 4.2 vanilla with VBox 4.3.31. Could you attach the kernel configuration of your Linux 4.1.6 kernel as well as the configuration of your 4.2.0 kernel?

Changed 2 years ago by MikeGreene

kernel 4.1.6 config file

Changed 2 years ago by MikeGreene

kernel 4.2.0 config file

comment:2 in reply to: ↑ 1 Changed 2 years ago by MikeGreene

Replying to frank:

Cannot reproduce on Linux 4.2 vanilla with VBox 4.3.31. Could you attach the kernel configuration of your Linux 4.1.6 kernel as well as the configuration of your 4.2.0 kernel?

I attached both.

comment:3 Changed 2 years ago by MikeGreene

Where do I find the current 4.3.31 source to try?

comment:4 in reply to: ↑ 1 Changed 2 years ago by MikeGreene

Replying to frank:

Cannot reproduce on Linux 4.2 vanilla with VBox 4.3.31. Could you attach the kernel configuration of your Linux 4.1.6 kernel as well as the configuration of your 4.2.0 kernel?

Where do I get the 4.3.31 source?

Changed 2 years ago by frank

Fix for VBox 4.3.30 on Linux 4.2 kernels

comment:5 Changed 2 years ago by frank

Sorry, the next official 4.3.x release will be 4.3.32. But I've attached a patch which should fix your problem. Make sure to patch the file in your host kernel driver, then recompile the host kernel driver and you should be able to start your VMs.

comment:6 Changed 2 years ago by MikeGreene

I installed patch and recompiled, but have same problem. I have attached VBox.log_with_patch and VBox.log.3_with_patch. VBox.log.3_with_patch was a hard lockup of the host system.

Changed 2 years ago by MikeGreene

Log with patch

Changed 2 years ago by MikeGreene

Log with patch, lock up of host system

comment:7 Changed 2 years ago by frank

Are you 100% sure that you patched your host kernel modules in /usr/src/vboxhost-4.3.30/vboxdrv/r0drv/linux/threadctxhooks-r0drv-linux.c and that you re-compiled and re-loaded the modules after the change? Please check manually that you really touched this file and that your compiled vboxdrv.ko module is from today. It's very unlikely that this patch does not help.

comment:8 Changed 2 years ago by MikeGreene

I will check, it is probably my oversight.

comment:9 Changed 2 years ago by MikeGreene

Yes it works! Sorry, portage did not automatically install the modules patch. However, patch manually and all is well.

Thanks!

comment:10 Changed 23 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use