VirtualBox

Ticket #14490 (closed defect: obsolete)

Opened 7 years ago

Last modified 2 years ago

Add support for HFS+ / GPT to UEFI

Reported by: Edward Owned by:
Component: EFI Version: VirtualBox 5.0.2
Keywords: Cc:
Guest type: OSX Server Host type: Mac OS X

Description

Tried two different dmg images both in UDZO format. In VirtualBox 4, UEFI could read up HFS+ partition as device FS0, FS1 etc. Now VirtualBox 5 only shows BLK0 and BLK1. Thus OS X installation image no longer works.

The first one is an OS X BaseSystem.dmg.

     start      size  index  contents
         0         1         PMBR
         1         1         Pri GPT header
         2        32         Pri GPT table
        34         6         
        40  16367352      1  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  16367392   1627983         
  17995375        32         Sec GPT table
  17995407         1         Sec GPT header

The second disk is in the new installation format created by Apple's "createinstallmedia" command line tool.

     start      size  index  contents
         0         1         PMBR
         1         1         Pri GPT header
         2        32         Pri GPT table
        34         6         
        40    409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
    409640  20299696      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  20709336    262151         
  20971487        32         Sec GPT table
  20971519         1         Sec GPT header

Attachments

VBox.log Download (96.1 KB) - added by Edward 7 years ago.

Change History

Changed 7 years ago by Edward

comment:1 Changed 7 years ago by Edward

Did the same test and it didn't work on VirtualBox 4 as well.

I figured out the problem is that VirtualBox seems only support reading "HFS+" on "MBR Partition Table" in UEFI. Apple is dropping MBR in El Capitan installation image, even the BaseSystem.dmg which was always MBR has been upgraded to GPT. Thus, it's no longer recognized.

Should I open a new ticket to request the feature of "HFS+ on GPT in UEFI" and close this one?

Last edited 7 years ago by Edward (previous) (diff)

comment:2 follow-up: ↓ 3 Changed 7 years ago by frank

  • Summary changed from HFS+ Partitions in dmg no longer recognized by UEFI in VirtualBox 5 to Add support for HFS+ / GPT to UEFI

Not necessary. I've changed the bug summary.

comment:3 in reply to: ↑ 2 Changed 7 years ago by Edward

Replying to frank:

Not necessary. I've changed the bug summary.

Also, this seems to be weird. After I finished the Yosemite Guest installation, the installation on virtual HDD is HFS+ / GPT and it works. So, for some reason HFS+ / GPT on CDROM does not work.

comment:4 Changed 6 years ago by RoteAdler

The problem is beyond UEFI, image files with GPT are not recognized when mounted from the host via Devices menu. GPT is the default for new image files in recent Macs, so support would be welcome.

There is no problem when GPT images are open from the guest, so they may be open with a copy or through a shared folder. But not within UEFI at first glance.

Anyway, "Add support for HFS+ / GPT" would be a more accurate summary.

comment:5 Changed 6 years ago by RoteAdler

Disk images created with hdiutil or Disk Utility must be mounted on a device with block size of 512 bytes. VBox DVD drive has 2048 block size, and GPT depends on the block size, so images like those listed in the first message dont work.

I think this is more a OSX issue than VBox's. I really don't understand how such images can work if burned in a DVD. Anyway the 2048 block size is deeply hard-coded in DevAHCI.cpp, there are comments like "@todo this size is not always correct" but what can VBox do if OSX allows to create DVD masters with GPT and a 512 block size layout?

Maybe UEFI has some way to mount the image on a 512 bytes block device? If not, the image can be conveted to APM with hdiutil create -layout SPUD and asr restore.

I have rearranged one image layout to 2048 bytes with a hex editor and the thing goes fine within UEFI and when mounted as DVD, so definitely VBox supports HFS+ / GPT. But not those created by OSX.

comment:6 Changed 2 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Closing as obsolete, our EFI has HFS+ support and the recent 6.1 release of VirtualBox improved macOS guest support.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use