VirtualBox

Ticket #1448 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Seamless: menu outside normal application window not visible -> fixed in 3.0.6

Reported by: nielsslot Owned by:
Priority: minor Component: GUI/seamless
Version: VirtualBox 1.6.0 Keywords: seamless mode linux guest
Cc: Guest type: Linux
Host type: Windows

Description

With a Windows Vista host running the latest Kubuntu (Hardy) in seamless mode the right click menu from the KDE panel is not completely visible. The menu is only drawn on top of the panel. The part of the menu that should normally appear above the desktop (or any other running application) is not visible.

Using the menubar on another application, like Konsole, can also result in the menu not being displayed correctly. It disappears when it should be drawn outside the application window rectangle.

Steps to reproduce:

  • Install Virtualbox 1.6 on a Windows Vista host
  • Install Kubuntu Hardy 8.04 in a virtual machine
  • Install Guest additions
  • Go to seamless mode
  • Right click on the KDE panel (task bar)

Attachments

screenshot-kde-panel-virtualbox.png Download (14.9 KB) - added by nielsslot 6 years ago.
Screenshot of the KDE panel right click menu not showing up completely.

Change History

comment:1 Changed 6 years ago by frank

Did you try VirtualBox 1.5.6 before and was there a difference? Just want to find out if this is a regression or not.

comment:2 Changed 6 years ago by sandervl73

I couldn't reproduce this with Ubuntu Hardy. Maybe Kubuntu does something different.

comment:3 Changed 6 years ago by frank

(Sorry for this stupid question, forgot that there was no seamless mode in 1.5.6...)

Changed 6 years ago by nielsslot

Screenshot of the KDE panel right click menu not showing up completely.

comment:4 Changed 6 years ago by frank

  • Guest type changed from other to Linux

comment:5 Changed 6 years ago by frank

  • Component changed from other to GUI/seamless

comment:6 Changed 5 years ago by frank

  • Host type changed from other to Windows
  • Summary changed from Linux guest in seamless mode, menu outside normal application window not visible to Seamless: menu outside normal application window not visible

comment:7 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Seamless: menu outside normal application window not visible to Seamless: menu outside normal application window not visible -> fixed in 3.0.6

This should be fixed now.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use