VirtualBox

Ticket #14476 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

3D acceleration broken all guests since VB 5.0.2 OSX

Reported by: lkj Owned by:
Priority: major Component: 3D support
Version: VirtualBox 5.0.2 Keywords:
Cc: Guest type: all
Host type: Mac OS X

Description

Since the release of VB 5.0.2 3D acceleration is broken for all guests on different Macs. I'm sending the vbox.log for the Late 2012 iMac running OSX 10.11 Beta 6. The GPU is NVIDIA GeForce GTX 680MX 2048 MB

Attachments

VBox.log Download (128.5 KB) - added by lkj 2 years ago.
Ubuntu 14.04.3
vbox.log Download (168.9 KB) - added by lkj 2 years ago.
new log
VBox.2.log Download (114.9 KB) - added by lkj 2 years ago.
test-2015-08-19-11-44-33.log Download (119.8 KB) - added by lkj 2 years ago.
Xorg.0.log Download (26.0 KB) - added by buggerbunny 2 years ago.
Xorg.0.log / Host: OSX 10.11 PB3 / Guest: Mint 17.2
Logs-Win7-64-OpenGLcrash.zip Download (111.3 KB) - added by AnrDaemon 2 years ago.
Desktop composition glitches and OpenGL call crash
VBox.3.log Download (70.8 KB) - added by math_programmer 2 years ago.
VB 5.0.2 GA 5.0.2 OS X host, Mint 17 guest

Change History

Changed 2 years ago by lkj

Ubuntu 14.04.3

comment:1 Changed 2 years ago by aeichner

Your log shows that the OpenGL service is not loaded, are you sure 3D is enabled for this VM?

comment:2 Changed 2 years ago by lkj

Sorry, I turned it off since it wasn't working. I'll upload a new log.

Changed 2 years ago by lkj

new log

comment:3 Changed 2 years ago by lkj

The new log is from my Mid 2013 MacBook Air. Intel HD Graphics 5000 1536 MB

Changed 2 years ago by lkj

comment:4 Changed 2 years ago by lkj

I resent the first log with 3D enabled.

Last edited 2 years ago by lkj (previous) (diff)

comment:5 Changed 2 years ago by aeichner

We know what is wrong, thanks for the new logs. We are working on a fix right now.

comment:6 Changed 2 years ago by lkj

Glad to help. I was just about to send a vbox.log from my 2015 MacBook. Now I don't have to. :)

Last edited 2 years ago by lkj (previous) (diff)

comment:7 Changed 2 years ago by aeichner

comment:8 Changed 2 years ago by lkj

No dice. Ubuntu boots to a black screen with 3D enabled on both OSX 10.11 and 10.10.5.

I ran glxinfo on my Linux Mint 17.2 and Ubuntu guests and get an error message…

libGL error: core dri or dri2 extension not found
libGL error: failed to load driver: vboxvideo

It should tell me if Gallium or Chromium is running.

comment:9 Changed 2 years ago by aeichner

Can you upload the VBox.log, the Xorg.log and output form dmesg from the guest?

comment:10 Changed 2 years ago by lkj

Well, seeing I can't get past the black screen I would need to disable 3D to see the xorg.log to send and the dmesg output. Is that ok?

comment:11 Changed 2 years ago by lkj

Just some further info. I have a OpenSUSE 13.2 guest. It was fine. I updated the guest and it was still fine. I installed the test build GAs and now it boots to a black screen as well.

comment:12 Changed 2 years ago by aeichner

You should be able to switch to a textmode terminal using <Host>+F<N> to log in and copy the Xorg.log somewhere. Or you could try to use the backup Xorg.log which is created before the a new one is created. It should end with .old. You have to make sure though that it really is the one from a run with 3D enabled because only the log from the previous run is backed up.

comment:13 Changed 2 years ago by aeichner

Can you try to revert to the previously installed guest additions to see if this fixes the issue?

comment:14 Changed 2 years ago by lkj

I'll see what I can do. I have to run for a bit. I don't think it's the GAs however because I hadn't updated them yet in either Ubuntu 14.0.4 or 15.04 when I got the black screens. Once I did update them they were still black.

Just curious, are you using new guest installs for the test builds or were they pre-existing guests?

comment:15 Changed 2 years ago by aeichner

Can you at least upload the VBox.log for now? Maybe it reveals some information. I didn't try it with Linux guests yet because I don't have one handy (don't do any 3D work normally), only a Windows guest where I was able to reproduce the issue and verified that the fix worked.

Changed 2 years ago by lkj

comment:16 Changed 2 years ago by lkj

added.

Changed 2 years ago by buggerbunny

Xorg.0.log / Host: OSX 10.11 PB3 / Guest: Mint 17.2

comment:17 Changed 2 years ago by buggerbunny

Xorg.0.log added.

Display goes blank on login but screensaver shows up as usual. Login back in from the screensaver and the display goes blank again.

Edit: VirtualBox 5.0.3 r102220-OSX with GE 5.0.3 r102211

Last edited 2 years ago by buggerbunny (previous) (diff)

comment:18 Changed 2 years ago by lkj

Since Windows guests were brought up I thought I would mention with this test build and previous builds, my Windows 7 guest starts and gets to the Welcome screen, then looks like it's frozen, but the sound alert when Windows gets to the desktop plays and if I click on the screen the desktop shows up and Aero is working.

Windows 8.1 starts fine and if one waits long enough it will eventually show the welcome although you can click on it sooner, just like Windows 7, and get to the login screen.

Windows 10 gets to the desktop but if you try and launch a Metro app like settings it will either close or not fully draw. Disabling 3D fixes that.

Last edited 2 years ago by lkj (previous) (diff)

comment:19 Changed 2 years ago by socratis

Just to add my experience as well, I saw that 5.0.2 broke 3D with Mint 17, regardless of what GAs were installed ( https://forums.virtualbox.org/viewtopic.php?f=1&t=69560#p331807).

  • With the 5.0.3 build and 5.0.2 GAs, it works.
  • With 5.0.3 GAs, I see a black screen (preview icon works, dock icon doesn't work).

I have snapshot of the 5.0.2 VM so I can test things if you like, but the bottom line is that 5.0.3 works, just not with the corresponding GAs.

Host: MBP 17" early 2011, 10.9.5, AMD Radeon HD 6750M.

comment:20 Changed 2 years ago by lkj

I can verify socratis' results. Running Linux guests in the 5.0.3 test build but with the 5.0.2 GAs seems to work. Tried Ubuntu 14.04.3, 15.04 and LM 17.2 Cinnamon on an OSX 10.10.5 host.

Ubuntu 14.04.3 also works on an OSX 10.11 host.

Last edited 2 years ago by lkj (previous) (diff)

comment:21 Changed 2 years ago by aeichner

Thanks for the additional information, much appreciated!

comment:22 follow-ups: ↓ 23 ↓ 28 Changed 2 years ago by AnrDaemon

Windows 7/64 host/guest

3D enabled

After installing 5.0.2 guest additions, the guest system is not usable anymore.

Desktop compositions doesn't work correctly, half the elements doesn't render until you mouse over them.

Intermittent black screens on account selection/UAC prompt/Ctrl+Alt+Del screen.

Black screens after starting OpenGL apps. Even if application doesn't run in fullscreen by the very nature of it.

When OpenGL app try to call some of the more intricate functions, VM promptly crashes.

Changed 2 years ago by AnrDaemon

Desktop composition glitches and OpenGL call crash

comment:23 in reply to: ↑ 22 Changed 2 years ago by lkj

Replying to AnrDaemon:

Windows 7/64 host/guest

This ticket is for OSX hosts.

Last edited 2 years ago by lkj (previous) (diff)

comment:24 Changed 2 years ago by AnrDaemon

Great. Except the sympthoms are awfully familiar.

Changed 2 years ago by math_programmer

VB 5.0.2 GA 5.0.2 OS X host, Mint 17 guest

comment:25 Changed 2 years ago by math_programmer

With VirtualBox 5.0.2, GA 5.0.2, OS X host (15" MBP, 2015), Mint is "running in software rendering mode" and the graphics are painfully slow. Otherwise, it works. I'm not experiencing any black screens. I attached vbox.log.

Please tell me if you need any other log files, or for me to try alternate builds.

comment:26 Changed 2 years ago by lkj

Fixed in VB 5.0.3 r102322

Note: some guests with 3D enabled on OSX 10.11 developer preview boot to a black or what looks like a frozen screen. Clicking on the screen brings up the desktop or log in screen.

Last edited 2 years ago by lkj (previous) (diff)

comment:27 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.4.

comment:28 in reply to: ↑ 22 Changed 2 years ago by DreamPiggy

Replying to AnrDaemon:

Windows 7/64 host/guest

3D enabled

After installing 5.0.2 guest additions, the guest system is not usable anymore.

Desktop compositions doesn't work correctly, half the elements doesn't render until you mouse over them.

Intermittent black screens on account selection/UAC prompt/Ctrl+Alt+Del screen.

Black screens after starting OpenGL apps. Even if application doesn't run in fullscreen by the very nature of it.

When OpenGL app try to call some of the more intricate functions, VM promptly crashes.

Look that this bug has come after 5.0.0 version...Look at this:https://www.virtualbox.org/ticket/14592

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use