VirtualBox

Ticket #14361 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

No sound with any guest on Windows 10 host (after upgrade from Win 7)

Reported by: gmace11 Owned by:
Component: audio Version: VirtualBox 5.0.0
Keywords: no sound Cc:
Guest type: Linux Host type: Windows

Description

VMs that were working correctly before no longer play sound when VB 5.0 is running on a Windows 10 Host.

I have tried both Lubuntu 14.04 and Windows 7 guests with the same results. Tried different audio settings combinations Host Driver: Windows DirectSound and Controller: ICH AC97 (was what I had before and was working for Lubuntu guest and Win 7 host) as well as Intel HD Audio.

When using ICH AC97 on Lubuntu, the visible symptom is that any application that plays audio seems to actually block on the audio component (a player will actually not show any progress in terms of elapsed time).

Looking at the VB longs I see two types of events that seem relevant (attaching full log):

00:00:20.777046 DSound: create capture buffer E_FAIL 00:00:26.406320 DSound: playback start E_ACCESSDENIED

I tried to enable more verbose logging by setting VBOX_RELEASE_LOG to +dev_audio.e.f.l2 but did not get any additional Dsound log lines.

I've also tried older versions of VirtualBox 4.3.30 but no luck.

Attachments

win10_host_lubuntu1404_guest.log Download (114.8 KB) - added by gmace11 5 years ago.
Log
win7.log Download (95.2 KB) - added by noname1 5 years ago.

Change History

Changed 5 years ago by gmace11

Log

comment:1 Changed 5 years ago by jaqob

I have the same problem after upgrading to Windows 10.

comment:2 Changed 5 years ago by oferdavidi

The same history of the Host here just the guests are different. The log indicate the same: 00:00:02.501036 DSound: create capture buffer E_FAIL 00:00:02.505646 DSound: DirectSound capture is currently unavailable

comment:3 follow-up: ↓ 4 Changed 5 years ago by oferdavidi

Just to add one note that could be important, my PC is running after the upgrade DirectX Version 12

Last edited 5 years ago by oferdavidi (previous) (diff)

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 11 Changed 5 years ago by gmace11

Oferdavidi, are you saying that you got sound to work after upgrading directX on the Win10 host to v12? I have 11.1 running which is what comes with the upgrade. If the upgrade helped resolve the issues for you, do you have a pointer to upgrade instructions? I could not find anything that looks reliable.

comment:5 Changed 5 years ago by leeb

I have the same problem also on freshly installed Solaris Guests of solaris 11.2 and 11.3 beta.

If anyone as a workaround or fix please post here.

comment:6 Changed 5 years ago by leeb

Just to add to the note above on an solaris 11 guest with gnome 2.30 (default) with gnome window manager sound enabled, the guest will become unresponsive shortly after login. The reason being that open of the gnome application is making a sound (login sound - or something) and pulseaudio hang and does not recover. You can reproduce this simply with /usr/bin/play /usr/demo/SOUND/sounds/chirp.au - here we hang on any interaction with /dev/dsp. Solaris 11 guests are unusable with audio enabled no matter what combination of audio setting from VB from the GUI.

Workaround is to disable audio from VB at least guest is usable again.

comment:7 follow-up: ↓ 9 Changed 5 years ago by dbunkerd

I have the same problem as described in original bug report. Tried revision 101957 but still no sound in, for example, Linux Mint 17.2 guest. Disabling sound in host setting helps. I guess we just have to be patient and wait for the full Windows 10 support.

comment:8 Changed 5 years ago by dbunkerd

I forgot to mention that I upgraded from Windows 8.1 to Windows 10 and installed so-called "SR 1" (Cumulative Update for Windows 10 for x64-based Systems (KB3081424)) this morning. No changes in regards to the sound problem.

comment:9 in reply to: ↑ 7 Changed 5 years ago by jaqob

Replying to dbunkerd:

I have the same problem as described in original bug report. Tried revision 101957 but still no sound in, for example, Linux Mint 17.2 guest. Disabling sound in host setting helps. I guess we just have to be patient and wait for the full Windows 10 support.

I would say that they already support Windows 10.

The 5.0 release supports the latest guest or host operating systems including: Mac OS X Yosemite, '''Windows 10''', Oracle Linux, Oracle Solaris, other Linux operating systems, and legacy operating systems.

 https://www.oracle.com/corporate/pressrelease/oracle-vm-virtualbox-5-070915.html

comment:10 Changed 5 years ago by frank

Windows 10 will be definitely supported with 5.0.x but version 5.0.0 does unfortunately not. See also the message at the download page.

comment:11 in reply to: ↑ 4 Changed 5 years ago by oferdavidi

Replying to gmace11:

Oferdavidi, are you saying that you got sound to work after upgrading directX on the Win10 host to v12? I have 11.1 running which is what comes with the upgrade. If the upgrade helped resolve the issues for you, do you have a pointer to upgrade instructions? I could not find anything that looks reliable.

Sound stop working after Windows 10 upgrade, that brought with it DirectX 12. Followed the same step seen in the original bug report, but it didn't change the no sound phenomena in host. Inside my guests, Windows/ Linux, I can see that sound is working. The log of VirtualBox indicate "DSound: create capture buffer E_FAIL". Looks like the upgrade version of Windows 10 brought features, the VirtualBox was not ready for, but I'm sure they will prevail again, keep the good work coming team!

comment:12 follow-ups: ↓ 14 ↓ 17 Changed 5 years ago by gmace11

I think I have found a workaround for this issue.

1) Start Virtual Box

2) Start your guest VM

3) BEFORE attempting to play sound from the guest, start an application that engages the audio device on the Win 10 host (I use a youtube video)

4) While audio is playing on the host, attempt to play audio from the guest.

The audio from the guest should start playing as well. At this point, you can stop the audio from the host which is no longer necessary. This seems to fix the issue until VirtualBox is shut down. You can even reboot or shutdown your guests.

I have been able to successfully do this with VB 5.0 as well as 5.0.1 (test build 101957)

Hope this helps and works for everyone

Last edited 5 years ago by gmace11 (previous) (diff)

comment:13 Changed 5 years ago by lkj

Works for me. Thanks.

comment:14 in reply to: ↑ 12 Changed 5 years ago by dbunkerd

Replying to gmace11:

I think I have found a workaround for this issue.

[...]

Thanks a lot. Your workaround works indeed. Used test build 101957.

comment:15 Changed 5 years ago by p060477

@ gmace11 :

Fine! it works for me too..BUT only if i do not close the youtube on my host if i paused it i'm able to shut and re start the guest having sound if i close the youtube on host then when i re start the guest the issue reappairs.. this with EVERY test builds..from 10.19.02 to the latest 10.19.57 win 10 home 64bits as host win xp sp3 pro ed as guest hope this helps the VB dev

comment:16 Changed 5 years ago by p060477

to be clear the trick is usefull also with VB 5-0-0 official stable vers so up to now the test builds did not really solve the issues with win 10 as host..

comment:17 in reply to: ↑ 12 Changed 5 years ago by oferdavidi

Replying to gmace11:

I think I have found a workaround for this issue.

Works for me too, I just mute the host, if you don't mind ;) Thnx for the great workaround!

comment:18 Changed 5 years ago by gmace11

The sound issue appears to be fixed in the latest test build 5.0.1 (102010).

Huge thank you to the dev team!

comment:19 follow-ups: ↓ 20 ↓ 22 Changed 5 years ago by frank

Can more users confirm that the latest test build fixes the sound issue and no workaround is required?

comment:20 in reply to: ↑ 19 Changed 5 years ago by dbunkerd

Replying to frank:

Can more users confirm that the latest test build fixes the sound issue and no workaround is required?

No unfortunately I cannot confirm this. I have the same sound-issue with the latest test build 5.0.1 (102010). I even uninstalled the old one and re-installed 102010 just to make sure.

comment:21 Changed 5 years ago by giusi

@Frank :

i confirm dbunkerd's post here:

also for me : win 10 64 bit host , upgrade from win 8.1, win xp guest

any of the test builds have solved also the very latest

only the useful workaround found here

Last edited 5 years ago by giusi (previous) (diff)

comment:22 in reply to: ↑ 19 Changed 5 years ago by oferdavidi

Replying to frank:

Can more users confirm that the latest test build fixes the sound issue and no workaround is required?

I came here after installing 5.0.1 that didn't solve the sound issue, but the great workaround did :)

comment:23 Changed 5 years ago by giusi

Just to underline that we have to do ALWAYS this workaround i mean that EVERY time we reboot then we have to do this workaround AGAIN

comment:24 Changed 5 years ago by Universe

Same bug after upgrading from Win 7 pro to Windows 10. VB: Version 5.0.1r102010, Host: Windows 10 64bit, Guest: Window 7 Pro 64bit Workaround provided by gmace11 was successful. Sound restored, however now experiencing sound delays and crackling - thus impacting guest. Placing this comment to track bug/fix.

comment:25 follow-up: ↓ 26 Changed 5 years ago by ddixuike

Audio bug is fixed on my host. No workarounds needed. (5.0.2 r102096)

comment:26 in reply to: ↑ 25 Changed 5 years ago by dbunkerd

Replying to ddixuike:

Audio bug is fixed on my host. No workarounds needed. (5.0.2 r102096)

Confirmed. 5.0.2 r102096 fixes this bug. Thanks to all devs for the great work.

comment:27 Changed 5 years ago by frank

Thanks for the confirmation!

comment:28 Changed 5 years ago by giusi

Hi!

win 10 home ed 64 bit host win xp sp3 pro guest

with new 5.0.2 the sound issue is SOLVED for me!! thxs so much really indeed! BUT the network -bridged- still not.. same frustrating behaviour to not able to choose my net adapter if i choose -bridge- i have - no way- to select any.. and i've also unistalled and reinstalled the most update driver for my realtek: Realtek PCIe GBE Family Controller driver 10.1.505.2015 mobo:  http://www.gigabyte.com/products/product-page.aspx?pid=4955#dl

any ideas..? have i to set something..? if yes what and moreover -how-...??

so much thxs indeed for all of you !!

cheers!!

:)

Last edited 5 years ago by giusi (previous) (diff)

comment:29 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:30 Changed 5 years ago by oferdavidi

For me 5.0.2 did the needed fix. All guest OS ( Linux and Windows) have their sound pass to host. Many thanks for the VirtualBox team for yet another well done job!

comment:31 Changed 5 years ago by noname1

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have the same problem in 5.0.8 -- "CreateCaptureBuffer E_FAIL" and "Playback start E_ACCESSDENIED" in logs. After switching between audio controllers and restarting the VM several times it starts to work sometimes, but after another reboot it stops to work again. Host: Windows 7 Guest: Arch Linux

Changed 5 years ago by noname1

comment:32 Changed 5 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to fixed

noname1, this ticket is about Windows 10 host and the original problem has been fixed.

Please create a new ticket and attach a new log with enabled debug logging:

  • start the VM
  • execute on the host:

VBoxManage debugvm arch log --release "+drv_host_audio.e.l2"

  • try to play some sound in the guest.

VBox.log will contain a bit more information about audio output.

comment:33 Changed 5 years ago by noname1

https://www.virtualbox.org/ticket/14747

I don't see any additional information in the logs after running that debugvm command, though.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use