VirtualBox

Ticket #14252 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Shared Folder Issue [FIXED IN SVN]

Reported by: cmccarron Owned by:
Priority: major Component: shared folders
Version: VirtualBox 5.0.0 Keywords: Share Folders
Cc: Guest type: Windows
Host type: Windows

Description

Environment

Host: Windows 7 64bit Virtual Machine: Windows 7 32bit

It seems that something is wrong with Shared Folder mapping/access. The previous version (4.3.28) would allow me to share both network drives and local drives to the virtual machine. I can map both local and network drives from the host computer but when I try to access a shared folder mapped to a network drive I get the following error: "F:\ is not available The parameter is incorrect.". Access shared folders mapped to host local drives/folders seems to be working fine.

F:\ is a Host Network drive mapped to a Windows Domain Controller H:\ is a Host Local drive Z:\ is a Host Network drive mapped to a Windows Domain Controller

If more information is needed, logs etc, please let me know what you need and I will provide it.

Thanks VirtualBox Team for all the hard work on this software.

Attachments

RC3 Error1.JPG Download (20.4 KB) - added by cmccarron 2 years ago.
Error Message when access Shared Folder mapped to Host Network Drive
RC3 Info4.JPG Download (31.3 KB) - added by cmccarron 2 years ago.
Windows XP Guest Error
RC3 Info1.JPG Download (26.1 KB) - added by cmccarron 2 years ago.
VM Mapped Shared Folders
RC3 Info2.JPG Download (18.2 KB) - added by cmccarron 2 years ago.
VM Shared Folder Settings
RC3 Info3.JPG Download (31.3 KB) - added by cmccarron 2 years ago.
Host Drive Mapping
VBox.log Download (103.6 KB) - added by cmccarron 2 years ago.
Windows 7 Log File
VBox XP.log Download (97.4 KB) - added by cmccarron 2 years ago.
Windows XP Guest Log File
Win7 Rockwell.vbox Download (28.3 KB) - added by cmccarron 2 years ago.
Virtual Machine Config File
RC3 Info5.JPG Download (69.0 KB) - added by cmccarron 2 years ago.
Error trying to Access via vboxsvr
GuestLogfile.7z Download (63.4 KB) - added by cmccarron 2 years ago.
Guest Procmon Log access F:\
GuestLogfile2.7z Download (74.4 KB) - added by cmccarron 2 years ago.
Guest Procmon Log access using vboxsvr\Projects
Procmon.7z Download (140.7 KB) - added by cmccarron 2 years ago.
Updated Host Procmon Log File
VB_4328_Logfile.7z Download (280.9 KB) - added by cmccarron 2 years ago.
ProcMon from v4.3.28 (successfull)
VB_4330_Logfile.7z Download (230.0 KB) - added by cmccarron 2 years ago.
ProcMon from v4.3.30 (successfull)
VB_501_Logfile.7z Download (482.8 KB) - added by cmccarron 2 years ago.
Procmon from v5.0.1-101732
VB_501-101738_Logfile.7z Download (451.3 KB) - added by cmccarron 2 years ago.
Procmon from v5.0.1-101738
RC3 Info6.JPG Download (84.2 KB) - added by cmccarron 2 years ago.
Z: drive on host
RC3 Info7.JPG Download (59.4 KB) - added by cmccarron 2 years ago.
Z: drive on guest
VB_501-101738_Logfile_2.7z Download (114.5 KB) - added by cmccarron 2 years ago.
Procmon from v5.0.1-101738 Browsing Z: Drive

Change History

Changed 2 years ago by cmccarron

Error Message when access Shared Folder mapped to Host Network Drive

Changed 2 years ago by cmccarron

Windows XP Guest Error

Changed 2 years ago by cmccarron

VM Mapped Shared Folders

Changed 2 years ago by cmccarron

VM Shared Folder Settings

Changed 2 years ago by cmccarron

Host Drive Mapping

Changed 2 years ago by cmccarron

Windows 7 Log File

Changed 2 years ago by cmccarron

Windows XP Guest Log File

comment:1 Changed 2 years ago by cmccarron

This problem also effects my Windows XP Guest and has been an issue in both Windows 7 and XP since 5.0 Beta.

Last edited 2 years ago by cmccarron (previous) (diff)

comment:2 Changed 2 years ago by frank

  • Priority changed from blocker to major

comment:3 Changed 2 years ago by sunlover

I did some tests and can not reproduce the problem with VirtualBox 5.0.0, i.e. the Windows 32 guest can access shared folder mapped to a host network drive.

I wonder what is different in your setup. Do you run VirtualBox as admin or as a regular user on the host?

Maybe you could get a procmon log on the host?

 https://technet.microsoft.com/en-us/library/bb896645.aspx

Filter can be set to "Path contains F:\" (where f: is the _host_ drive mapped to the domain controller). Then the guest should access the corresponding shared folder to reproduce the problem. The procmon log will contain all accesses to the host drive and result codes. Maybe this will help to find out what is wrong.

comment:4 Changed 2 years ago by cmccarron

I am running Virtualbox as a user that is part of the Administrator group. I am not having this problem with VirtualBox 4.3.28.

Thanks for your help.

Changed 2 years ago by cmccarron

Virtual Machine Config File

comment:5 Changed 2 years ago by cmccarron

I disconnected the F: and Z: drive then browsed using
vboxsvr and received the following error.

Changed 2 years ago by cmccarron

Error trying to Access via
vboxsvr

comment:6 Changed 2 years ago by cmccarron

When I ran ProcMon on the host I did not get any results. So I ran it on the guest and got a result. It is attached.

Changed 2 years ago by cmccarron

Guest Procmon Log access F:\

Changed 2 years ago by cmccarron

Guest Procmon Log access using
vboxsvr\Projects

comment:7 Changed 2 years ago by sunlover

Unfortunately the procmon log does not contain any accesses to any host paths. Could you please retry:

  • start the VM where you get the error;
  • start elevated procmon on the host ("Run as administrator")
  • Open Filter/Filter.. menu in procmon
  • in the dialog remove all conditions
  • then add a new condition: "Path" "contains" "F:\" then "Include"

of course if F:\ is not the host drive letter mapped to the domain controller, then replace F:\ with correct drive letter

  • click 'Add' and 'OK'
  • in the guest try to access the corresponding shared folder (where the host drive F: is mapped) to reproduce the problem
  • make sure that procmon shows some events related to F:
  • attach the new procmon file

Thanks.

comment:8 Changed 2 years ago by cmccarron

Did you look at GuestLogfile.7z and GuestLogfile2.7z? They were generated on the Guest and do have some entries in it. Working on creating a new host procmon log file on the host.

Last edited 2 years ago by cmccarron (previous) (diff)

comment:9 Changed 2 years ago by cmccarron

Ok, I added a filter where the path contains ElecWorkfile and got some results. I have updated the Procmon.7z log file.

Changed 2 years ago by cmccarron

Updated Host Procmon Log File

comment:10 follow-up: ↓ 14 Changed 2 years ago by sunlover

Thanks for the updated procmon host log. It shows the "incorrect parameter" error. However it is still not clear why the error occurs.

Would it be possible for you to get similar procmon logs for VBox 4.3.28 and 4.3.30?

comment:11 Changed 2 years ago by rastakajakwanna

I ran into the same issue but using Vagrant ( ticket what pointed me here)

Last edited 2 years ago by rastakajakwanna (previous) (diff)

comment:12 Changed 2 years ago by cmccarron

Yes, sorry for the delay, I am out of town. I can provide Procmon for 4.3.28 and 4.3.30. I will try to get them uploaded before Sunday.

comment:13 Changed 2 years ago by cmccarron

Attached is the Procmon log file from v4.3.28. It was captured using a VPN connection but I was able to successfully browse the F: drive which is a network drive on the host.

Changed 2 years ago by cmccarron

ProcMon from v4.3.28 (successfull)

Changed 2 years ago by cmccarron

ProcMon from v4.3.30 (successfull)

comment:14 in reply to: ↑ 10 Changed 2 years ago by cmccarron

Replying to sunlover:

Thanks for the updated procmon host log. It shows the "incorrect parameter" error. However it is still not clear why the error occurs.

Would it be possible for you to get similar procmon logs for VBox 4.3.28 and 4.3.30?

Done

comment:15 Changed 2 years ago by sunlover

Thanks. I'll compare these logs. Unfortunately I still could not reproduce the problem.

comment:16 Changed 2 years ago by sunlover

comment:17 Changed 2 years ago by bird

I've reproduced and (hopefully) fixed the issue now. It only happens if the server directory we're trying to list contains a lot of files and is a windows server (samba shows no such issues). (The buffer size of the NtQueryDirectoryInformation call had to be reduced to 64KB or less for it to work. Seems the server side of things return larger buffers and handles it in a non obvious way. No trouble if the directory only contains a handful of files.)

Could you please try the following build and report back whether it fixes the problem?

https://www.virtualbox.org/download/testcase/VirtualBox-5.0.1-101738-Win.exe

comment:18 Changed 2 years ago by cmccarron

I just tried build 5.0.1-101732 and it worked. I have uploaded a log file for that version. I will download 101738 and try that one right now. Thanks for your help in fixing this issue.

Changed 2 years ago by cmccarron

Procmon from v5.0.1-101732

comment:19 Changed 2 years ago by cmccarron

Build 5.0.1-101738 also works. ProcMon log file is attached.

Thank you.

Changed 2 years ago by cmccarron

Procmon from v5.0.1-101738

comment:20 follow-up: ↓ 22 Changed 2 years ago by bird

  • Summary changed from Shared Folder Issue to Shared Folder Issue [FIXED IN SVN]

Great! Thanks for testing!!

comment:21 Changed 2 years ago by cmccarron

Ok there appears to still be something wrong. While it is working, when I try to view another drive attached to the root share (
elecworkfile) from the domain controller I get 0 results.

If I map the Z: drive to a folder, such as
elecworkfile\Software, I can get results.

Last edited 2 years ago by cmccarron (previous) (diff)

Changed 2 years ago by cmccarron

Z: drive on host

Changed 2 years ago by cmccarron

Z: drive on guest

Changed 2 years ago by cmccarron

Procmon from v5.0.1-101738 Browsing Z: Drive

comment:22 in reply to: ↑ 20 Changed 2 years ago by cmccarron

Replying to bird:

Great! Thanks for testing!!

There is still something wrong. It does not show any files or folders if you are mapped to a root share. If I am sharing
elecworkfile from the server and map Z: to
elecworkfile when you open z: you get no results. If I map F: to
elecworkfile\projects, I can see all files and folders.

Thanks

comment:23 Changed 2 years ago by bird

Yeah, definitely something wrong. But it seems to depend on the server side. I've redone the fix and I think this time it will work for all servers. Here's a new testbuild:

https://www.virtualbox.org/download/testcase/VirtualBox-5.0.1-101771-Win.exe

comment:24 Changed 2 years ago by cmccarron

Everything seems to be working now.

Thank you!

comment:25 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use