VirtualBox

Ticket #14219 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Vbox removes devices to early

Reported by: Megachip Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.28 Keywords:
Cc: Guest type: all
Host type: Mac OS X

Description

Every time, I'm changing settings of the box while running, it throws out mounted devices (usb, sata etc.).

OSX immediately taken these devices and remount them on host device, so the box will crash cause it has no access to the devices anymore.

Same happens pushing the close button (after what the interface ask for shutdown, pause or power off). Devices will be ejected and can't remounted if I cancel the dialog.

Happens on 5.0.0 RC1 too.

Attachments

vbox.log Download (163.7 KB) - added by Megachip 2 years ago.
Crash after inserting guest additions
Windows 10-2015-07-13.log Download (150.8 KB) - added by Megachip 2 years ago.
Crash after inserting guest additions

Change History

comment:1 Changed 2 years ago by aeichner

Please upload a VBox.log from the affected VM, the VBox version the log is from doesn't matter.

Changed 2 years ago by Megachip

Crash after inserting guest additions

comment:2 Changed 2 years ago by Megachip

Possible it matches https://www.virtualbox.org/ticket/9975 too. It did not matter if it is sata, ide or usb.

comment:3 Changed 2 years ago by Megachip

This bug is really nasty. Occurred in 5.0.0 too.

Inserting guest additions iso into VirtualBox and it crashed.

00:54:14.765440 Changing the VM state from 'RUNNING' to 'SUSPENDING'
00:54:14.828985 PDMR3Suspend: 63 331 385 ns run time
00:54:14.828999 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'
00:54:14.835276 File system of '/Applications/VirtualBox.app/Contents/MacOS/VBoxGuestAdditions.iso' (DVD) is hfs
00:54:14.839863 DrvBlock: Flushes will be ignored
00:54:14.839869 DrvBlock: Async flushes will be passed to the disk
00:54:14.840188 VD: Opening the disk took 32812 ns
00:54:14.840201 PIIX3 ATA: LUN#0: CD/DVD, total number of sectors 28614, passthrough disabled
00:54:14.840206 ************************* CFGM dump *************************
00:54:14.840207 [/Devices/piix3ide/0/LUN#0/] (level 0)
00:54:14.840209   Driver <string>  = "Block" (cb=6)
00:54:14.840210 
00:54:14.840210 [/Devices/piix3ide/0/LUN#0/AttachedDriver/] (level 1)
00:54:14.840211   Driver <string>  = "VD" (cb=3)
00:54:14.840212 
00:54:14.840212 [/Devices/piix3ide/0/LUN#0/AttachedDriver/Config/] (level 2) (restricted root)
00:54:14.840213   Format   <string>  = "RAW" (cb=4)
00:54:14.840214   Path     <string>  = "/Applications/VirtualBox.app/Contents/MacOS/VBoxGuestAdditions.iso" (cb=67)
00:54:14.840215   ReadOnly <integer> = 0x0000000000000001 (1)
00:54:14.840216   Type     <string>  = "DVD" (cb=4)
00:54:14.840217 
00:54:14.840217 [/Devices/piix3ide/0/LUN#0/AttachedDriver/Config/Plugins/] (level 3)
00:54:14.840218 
00:54:14.840219 [/Devices/piix3ide/0/LUN#0/AttachedDriver/Config/Plugins/VDPluginCrypt/] (level 4)
00:54:14.840220   Path <string>  = "/Applications/VirtualBox.app/Contents/MacOS/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/darwin.amd64/VDPluginCrypt.dylib" (cb=128)
00:54:14.840221 
00:54:14.840221 [/Devices/piix3ide/0/LUN#0/Config/] (level 1) (restricted root)
00:54:14.840222   Mountable <integer> = 0x0000000000000001 (1)
00:54:14.840223   Type      <string>  = "DVD" (cb=4)
00:54:14.840224 
00:54:14.840224 ********************* End of CFGM dump **********************
00:54:14.840360 Changing the VM state from 'SUSPENDED' to 'RESUMING'
00:54:14.840870 Changing the VM state from 'RESUMING' to 'RUNNING'
00:54:15.232146 AHCI#0P0: Write at offset 510698692608 (8192 bytes left) returned rc=VERR_IO_SECTOR_NOT_FOUND
00:54:15.236195 AHCI#0: Port 0 reset
00:54:15.474632 AHCI#0P0: Read at offset 547591999488 (92672 bytes left) returned rc=VERR_IO_SECTOR_NOT_FOUND
00:54:15.474830 AHCI#0: Port 0 reset
00:54:15.919671 AHCI#0P0: Write at offset 511433818112 (4096 bytes left) returned rc=VERR_IO_SECTOR_NOT_FOUND
00:54:15.919918 AHCI#0: Port 0 reset
00:54:15.947696 AHCI#0P0: Write at offset 521480261632 (81920 bytes left) returned rc=VERR_IO_SECTOR_NOT_FOUND
00:54:15.947985 AHCI#0: Port 0 reset

Changed 2 years ago by Megachip

Crash after inserting guest additions

comment:4 Changed 2 years ago by aeichner

We know what the issue is which causes the remount but it is a bit difficult to fix. This bug will be fixed in one of the maintenance releases.

comment:5 Changed 2 years ago by aeichner

This will be fixed in the next maintenance release. VBox now tries to unmount all used volumes before opening and denies any mount attempt on the host while the VM is running. I uploaded a testbuild to https://www.virtualbox.org/download/testcase/VirtualBox-5.0.1-101955-OSX.dmg for you to try out. Would be great if you could verify that the issue is fixed now, thanks!

comment:6 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.2. Please reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use