VirtualBox

Ticket #14159 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

ExtPack install would fail if %TMP% path contains Chinese characters => Fixed in SVN

Reported by: nim Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.28 Keywords:
Cc: Guest type: other
Host type: other

Description

I disovered this problem some time ago (half a year or so). I then thought it might be fixed soon. But it is not yet in 4.3.28.

It's like this. Yesterday I did a re-intall of my Windows 8 system since after 3 years the system is behaving strangely in many ways.

My Windows 8 account contains my name, hence the default %TMP% path contains Chinese characters like C:\Users\名字\AppData\Local\Temp. This would cause ExtPack installation fail with error code 1.

I am certain about this - because last time I encountered this error, I set %TMP% to C:\Temp and the installation succeeded as expected. And, this time I had the probem again, and I set %TMP% to C:\Temp as before, and, succeess!

Change History

comment:1 Changed 2 years ago by frank

  • Priority changed from blocker to major

Worth investigating but not a blocker as there is a workaround.

comment:2 Changed 2 years ago by frank

We think we found and fixed the problem. Could you install the latest Windows test build from here and verify that the problem is gone? Thank you!

comment:3 Changed 2 years ago by frank

  • Summary changed from ExtPack install would fail if %TMP% path contains Chinese characters to ExtPack install would fail if %TMP% path contains Chinese characters => Fixed in SVN

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0. The next 4.3.x maintenance release will have this fix as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use