VirtualBox

Ticket #14151 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Linux fonts became so big after latest virtualbox 4.3.28 upgrade -> fixed in 4.3 and later releases after June 8 2015

Reported by: nengxu Owned by:
Priority: critical Component: GUI
Version: VirtualBox 4.3.28 Keywords: font resolution size
Cc: Guest type: Linux
Host type: Windows

Description

Found on 2 Virtualbox Linux guests: Arch Linux 64, Lubuntu 2015.04 32, host is Windows 7. The main problem is that fonts become so huge after 4.3.28 upgrade from 4.3.26.

This problem seems a little complicated. It is related to VM screen resolution but strangely. On W7

1) if I shrink the VM screen resolution smaller, say 1024x768, and stay with this small screen, the fonts are normal everywhere.

2) When boot up the VM, I cannot use a large resolution like 1920x1200 (as my VM was running under before the recent virtualbox packages upgrade). Otherwise, all fonts become so huge. So I detoured this out by booting in small resolution.

3) After booting up in small resolution, if I increase the resolution, say back to 1920x1200, the fonts on the console (my case terminator) stay fine. However, when I start applications like Sublime Text, Claws mail, the fonts on those applications' menu bar become so huge. The fonts inside Sublime Text are normal. But the fonts inside Claws mail are huge too.

4) After booting up in small resolution, if first start up the applications, then increase the resolution, say back to 1920x1200, all fonts are fine everywhere.

Attachments

VBox.log Download (122.9 KB) - added by nengxu 3 years ago.
Log file from Arch Linux 64 guest
VBox.2.log Download (132.5 KB) - added by nengxu 3 years ago.
Log file from Lubuntu 2015.04 32 guest
VirtualBox-14151-01.PNG Download (44.5 KB) - added by nengxu 2 years ago.
VirtualBox-14151-02.PNG Download (26.5 KB) - added by nengxu 2 years ago.
VirtualBox-14151-03.PNG Download (86.8 KB) - added by nengxu 2 years ago.
VirtualBox-14151-04.PNG Download (93.9 KB) - added by nengxu 2 years ago.
VirtualBox-14151-05.PNG Download (43.0 KB) - added by nengxu 2 years ago.
0001-assign-value-to-mmHeight-not-height.patch Download (1.1 KB) - added by eworm 2 years ago.
assign value to mmHeight, not height
centos.JPG Download (124.5 KB) - added by jordanpg 2 years ago.
big-fonts-centos6.6
Xorg.0.log.4.3.28.after.reboot Download (34.6 KB) - added by jordanpg 2 years ago.
Xorg.0.log.4.3.29.after.install.before.reboot Download (35.5 KB) - added by jordanpg 2 years ago.
Xorg.0.log.4.3.29.after.install.after.reboot Download (34.6 KB) - added by jordanpg 2 years ago.
Xorg.0.log.5.0.0.after.install.after.reboot Download (34.5 KB) - added by jordanpg 2 years ago.
Xorg.0.log.5.0.0.after.install.before.reboot Download (35.2 KB) - added by jordanpg 2 years ago.

Change History

Changed 3 years ago by nengxu

Log file from Arch Linux 64 guest

Changed 3 years ago by nengxu

Log file from Lubuntu 2015.04 32 guest

comment:1 Changed 3 years ago by nengxu

I reported this problem firstly in Arch Linux forum:

 https://bbs.archlinux.org/viewtopic.php?id=197626

There you can find other users' similar experience.

comment:2 Changed 2 years ago by KCBurns

Seems reverting to 4.3.26 guest additions (with 4.3.28 VBox) solved this for my Centos6 guest on Centos6 host.

comment:3 Changed 2 years ago by nengxu

This is a serious regression bug and greatly deteriorates user experience. Please fix it at your earliest convenience. Thanks.

comment:4 Changed 2 years ago by eworm

Suffering this as well...

With guest additions 4.3.26:

$ xdpyinfo | grep dots
  resolution:    96x96 dots per inch

This changed with 4.3.28, the dpi values are increased and decreased based on the resize ratio:

$ xdpyinfo | grep dots
  resolution:    181x129 dots per inch

comment:5 Changed 2 years ago by michael

This is a (slight) shot in the dark, but could you try this Additions build? It is from 5.0, but should be very similar to 4.3.28 (I synchronised a lot of code recently which is presumably where this regression came from).

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_5.0.0-100804.iso

comment:6 Changed 2 years ago by vtrigonis

I use an Arch64 guest hosted on Win7 and I start X manually. I noticed that the problem only appears the first time X starts, after the guest has booted. If X is stopped and restarted, the problem goes away. The following are the lines that change in the Xorg log between successive starts:

Started for the first time, immediately after boot (xdpyinfo reporting 181x135 dpi):

(II) VBoxVideo(0): Modeline "1024x768"x60.0   47.83  1024 1026 1028 1030  768 770 772 774 (46.4 kHz Pb)
(II) VBoxVideo(0): Output VGA-0 using initial mode 1024x768
(II) VBoxVideo(0): Setting screen physical size to 270 x 203

After X is restarted (xdpyinfo reporting 96x96 dpi):

(II) VBoxVideo(0): Modeline "1920x1080"x60.0  125.50  1920 1922 1924 1926  1080 1082 1084 1086 (65.2 kHz Pb)
(II) VBoxVideo(0): Output VGA-0 using initial mode 1920x1080
(II) VBoxVideo(0): Setting screen physical size to 508 x 285

comment:7 Changed 2 years ago by frank

vtrigonis, could you test if the Additions Michael posted in comment 5 make any difference?

comment:8 Changed 2 years ago by vtrigonis

Unfortunately I can't use those  with Arch. I use  the ones provided by the distro's package manager.

comment:9 Changed 2 years ago by michael

I made a silly typing mistake in my fix, don't know how I managed to test without noticing it. Here is a fixed build:

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_5.0.0-100817.iso

comment:10 Changed 2 years ago by eworm

Basically I have the same issue as vtrigonis has. Installing software without package manager in bad. :-p

But I have an Arch live system available, so I do not care about testing the additions without package manager. I was not successful, though: With the addition 5.0.0rc1 (build 100817) I see xfce4-display-settings being started on guest window resize, but guest display stays at 1024x768.

comment:11 Changed 2 years ago by frank

eworm, could you precise your observations with the Guest Additions from r100817? Do I understand you correct that the guest display stays at 1024x768 and does not adapt to the window size? And how look the fonts, are they correct now?

comment:12 Changed 2 years ago by frank

I just updated the Additions .iso image on the test builds page, please use that one instead.

comment:13 Changed 2 years ago by eworm

Oh, I was wrong. Well, kind of... Uninstalled the package virtualbox-guest-utils, which provided vboxvideo.so (the Xorg driver module). It did not work for me as Xorg used plain VESA modes.

So after putting the file back in place everything works as expected. Here is what I did:

  • uninstall virtualbox-guest-utils, virtualbox-guest-modules
  • restore vboxvideo.so
  • install VBoxLinuxAdditions.run from VBoxGuestAdditions_5.0.0-100817.iso
  • build modules via dkms
  • reboot

-> works!

Any chance to get a patch against 4.3.28 with the required changes? :D

comment:14 Changed 2 years ago by eworm

BTW, dpi values still change, but font does not change as long as I have enabled "Custom DPI settings" in Xfce config. I do not know whether or not the values changed before.

comment:15 Changed 2 years ago by nengxu

Just installed VirtualBox-4.3.29-100833-Win.exe on W7. On my Lubuntu 32 guest, installed 4.3.29 guest addition and restart. Still have fonts problems. Please see attached screen shots.

Changed 2 years ago by nengxu

Changed 2 years ago by nengxu

Changed 2 years ago by nengxu

Changed 2 years ago by nengxu

Changed 2 years ago by nengxu

comment:18 Changed 2 years ago by michael

Could someone give me a quick recap about how to reproduce this problem with a freshly installed virtual machine (Ubuntu is nice, but others will do) and the test build Additions? It is fine if it involves installing old Additions first. Thanks.

comment:19 Changed 2 years ago by KCBurns

Guest Additions 5.0.0_100817 (with 4.3.28 VBox) seems to have solved this for my Centos6 guest on Centos6 host.

Michael - in my case, I got desired results on first boot after installing guest additions 4.3.28, but when booted up fresh for next day's work I had to re-install guest additions 4.3.28 to get desired results. This was consistently reproduced when using GA 4.3.28 in a Centos6 guest. However I have been able to resolve the problem by installing either GA 4.3.26 or 5.0.0_100817 (while running VBox 4.3.28 on host).

Changed 2 years ago by eworm

assign value to mmHeight, not height

comment:20 Changed 2 years ago by eworm

Not sure if this is related, but looks like there is a typo in vboxvideo.c...

comment:21 Changed 2 years ago by michael

It is related - that was the mistake I mentioned in comment 9.

comment:22 Changed 2 years ago by michael

  • Summary changed from Linux fonts became so big after latest virtualbox 4.3.28 upgrade to Linux fonts became so big after latest virtualbox 4.3.28 upgrade -> fixed in 4.3 and later releases after June 8 2015

First confirmation that the fix back-ported to 4.3 testing works too:

 https://forums.virtualbox.org/viewtopic.php?f=1&t=67837&p=324090#p324089

I will close this ticket - please re-open if necessary.

comment:24 Changed 2 years ago by jordanpg

Using 4.3.28r100309 with vanilla CentOS 6.6 guest.

Neither the 4.3.29 nor 5.0RC1 GA builds fix the font problem for me.

Please let me know if I can provide any diagnostic info for troubleshooting.

Last edited 2 years ago by jordanpg (previous) (diff)

comment:25 Changed 2 years ago by frank

jordanpg, could you post screenshots together with the corresponding /var/log/Xorg.0.log for a guest when you use the 4.3.26 Additions and when you use the latest 4.3 Additions which still don't fix your font size problems?

comment:26 Changed 2 years ago by nengxu

Tried Guest Additions 5.0.0_100817 under VirtualBox-4.3.29-100833-Win.exe on W7, now my Lubuntu 32 box works fine with the fonts. Thanks.

However, please note that VirtualBox-4.3.29-100833-Win.exe alone is not solving the problem as shown in my previous comment and screen shots.

Changed 2 years ago by jordanpg

big-fonts-centos6.6

comment:27 Changed 2 years ago by nengxu

@eworm Tried your 64 Arch package. Worked fine with the latest Linux 4.0.5-1. Thanks!

Changed 2 years ago by jordanpg

Changed 2 years ago by jordanpg

Changed 2 years ago by jordanpg

Changed 2 years ago by jordanpg

Changed 2 years ago by jordanpg

comment:28 Changed 2 years ago by jordanpg

@frank, screenshot and logs attached. Screenshot is the same in all cases.

comment:29 Changed 2 years ago by michael

jordanp: you might need to delete the GNOME 2 configuration directory (I forget the exact path) in your user's home directory on the virtual machine. GNOME 2 may have remembered the font size from when you were using the previous Additions build. (Based on something someone else said.)

comment:30 Changed 2 years ago by jordanpg

That did not fix it, but I tried creating a new user and logging in and that did.

This points to a lingering config issue at the per-user level.

comment:31 Changed 2 years ago by jordanpg

Update: deleted all dotted directories in my home directory and restarted. This has fixed the problem for me. Not sure which directory was causing the problem.

comment:32 Changed 2 years ago by VBoxGrl

My specs;

Slackware 14.1 x86_64 Host

Slackware 14.1 x86_64 Guest running Openbox 3.5.0

I just compiled from source 4.3.28 and I am also experiencing larger fonts.

I am only seeing this the first time I type 'startx' and log into X.

After running X for the first time, if I log out of X, and then log back in the fonts return to normal, which seems odd...

Hmm

Last edited 2 years ago by VBoxGrl (previous) (diff)

comment:33 Changed 2 years ago by michael

Yes, 4.3.28 (specifically the 4.3.28 Guest Additions) is known to have this problem. Please read the comments above.

comment:34 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 5.0. The fix will be also available in the next 4.3.x maintenance release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use