VirtualBox

Ticket #1410 (reopened defect)

Opened 6 years ago

Last modified 3 years ago

clipboard host->guest copy/paste fails if rdp active => Fixed in 1.6.6

Reported by: akaihola Owned by:
Priority: major Component: RDP
Version: VirtualBox 1.5.6 Keywords: clipboard
Cc: Guest type: other
Host type: other

Description

I have virtualbox-1.5.6-28266_Ubuntu_gutsy (on an Ubuntu 7.10 Gutsy host, naturally) and a Freshly installed CentOS 5.0 guest with Linux guest additions. I've enabled the bidirectional clipboard and it works fine.

However, copy/pasting from the host to the guest does not work in rdp sessions (I'm using rdesktop). The menu item and keyboard shortcut for paste simply don't do anything. Copy/pasting from the guest to the host works fine.

Also, when an rdp session is opened in addition to VirtualBox's own guest window, copy/pasting ceases to work in VirtualBox's own guest window. When the rdp session is closed, copy/paste resumes to work correctly.

So far I've used only local rdp sessions.

Attachments

Restart.vbs Download (707 bytes) - added by LesDes 4 years ago.
VB script to kill and then restart VBoxTray.exe

Change History

comment:1 Changed 6 years ago by yope

I can confirm this to the point that I have only used rdesktop-vrdp so far, and the clipboard just does not work. My setup: Headless server running 64-bit Ubuntu 7.10 and Virtulbox binaries version 1.5.6. Guests are either WinXP or Win2000 with guest additions installed. Client runs 32-bit Kubuntu 7.10 and rdesktop-vrdp over ethernet. Copy/paste guest from/to client (either primary or secondary clipboard) does not work. Enabling or disabling bidirectional clipboard in VB settings doesn't make any difference.

comment:2 Changed 6 years ago by h00kupz

I can confirm as well I see this same issue with a Windows XP guest with OpenSUSE 10.3 as the host and running the guest in VRDP mode when pasting from the host to the guest through rdesktop. The target application running inside the guest operating system locks up and when shutting down the Windows XP guest the "VBoxSharedClipboardClass" is not responding and must be killed.

comment:3 Changed 6 years ago by h00kupz

As well with VirtualBox 1.5.6 guest additions installed (forgot to include that previously my apologies).

comment:4 Changed 6 years ago by frank

Did you check 1.6.0?

comment:5 Changed 6 years ago by h00kupz

Yes this is the case in 1.6.0 also (just upgraded).

comment:6 Changed 6 years ago by frank

  • Component changed from other to RDP

comment:7 Changed 6 years ago by frank

  • Summary changed from clipboard host->guest copy/paste fails if rdp active to clipboard host->guest copy/paste fails if rdp active => Fixed in 1.6.6

We believe that we fixed this problem in 1.6.6. Please verify this when the package is available.

comment:8 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 Changed 4 years ago by techno.scavenger

  • Status changed from closed to reopened
  • Resolution fixed deleted

Re-opening this issue. This was observed using 3.2.4.

See thread for info:  http://forums.virtualbox.org/viewtopic.php?f=6&t=27825&p=142311#p142311

My configuration: Host: Ubuntu 10.04 Guest: Windows Xp (guest1) Another machine: Windows Xp (machine1)

Remote desktop "machine1 <-rdp-> guest1", causes clipboard to stop working in machine1.

comment:10 Changed 4 years ago by LesDes

I still have this problem regularly so I have created a script which I run from a shortcut (Windows host) whenever copy/paste fails. It may be useful to others: ==================================

' Based on: Process.vbs by Guy Thomas  http://computerperformance.co.uk/ ' -------------------------------------------------------' Option Explicit Dim objWMIService, objProcess, colProcess, strComputer, strList, objShell strComputer = "."

Set objWMIService = GetObject("winmgmts:" _ & "{impersonationLevel=impersonate}!\" _ & strComputer & "\root\cimv2")

Set colProcess = objWMIService.ExecQuery _ ("Select * from Win32_Process")

For Each objProcess in colProcess

If objProcess.name = "VBoxTray.exe" Then objProcess.terminate

Next

' Restart

Set objShell = CreateObject("Shell.Application") objShell.ShellExecute "VBoxTray.exe", "", "", "open", 1

WScript.Quit

Changed 4 years ago by LesDes

VB script to kill and then restart VBoxTray.exe

comment:11 Changed 4 years ago by LesDes

Sorry but my previous post seems to have been rather messed up when I pasted in the short VB scripts so I have uploaded it as an attachment.

comment:12 Changed 4 years ago by gimel

Hello, probably related.

What I have here (Host Windows, Guest Windows) : when I open a RDP into the guest, I can't copy inside the RDP session itself. Everytime I paste, it inserts "null". For example, if some text was selected when I do the Ctrl-V the text is removed. Of course I cannot paste neither inside the same RDP session or outside of it. As soon as I kill VBoxTray.exe in this same session, I can copy/paster normally.

Still valid in version 3.2.6

comment:13 Changed 3 years ago by agrogers

I am using 4.0.2 r69518 with a Win7 host and WinXP guests. I am RDPing into several machines at once and I am finding the same problems as described above.

  1. Copy and paste fail to work
  2. All Copy and Paste on the *Host* stops working too
  3. Closing one or more RDP sessions will fix the problem
  4. Killing the vboxtray app on the guests solves the problem

I am not using the Remote Display option.

Thanks Andrew

comment:14 Changed 3 years ago by a.key

I am running vbox 4.0.2 on x86_64 Linux. Having the same problem. When VM is started in headless mode the clipboard is not working (copy/paste from host to guest and the other way around) that's through VRDP of course.

But I noticed something that people might find useful: When I started the Oracle VM VirtualBox Manager the clipboard started to work. I can close the window and the clipboard will continue to work so it seems like the clipboard function for VRDP is somehow dependent on the VM Manager window at least for initialization as it can later be closed and clipboard continues to work.

To recreate:

Oracle VM Manager window is closed Start the VM in headless mode: VBoxHeadless --startvm XP Check copy/paste from host to guest - not working Start the VM Manager window Check copy/paste from host to guest - working fine Check copy/paste from guest to host - not working. Close VM Manager window - no change.

Guest to host is still not working but I don't mind this one.

comment:15 Changed 3 years ago by SrinivasNS

I am using 4.0.4 r70112 with Windows 7 host and windows XP as the guest. If I use it from the host copy/paste works. If I RDP into it from the host machine or from another machine (XP or widnows 7), copy/paste would not work in the guest session. I can still use the copy/paste functionality on the host or any other machine from which I RDP into this virtual machine.

comment:16 Changed 3 years ago by agrogers

Just grabbed the latest version (4.0.8 r71778). Sadly there is still issues for me with the copy and paste. Setup is:

Host: Win7 Guest1: XP Guest2: XP PC1: XP

I connect to Guest1 and Guest2 via RDP from PC1. To replicate the issue:

  1. Start Guest1 and Guest2
  1. RDP to Guest1. Copy and Paste WORKS fully on Guest1 and PC
  1. RDP to Guest2. Copy and Paste works fully on Guest1 and Guest2. ALL copy and paste now fails on PC. It is not possible to paste at all on PC, either locally or into the RDP clients. However i can copy and paste *between* RDP sessions.

Thanks Andrew

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use