VirtualBox

Ticket #14046 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

VirtualBox Mac-version-10.10.3 (Yosemite), NAT network issue

Reported by: ranjan242526 Owned by:
Component: other Version: VirtualBox 4.3.26
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description (last modified by vushakov) (diff)

I have recently bought a MACBook, running with 10.10.3 (Yosemite). I want to install Vagrant to run parallel systems. Vagrant uses VirtualBox to spin multiple VMs. While doing so I have two observation which is blocking me to proceed further.

# Issues:

1. The Acquired ip through DHCP (NAT) is "10.0.2.15". All the new VM under NAT, acquire the same ip ("10.0.2.15")

  1. The Guest VM is not ping able from my Host Machine.

NOTE: I am using Ubuntu-Server 14.04 for my guest VM setup.

# Approach:

# 1 : [FAILED ..] Manually tried creating a VM (instead Vagrant ) I have also tried with all the provided virtual adaptor with NAT mode, unfortunately there is no difference. PCNet PCI II (Am79C970A); PCNet FAST III (Am79C973, the default); Intel PRO/1000 MT Desktop (82540EM); [Default one] Intel PRO/1000 T Server (82543GC); Intel PRO/1000 MT Server (82545EM); Paravirtualized network adapter (virtio-net).

# 2 : [Working] Tried downloading a Box from Vagrant and tried to run, it works perfect.

# 3 : [Working] I have created a the same VM under bridge networking, it is working by acquire the ip from my physical network. and accessible from my Host machine.

# User Story:

I want to create a Base Vagrant VM with custom configuration for my CI setup.

# Reference:

My Host Network configuration:

Soumyas-MacBook-Pro:RawMachine1 soumya$ ifconfig
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
options=3<RXCSUM,TXCSUM>
inet6 ::1 prefixlen 128 
inet 127.0.0.1 netmask 0xff000000 
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
nd6 options=1<PERFORMNUD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether 6c:40:08:9e:d0:5a 
inet6 fe80::6e40:8ff:fe9e:d05a%en0 prefixlen 64 scopeid 0x4 
inet 192.168.1.7 netmask 0xffffff00 broadcast 192.168.1.255
nd6 options=1<PERFORMNUD>
media: autoselect
status: active
en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
options=60<TSO4,TSO6>
ether 72:00:06:43:af:80 
media: autoselect <full-duplex>
status: inactive
en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
options=60<TSO4,TSO6>
ether 72:00:06:43:af:81 
media: autoselect <full-duplex>
status: inactive
bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=63<RXCSUM,TXCSUM,TSO4,TSO6>
ether 6e:40:08:e9:57:00 
Configuration:
id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
ipfilter disabled flags 0x2
member: en1 flags=3<LEARNING,DISCOVER>
ifmaxaddr 0 port 5 priority 0 path cost 0
member: en2 flags=3<LEARNING,DISCOVER>
ifmaxaddr 0 port 6 priority 0 path cost 0
nd6 options=1<PERFORMNUD>
media: <unknown type>
status: inactive
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
ether 0e:40:08:9e:d0:5a 
media: autoselect
status: inactive
awdl0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1452
ether 8e:5f:a4:16:d5:3b 
inet6 fe80::8c5f:a4ff:fe16:d53b%awdl0 prefixlen 64 scopeid 0x9 
nd6 options=1<PERFORMNUD>
media: autoselect
status: active
vboxnet0: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether 0a:00:27:00:00:00 
Soumyas-MacBook-Pro:RawMachine1 soumya$ ping 10.0.2.15
PING 10.0.2.15 (10.0.2.15): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
^C
--- 10.0.2.15 ping statistics ---
7 packets transmitted, 0 packets received, 100.0% packet loss
Soumyas-MacBook-Pro:RawMachine1 soumya$

I have also attached the screenshot of VirtualBox Guest VM, Please have a look.

Please let us know, If more info is required for analyse the issue.

NOTE: I have also tried looking to the defect #13104: But couldn't find any relation or clue.

Attachments

Logs.zip Download (51.2 KB) - added by ranjan242526 7 years ago.
VirtualBox Log for VMs

Change History

Changed 7 years ago by ranjan242526

VirtualBox Log for VMs

comment:1 Changed 7 years ago by vushakov

  • Description modified (diff)

comment:2 Changed 7 years ago by vushakov

  • Description modified (diff)

comment:3 in reply to: ↑ description Changed 7 years ago by vushakov

Replying to ranjan242526:

# Issues:

  1. The Acquired ip through DHCP (NAT) is "10.0.2.15". All the new VM under NAT, acquire the same ip ("10.0.2.15")
  2. The Guest VM is not ping able from my Host Machine.

This is expected and documented behavior.

comment:4 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

AFAICS the only remaining point in the list is that you cannot create a VM with Vagrant. As Vagrant != VirtualBox I will close this ticket. For seeking help, please ask the Vagrant folks. For asking such questions like above for VirtualBox, please go to the VirtualBox forums (forums.virtualbox.org).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use