VirtualBox

Ticket #13957 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Reset immutable disks at "Restoring virtual machine" is erroneous

Reported by: FelixG Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.3.24 Keywords: immutable disk, resume, crash
Cc: Guest type: Windows
Host type: Windows

Description

When an saved stated (frozen machine) is resumed, virtualbox reset inmutable disks.

This is wrong because it causes an inestable status in the virtual machine. Inmutable disks only must be reset with a cold start.

(Host and guest are Windows S.O. The inmutable disk is used to contain temporal directories and pagefile.sys, preventing the growth of the primary disk)

Other issues:

  • With "--autoreset off", an inmmutable disk is equal to a multiattach disk. It would be interesting to have a manual reset option.

Attachments

Restoring virtual machine.png Download (6.6 KB) - added by FelixG 3 years ago.
Restoring virtual machine

Change History

Changed 3 years ago by FelixG

Restoring virtual machine

comment:1 Changed 3 years ago by FelixG

Release 4.3.28 continues with the same problem.

Please solve this problem in the next release, it's easy to correct!

comment:2 Changed 2 years ago by FelixG

Release 5.0.0 also has the same problem.

Reset the disk when the machine is resumed, causes an inestable status!!!!

Immutable disks only must be reset with a cold start.

Please, change it.

comment:3 Changed 2 years ago by Flow86

ran into same problem.

please, change this soon!

it renders whole disks unusable, since the filesystem is cached in ram on most operating systems!

comment:4 Changed 2 years ago by klaus

Gah. Your attachment made me believe you're talking about starting a VM from a restored snapshot (which works perfectly!). Now the problem is clear, and it's a bug which existed for many many years. Clearly no one thought of this case, and as there are only very few users of immutable disks in general (and most use it in very specific ways, apparently not touching saved state) it's not a code which gets touched or changed.

comment:5 Changed 2 years ago by frank

Fix committed to VBox 5.0.x, please try a recent test build from here (revision >= 101939).

Last edited 2 years ago by frank (previous) (diff)

comment:6 Changed 2 years ago by frank

The latest 4.3.x builds contain the fix as well.

comment:7 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use