VirtualBox

Ticket #13924 (closed defect: obsolete)

Opened 8 years ago

Last modified 5 years ago

Unable to upgrade to 4.3.24 and unable to x 4.3.22

Reported by: truane Owned by:
Component: installer Version: VirtualBox 4.3.22
Keywords: Cc:
Guest type: all Host type: Windows

Description

Hi

I get a error when trying to upgrade to 4.3.24 and then the installation just rolls back. After failing to install every virtual machine complains about the Host only network when I try to start them.

As a solution i tried to uninstall 4.3.22 from my system so that i could do a clean install 4.3.24 but when try to uninstall the uninstall dialog pops up does something and then closes without removing virtual box.

I tried rebooting the system with no effect.

Is there manual step for removing virtual box? is there logging for the installation/installation that I might be able to find out exactly what the issue is?

regards

tom

Change History

comment:1 Changed 8 years ago by virusd9

Hi, I have the same issue on win7 host, upgrade fails and uninstall of 4.3.22 fails too. Already tried the test to install the test last test build but even this failed. Here the win7 log of the failed uninstall.

Please help.

Nome registro: Application Origine: MsiInstaller Data: 3/11/2015 3:42:04 PM ID evento: 11725 Categoria attività:Nessuna Livello: Informazioni Parole chiave: Classico Utente: XXXXXXXXXXXXXXXXX Computer: XXXXXXXXXXXXXXXXX Descrizione: Product: Oracle VM VirtualBox 4.3.22 -- Removal failed. XML evento: <Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="MsiInstaller" /> <EventID Qualifiers="0">11725</EventID> <Level>4</Level> <Task>0</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2015-03-11T14:42:04.000000000Z" /> <EventRecordID>4892</EventRecordID> <Channel>Application</Channel> <Computer>xxxxxxxxxxxxxxxxxxxxxxx</Computer> <Security UserID="S-1-5-21-121752565-2208887045-340623127-23064190" />

</System> <EventData>

<Data>Product: Oracle VM VirtualBox 4.3.22 -- Removal failed.</Data> <Data>(NULL)</Data> <Data>(NULL)</Data> <Data>(NULL)</Data> <Data>(NULL)</Data> <Data>(NULL)</Data> <Data> </Data> <Binary>7B46303533463734412D413633312D344346412D413237312D3644303734373539394243397D</Binary>

</EventData>

</Event>

Last edited 8 years ago by virusd9 (previous) (diff)

comment:2 Changed 8 years ago by frank

What happens if you uninstall VirtualBox, then reboot the host and then install the new version?

comment:3 Changed 8 years ago by truane

You are unfortunately unable to uninstall after you try to install the new Virtual Box that is the main issue

So Finally got it to install by going through the registry and removing it manually. Then removing the files from the system. I then could re-install.

The problem is that Virtual Box how now gone to 4.3.26 and guess what I can't install it again. It takes a good hour to clean down the registry to remove the older version. If I have to do this again I'm not going to be installing new updates again and as it is me that tests the roll-out of VM's and virtual box to the company before they use them I wont be recommending any one else does it either.

Until a at least hear from someone in support why this is happening.

Last edited 8 years ago by truane (previous) (diff)

comment:4 Changed 8 years ago by eradrix

Same problem (win seven / 64). I'm currently unable to upgrade to version 4.3.24 or 4.3.26 so I'm stick to 4.3.22 and waiting for a solution...

comment:5 Changed 8 years ago by truane

after trying the upgrade I'm unable to create host-only network adapter and all system that used it wont start without it being removed.

comment:6 Changed 8 years ago by eradrix

Install issue:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
    <Provider Name="MsiInstaller" /> 
    <EventID Qualifiers="0">11719</EventID> 
    <Level>2</Level> 
    <Task>0</Task> 
    <Keywords>0x80000000000000</Keywords> 
    <TimeCreated SystemTime="2015-03-22T17:36:02.000000000Z" /> 
    <EventRecordID>7257</EventRecordID> 
    <Channel>Application</Channel> 
  </System>
- <EventData>
    <Data>Product: Oracle VM VirtualBox 4.3.26 -- Error 1719. The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.</Data> 
    <Data>(NULL)</Data> 
    <Data>(NULL)</Data> 
    <Data>(NULL)</Data> 
    <Data>(NULL)</Data> 
    <Data>(NULL)</Data> 
    <Data /> 
    <Binary>7B35373731463539412D424643392D344641462D413838332D3736343245463442413343337D</Binary> 
  </EventData>
  </Event>

comment:7 Changed 8 years ago by eradrix

Got it! I had to kill as many processes I could using task manager before trying to install. Surely a conflict with some online network process (cloud related?)

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use