VirtualBox

Ticket #13899 (reopened defect)

Opened 3 years ago

Last modified 2 months ago

"VboxNetNat.exe" Random crashes

Reported by: qidizi Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 4.3.22 Keywords: NAT
Cc: TechSalesDude Guest type: Linux
Host type: Windows

Description (last modified by vushakov) (diff)

host OS:window 7; host some software:avast!; noteBook:lenovo k27,intel I3,RAM 8G,ssd 128G; host network:LAN,or LAN wifi; guest OS:centos 7; guest network:NAT network,forwarding port(tcp127.0.0.1:22 => 10.0.2.5:22,tcp127.0.0.1:80=>10.0.2.5:80;tcp127.0.0.1:3306 => 10.0.2.5:3306),interface:Intel Pro/1000 MT server (82545EM) mixed mode is disabled; vm virtualbox VER:4.3.23-98520/4.3.22(test both )

when testing,only this guest OS is runing! my email is :qidizi&qq.com If you are using a NAT(not NAT network), this problem will become more serious, see the following  https://www.centos.org/forums/viewtopic.php?f=50&t=51112 If you use the "bridging model", this problem would not have arisen; Possible causes:postfix(http://www.postfix.org,Install on CentOS systems) is runing,and A large number of mail is being delivered;and the browser on the host(window on "k27"), constantly refresh a PHP page,the "nginx/php" on Centos;then "VboxNetNat.exe" Random crashes,But I cannot determine what operation caused crash;

Attachments

1.png Download (48.8 KB) - added by qidizi 3 years ago.
They are normal
2.png Download (9.4 KB) - added by qidizi 3 years ago.
3.png Download (75.2 KB) - added by qidizi 3 years ago.
when crash;can ping www.qq.com;but forward port is suspended,ssh/80 be loading...until close the crash message window;
6.png Download (49.1 KB) - added by qidizi 3 years ago.
7.png Download (27.6 KB) - added by qidizi 3 years ago.
8.png Download (26.1 KB) - added by qidizi 3 years ago.
but some time do not show this crash window,when it crashed;
4.png Download (64.4 KB) - added by qidizi 3 years ago.
after close the crash message window,all "vboxnetnat.exe" is crash;
centos-7-info.txt Download (23.9 KB) - added by qidizi 3 years ago.
Logs.rar Download (42.2 KB) - added by qidizi 3 years ago.
install 4.3.20,clear logs,start vbox,run centos guest,crash,shutdown guest,exit vbox,winrar logs files
QQ五笔截图未命名.png Download (58.9 KB) - added by qidizi 3 years ago.
4.3.20crash too,very soon.only connect ssh via "putty" tool.
vbox4.3.20-exception.png Download (19.4 KB) - added by qidizi 3 years ago.
vbox4.3.20 crash by unknown software exception
vbox4.3.20-exception-donotCreateDumpFiles.png Download (48.2 KB) - added by qidizi 3 years ago.
with 4.3.20,when crash,i do not get any dump files,but the regedit key/values is all right,so,i will reinstall vbox4.3.33(or VirtualBox test builds),and Have a look whether the use of stress testing tool, triggering the crash;get the dump files;
QQ五笔截图未命名.2.png Download (130.4 KB) - added by qidizi 3 years ago.
crash before press ok
QQ五笔截图未命名2.png Download (72.7 KB) - added by qidizi 3 years ago.
crash after press ok
2016-04-21 10_59_44-VBoxNetNAT.exe - Erreur d’application.png Download (10.0 KB) - added by Alex131089 19 months ago.
VBox 5.0.18, 1 VM & 1 NATNet with forwarding crash
NatNetwork.zip Download (1.4 KB) - added by par7133_2 13 months ago.
a crash log, with the test built
NatNetwork2.zip Download (17.2 KB) - added by par7133_2 12 months ago.
an other log with test build
NatNetwork4.zip Download (17.0 KB) - added by par7133_2 12 months ago.
a 4th crash log, with the test built

Change History

Changed 3 years ago by qidizi

They are normal

Changed 3 years ago by qidizi

Changed 3 years ago by qidizi

when crash;can ping www.qq.com;but forward port is suspended,ssh/80 be loading...until close the crash message window;

Changed 3 years ago by qidizi

Changed 3 years ago by qidizi

Changed 3 years ago by qidizi

but some time do not show this crash window,when it crashed;

Changed 3 years ago by qidizi

after close the crash message window,all "vboxnetnat.exe" is crash;

Changed 3 years ago by qidizi

comment:1 follow-ups: ↓ 3 ↓ 4 Changed 3 years ago by frank

Please attach a VBox.log file of such a VM session when the VM crashed. Also, did these crashes happen for you with VBox 4.3.20 as well?

comment:2 Changed 3 years ago by frank

Also, can you provide application crash dumps? See here (scroll down that page).

comment:3 in reply to: ↑ 1 Changed 3 years ago by qidizi

ok,i will post these here tomorrow,beijing time,at the 09:00.

Last edited 3 years ago by qidizi (previous) (diff)

Changed 3 years ago by qidizi

install 4.3.20,clear logs,start vbox,run centos guest,crash,shutdown guest,exit vbox,winrar logs files

comment:4 in reply to: ↑ 1 Changed 3 years ago by qidizi

Replying to frank:

Please attach a VBox.log file of such a VM session when the VM crashed. Also, did these crashes happen for you with VBox 4.3.20 as well?

4.3.20crash too,very soon.only connect ssh via "putty" tool.

Changed 3 years ago by qidizi

4.3.20crash too,very soon.only connect ssh via "putty" tool.

Changed 3 years ago by qidizi

vbox4.3.20 crash by unknown software exception

Changed 3 years ago by qidizi

with 4.3.20,when crash,i do not get any dump files,but the regedit key/values is all right,so,i will reinstall vbox4.3.33(or VirtualBox test builds),and Have a look whether the use of stress testing tool, triggering the crash;get the dump files;

comment:5 Changed 3 years ago by frank

Still relevant with VBox 4.3.26?

comment:6 Changed 3 years ago by qidizi

So far, no longer occur.

maybe crash only when i do something Different?

When it happened, I'll send feedback.

comment:7 Changed 3 years ago by qidizi

now my VBox is 4.3.26 r98988; it is still crash;

1 runing centos on the vbox; 2 runing postfix; 3 send very much email via smtp to postfix; 4 then vbox net is crash every times; 5 but window 7 can't get any crash dump files; 6 the dump files get from process explorer(sysinternals.com);

7 you can get more infomation from my pc via teamview ( https://www.teamviewer.com/zhCN/index.aspx) or QQ ( http://im.qq.com/download/);

8 my email :qidizi$qq.com

Changed 3 years ago by qidizi

crash before press ok

Changed 3 years ago by qidizi

crash after press ok

comment:8 Changed 3 years ago by qidizi

the dump files is too big;i can't post here; please download it from  http://share.weiyun.com/9cb8126b8d48e49ddc8db0b26d66cc36

comment:9 follow-up: ↓ 11 Changed 3 years ago by VVP

I can't download dump file from  http://share.weiyun.com/9cb8126b8d48e49ddc8db0b26d66cc36. I was asked to scan QR code and about login\password. And it was in Chinese.

comment:10 Changed 3 years ago by vushakov

  • Description modified (diff)

comment:11 in reply to: ↑ 9 ; follow-up: ↓ 12 Changed 3 years ago by qidizi

Replying to VVP:

I can't download dump file from  http://share.weiyun.com/9cb8126b8d48e49ddc8db0b26d66cc36. I was asked to scan QR code and about login\password. And it was in Chinese.

please try this url  http://pan.baidu.com/s/1gdnJEHP

and click "普通下载" or "下载(33.5)M"

Last edited 3 years ago by qidizi (previous) (diff)

comment:12 in reply to: ↑ 11 Changed 3 years ago by vushakov

Replying to qidizi:

Thanks, that worked.

comment:13 Changed 2 years ago by fsse8info

same problem with a NAT Network of 192.168.168.0/24

comment:14 Changed 2 years ago by vushakov

Please, can you give recent test build a try? 103571+ for 5.x, 103575+ for 4.x.

comment:15 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Hopefully fixed in VBox 5.0.10. Please reopen if necessary.

comment:16 Changed 21 months ago by Porsche_maniak

  • Status changed from closed to reopened
  • Resolution fixed deleted

This bug is still there @ 5.0.14 version. The guest os is Windows XP x86 and the host is Windows 2008R2 x64 The guest os is sending large amounts of emails. Get this error https://forums.virtualbox.org/download/file.php?id=20837 at random times.

I will submit the windows dump in few days.

Last edited 21 months ago by Porsche_maniak (previous) (diff)

comment:17 Changed 21 months ago by vushakov

Please, provide a full crash dump of VBoxNetNAT.exe

Changed 19 months ago by Alex131089

VBox 5.0.18, 1 VM & 1 NATNet with forwarding crash

comment:18 Changed 19 months ago by Alex131089

Affected too, VBox 5.0.18, 1 VM with 1 NAT Network with 2 port forwarding (127.0.0.50:80 -> 10.0.56.50:80 & the same for port 443). I cannot provide crash dump sorry. Isn't #14774 related ?

comment:19 Changed 19 months ago by frank

Unfortunately without a crash dump there is nothing we can do as we cannot reproduce the problem.

comment:20 Changed 15 months ago by aeichner

  • Status changed from reopened to closed
  • Resolution set to worksforme

No response, closing. Please reopen if still relevant and you provided the requested crash dump of VBoxNetNAT.exe.

comment:21 Changed 14 months ago by par7133_2

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I'm using VirtualBox Version 5.1.6 r110634 (Qt5.5.1) on Windows 7 SP1 with Fedora 24 as guest and VBoxNetNAT.exe often stops working, sometimes crashes.

I'm using WiFi, with the DHCP and I setup "VBoxManage modifyvm 'VM name' --natdnshostresolver1 on".

To restore the Nat Network while running, I have to set the network adapter on "not attached" and then reset the Nat Network. This restarts VBoxNetNat.exe

I did a dump of the three processes after a stop (not a crash). I did them manually: from Task Manager, "Show processes from all users", right click on the single process, Create Dump file:  https://1drv.ms/u/s!ArwJYLwiUJKMqTTAvupYx6MhCyzP

A second stop:  https://1drv.ms/u/s!ArwJYLwiUJKMqTXmevmd-5GlOZkh

Last edited 14 months ago by par7133_2 (previous) (diff)

comment:22 follow-up: ↓ 27 Changed 14 months ago by mr_raphael_martin

Exactly the same intempestive crash : every 5 minutes.

Context : Windows 7 64bits 16Go RAM hosting 4 Virtual Ubuntu 16.04 linux servers.

VirtualBox version 5.1.6. Previously seen also on version 5.0.24

I have captured dumps of 3 VBoxNetNat.exe processes (~90mo). Where can I upload them ?

comment:23 Changed 14 months ago by frank

mr_raphael_martin, could you contact me via private e-mail at frank _dot_ mehnert _at_ oracle _dot_ com? Please refer to this ticket. I cannot provide you a server URL, perhaps you find a server and can pass me the URL via e-mail? Thank you!

comment:24 follow-up: ↓ 25 Changed 14 months ago by par7133_2

Continue from #comment:22

After a crash VBoxNetNat.exe doesn't run properly anymore also if I switch from "not attached" or I relaunch VirtualBox. When I tried with "Nat" is all okay.

The dump of the crash didn't happen after having set the registry settings published here and from Microsoft. So I made a dump of the faulty VBoxNetNat.exe as from the instructions in #comment:22  https://1drv.ms/u/s!ArwJYLwiUJKMqTZ-CPYxfZfT3Txd

When I went to reboot the pc, the shutdown blocked itself on the process VBoxSVC.exe "VirtualBox Interface" saying "VirtualBox Interface has some active connections". Something that I can't understand as VirtualBox was already closed down. Here the dump of VBoxSVC.exe:  https://1drv.ms/u/s!ArwJYLwiUJKMqTcsTVkLs_kjO3QP

After the reboot of Windows, VBoxNetNat.exe started to run properly again.

Last edited 13 months ago by par7133_2 (previous) (diff)

comment:25 in reply to: ↑ 24 ; follow-up: ↓ 26 Changed 14 months ago by vushakov

Replying to par7133_2:

So I made a dump of the faulty VBoxNetNat.exe has from the instructions in #comment:22  https://1drv.ms/u/s!ArwJYLwiUJKMqTZ-CPYxfZfT3Txd

Are these dumps from live VBoxNetNat.exe processes (via "Create Dump File" in task manager or the like)?

comment:26 in reply to: ↑ 25 Changed 14 months ago by par7133_2

yes, via "Create Dump File" from Task Manager

Replying to vushakov:

Are these dumps from live VBoxNetNat.exe processes (via "Create Dump File" in task manager or the like)?

Last edited 14 months ago by par7133_2 (previous) (diff)

comment:27 in reply to: ↑ 22 Changed 14 months ago by vushakov

Replying to mr_raphael_martin:

I have captured dumps of 3 VBoxNetNat.exe processes (~90mo). Where can I upload them ?

Thanks for the dumps!

By Murphy's Law we could never reproduce the crash and this is the first dump we get where the stack of the relevant thread is not completely smashed, so I was able to finally get some clues as to what might be going wrong and that helps reducing the search space.

If you could kindly help by running a test build with extra instrumentation/logging I'll try to provide one some time next week.

comment:28 Changed 13 months ago by vushakov

Sorry for the delay. Please, can you give a try to a 5.1 test build r111559 or higher.

It will still crash, but it adds a bit of extra instrumentation to help confirm some hypotheses.

To enable the extra logs, you need to set these two environment variables:

VBOXNET_your_natnet_name_RELEASE_LOG="+nat_service.l2 -nat_service.restrict"
VBOXNET_your_natnet_name_RELEASE_LOG_FLAGS="thread timeprog"

The your_natnet_name portion of the variable names should be replaced with the name of your natnet. Use underscores for any characters in the natnet name that are not suitable for an identifier. E.g. for a network test-0 use VBOXNET_test_0_RELEASE_LOG.

It's probably easiest to set them globally via Window GUI. E.g. Control Panel -> System -> Advanced system settings -> Advanced -> Environment Variables.

The extra logging will be in %USERPROFILE%/.VirtualBox/your-natnet-name.log

If the environment vars are set correctly you should see

NAT_SERVICE LogRel2 enabled

near the beginning of that log to provide you immediate feedback.

Changed 13 months ago by par7133_2

a crash log, with the test built

comment:29 Changed 13 months ago by par7133_2

With the test build goes much better, few crashes.

However, here the attachment <<NatNetwork.zip>> with the log of a crash.

Changed 12 months ago by par7133_2

an other log with test build

Changed 12 months ago by par7133_2

a 4th crash log, with the test built

comment:30 Changed 7 months ago by lewinbo

still met this issue with latest VirtualBox: 5.1.22r 115126 (Win7 64bit)

comment:31 Changed 3 months ago by vushakov

  • Cc TechSalesDude added

comment:32 Changed 2 months ago by Omugile

I also encounter VboxNetNat.exe silent crashes. By restarting the process with "VBoxManage.exe natnetwork start --netname NAT" network connectivity is restored.

I would like to help, so if you would like me to collect a dump please let me know. Could you then send me a link with instruction for collecting this dump?

comment:33 Changed 2 months ago by vushakov

You can find instructions on how to get a minidump under Windows here.

comment:34 Changed 2 months ago by Romario74

The silent crash of /usr/lib/virtualbox/VBoxNetDHCP and /usr/lib/virtualbox/VBoxNetNAT happens on VB 5.2 Beta3 too. I am seeing these crashes since I first started to use Virtualbox around VB4.

Host: Ubuntu 17.04, VB 5.2.0 Beta3 Guest: RHEL6 x86_64

I somehow get the impression it happens with RHEL6 guest more frequently than with for example RHEL7 guest.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use