VirtualBox

Ticket #13835 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

guest additions do not build with 3.20 / 4.0 kernel

Reported by: robatino Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.22 Keywords:
Cc: Guest type: Linux
Host type: other

Description

Error from Fedora Rawhide x86_64 guest with 3.20.0-0.rc0.git5.1.fc23.x86_64:

Error! Bad return status for module build on kernel: 3.20.0-0.rc0.git5.1.fc23.x86_64 (x86_64)
Consult /var/lib/dkms/vboxguest/4.3.22/build/make.log for more information.

Attachments

make.log Download (9.2 KB) - added by robatino 3 years ago.
/var/lib/dkms/vboxguest/4.3.22/build/make.log
VBox.log Download (112.9 KB) - added by robatino 3 years ago.
make.2.log Download (8.4 KB) - added by Dom 3 years ago.
VBox.2.log Download (62.4 KB) - added by Dom 3 years ago.

Change History

Changed 3 years ago by robatino

/var/lib/dkms/vboxguest/4.3.22/build/make.log

Changed 3 years ago by robatino

comment:1 Changed 3 years ago by Perryg

Adding to follow ticket

comment:2 Changed 3 years ago by michael

No time to look at this properly now, but some notes after a quick look. The BDI_* flags in question were only ever relevant for MMU-less systems and can probably go unconditionally from our driver. See also commit b4caecd4<1>. The structure member was removed in commit b83ae6d4<2>. Sadly no defines changed in that commit that we can test for.

<1>  https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/diff/?id=b4caecd48005fbed3949dde6c1cb233142fd69e9
<2>  https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/diff/?id=b83ae6d421435c6204150300f1c25bfbd39cd62b

comment:3 Changed 3 years ago by frank

Should be fixed. Could you check for the latest 4.3 Additions in the test builds page?

comment:4 Changed 3 years ago by robatino

VBoxGuestAdditions_4.3.23-98490.iso both allows building the guest additions for the 3.20 kernel, and allows graphical mode to work (I've been running the 3.19 kernel with the old guest additions, and graphical mode hadn't worked since a recent Xorg update). Thanks!

comment:5 Changed 3 years ago by Dom

Can you point me to the 4.3.23 build for Linux amd64 please (Base + exte pack + iso)? The tesbuilds page is pointing to 4.3.21.

Last edited 3 years ago by Dom (previous) (diff)

comment:6 Changed 3 years ago by frank

Just use the "Guest Additions" build, that's the .iso image which does also support Linux guests.

comment:7 Changed 3 years ago by Dom

Hi Frank, ok I have raised a new case because in my case it is the dkms build that fails.

https://www.virtualbox.org/ticket/13888

comment:8 Changed 3 years ago by Dom

Hi Frank

Ok, saw that you set my case https://www.virtualbox.org/ticket/13888 as a dup of this one. Can you provide me with the amd64 package for Linux, guest iso, and ext-pack for 4.3.23 please?

Thanks, Dom

comment:9 Changed 3 years ago by frank

Again: Please download the "Guest Additions" build from the testbuilds page as I already mentioned above!

comment:10 Changed 3 years ago by Dom

Hi Frank,

I did download it. But my issue is that I can't even get to install the guest additions because the base installation of Virtual Box itself fails on the DKMS build during the installation of 4.3.22. So the steps I usually follow are:

1.Install debian package for VirtualBox

  1. Install extension pack
  2. Install guest additions.

At step 1, I get the following:

sudo apt-get install virtualbox-4.3 Reading package lists... Done Building dependency tree Reading state information... Done The following extra packages will be installed:

dkms

The following NEW packages will be installed:

dkms virtualbox-4.3

0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/65.1 MB of archives. After this operation, 152 MB of additional disk space will be used. Do you want to continue? [Y/n] y Preconfiguring packages ... Selecting previously unselected package virtualbox-4.3. (Reading database ... 284817 files and directories currently installed.) Preparing to unpack .../virtualbox-4.3_4.3.22-98236~Ubuntu~raring_amd64.deb ... Unpacking virtualbox-4.3 (4.3.22-98236~Ubuntu~raring) ... Selecting previously unselected package dkms. Preparing to unpack .../dkms_2.2.0.3-1.1ubuntu5.14.04_all.deb ... Unpacking dkms (2.2.0.3-1.1ubuntu5.14.04) ... Processing triggers for ureadahead (0.100.0-16) ... Processing triggers for hicolor-icon-theme (0.13-1) ... Processing triggers for shared-mime-info (1.2-0ubuntu3) ... Processing triggers for mime-support (3.54ubuntu1.1) ... Processing triggers for gnome-menus (3.10.1-0ubuntu2) ... Processing triggers for desktop-file-utils (0.22-1ubuntu1) ... Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ... Rebuilding /usr/share/applications/bamf-2.index... Processing triggers for man-db (2.6.7.1-1ubuntu1) ... Setting up virtualbox-4.3 (4.3.22-98236~Ubuntu~raring) ... addgroup: The group `vboxusers' already exists and is not a system group. Exiting. Stopping VirtualBox kernel modules ...done. Uninstalling old VirtualBox DKMS kernel modules ...done. Trying to register the VirtualBox kernel modules using DKMSERROR (dkms apport): kernel package linux-headers-4.0.0-999-generic is not supported Error! Bad return status for module build on kernel: 4.0.0-999-generic (x86_64) Consult /var/lib/dkms/vboxhost/4.3.22/build/make.log for more information.

...failed!

(Failed, trying without DKMS)

Recompiling VirtualBox kernel modules ...failed!

(Look at /var/log/vbox-install.log to find out what went wrong)

Setting up dkms (2.2.0.3-1.1ubuntu5.14.04) ... Processing triggers for ureadahead (0.100.0-16) ...

Last edited 3 years ago by Dom (previous) (diff)

comment:11 Changed 3 years ago by frank

Oh, then this must be a different problem. Unfortunately the logfile from your ticket doesn't show any hint. Please have a look at

/var/lib/dkms/<your_module_name>/<your_module_version>/build/make.log

Changed 3 years ago by Dom

comment:12 Changed 3 years ago by Dom

Ok, I added make.2.log

comment:13 Changed 3 years ago by frank

Ok, it turns out that the host drivers code needs also an update, I missed that before, sorry. I've updated the Linux packages on the test builds page. Please let me know if they work for you. No need for a new ExtPack or another Additions.iso.

comment:14 Changed 3 years ago by Dom

Hi Frank,

So the DMKS build and install work.Now what happens when I start my Windows guest (tried 4 times), the Guest machine and the Host machine totally freeze up and I have to manually power down. At each of the 4 attempts, the Windows Host froze ad different stages of the bootup process. Keep in mind I had to install ext-pack for 4.3.22. The reason being that it said my machine has saved state information that I was using USB 2.0.

Last edited 3 years ago by Dom (previous) (diff)

comment:15 Changed 3 years ago by Dom

Attached VBox.2.log

Last edited 3 years ago by Dom (previous) (diff)

Changed 3 years ago by Dom

comment:16 Changed 3 years ago by Dom

Hi Frank, do you need any other logs?

comment:17 Changed 3 years ago by frank

I don't need logs. At the moment I think it could be a bug in the Linux kernel. I ran Linux 4.0-rc1 today as well and saw one host lookup which I never saw before using stable kernels. Therefore I recommend to use a stable Linux kernel (-rc1 could still contain bugs).

comment:18 Changed 3 years ago by Dom

Thanks Frank, I will wait for a stable release then. When do you foresee 4.3.23 being released?

comment:19 Changed 3 years ago by frank

The next release will be 4.3.24 (uneven build numbers denote development releases) and I cannot provide you an exact release day. But it's NOT in the range of many week, sorry for being unspecific.

comment:20 Changed 3 years ago by Dom

Great, thanks Frank, you have been a great help :)

comment:21 Changed 3 years ago by frank

VBox 4.3.24 contains the adaptions for Linux 4.0. However, I will keep this defect open until we can rule out any incompatibilities of VBox with Linux 4.0.

comment:22 Changed 3 years ago by Dom

Thanks. I just saw 4.3.24 is out so I will give it a try.

comment:23 Changed 3 years ago by valdis

Heads up - am seeing a consistent crash with 4.0-rc1 and linux-next kernels with a strange traceback:

[  395.739996] Call Trace:
[  395.740000]  <IRQ> 
[  395.740003]  [<ffffffffa80b83d6>] generic_smp_call_function_single_interrupt+0x108/0x1ca
[  395.740018]  [<ffffffffa80297bb>] smp_call_function_interrupt+0x18/0x26
[  395.740025]  [<ffffffffa871de70>] call_function_interrupt+0x70/0x80
[  395.740028]  <EOI> 
[  395.740031]  [<ffffffffa8085e8d>] ? trace_hardirqs_off_caller+0x1f/0xac
[  395.740046]  [<ffffffffa84a23fa>] ? cpuidle_enter_state+0x60/0xb3
[  395.740052]  [<ffffffffa80885fb>] ? trace_hardirqs_on+0xd/0xf
[  395.740058]  [<ffffffffa84a23fe>] ? cpuidle_enter_state+0x64/0xb3
[  395.740065]  [<ffffffffa84a23fa>] ? cpuidle_enter_state+0x60/0xb3
[  395.740071]  [<ffffffffa84a2479>] cpuidle_enter+0x17/0x19
[  395.740078]  [<ffffffffa8080853>] cpu_startup_entry+0x286/0x3e7
[  395.740084]  [<ffffffffa80b0119>] ? clockevents_register_device+0x1e6/0x207
[  395.740091]  [<ffffffffa802a168>] start_secondary+0x14e/0x17b

Yeah, no obvious reason for it to crash *there*....

It bisects down to this commit:

commit 1e02ce4cccdcb9688386e5b8d2c9fa4660b45389 Author: Andy Lutomirski <luto@…> Date: Fri Oct 24 15:58:08 2014 -0700

x86: Store a per-cpu shadow copy of CR4

Context switches and TLB flushes can change individual bits of CR4. CR4 reads take several cycles, so store a shadow copy of CR4 in a per-cpu variable.

I'm reasonably sure that the problem is that VirtualBox isn't onboard with the whole shadow copy thing, and hilarity and hijinks result when it twiddles CR4 and doesn't update the shadow copy, and they get out of sync. Some quick grepping suggests the problem is in vboxdrv/SUPDrv.c but I can't prove it.

Fortunately, we're still at -rc1, so there's still time to sort this out....

Last edited 3 years ago by valdis (previous) (diff)

comment:24 Changed 3 years ago by frank

Thank you for this valuable information! We will check this out.

comment:25 Changed 3 years ago by colorprint

I have the same problem with 4.0-rc2 kernel - system crash when try to start VM. With 3.19 kernel it works fine.

comment:26 Changed 3 years ago by frank

  • Summary changed from guest additions do not build with 3.20 kernel to guest additions do not build with 3.20 / 4.0 kernel

To say it explicit: Current VBox versions will NOT properly run on Linux 4.0, expect host crashes. The next 4.3.x maintenance release will contain a fix.

comment:27 Changed 3 years ago by frank

See our test builds page for Linux test builds for 32-bit hosts and 64-bit hosts. These build contain the fix. It is NOT sufficient to update the host driver, the VBox code needs to be updated as well, so you would need to install the test build to confirm.

comment:28 Changed 3 years ago by colorprint

Yes, the test build works fine with 4.0-rc2 kernel. Thanks!

comment:29 Changed 3 years ago by valdis

Verifying that test build 98815 works with 4.0.0-rc2-next-20150306 as well.

comment:30 Changed 3 years ago by Dom

Cool, I just tried 4.0 rc3 and Vbox 4.3.25 and all is good now. Looking forward to GA releases on both ends.

comment:31 Changed 3 years ago by valdis

I've seen these two errors several times, not sure what triggers it. It's quite possible the second one is a result of wreckage left behind by the first error.

Running test build 98815, 64-bit Linux host....

Splat number 1:

[  745.447240] NET: Registered protocol family 40
[  745.480639] BUG: unable to handle kernel NULL pointer dereference at 000000000000009d
[  745.480647] IP: [<ffffffffc0c42807>] VSockVmciStreamSendmsg+0x55/0x351 [vsock]
[  745.480654] PGD 0 
[  745.480656] Oops: 0000 [#1] PREEMPT SMP 
[  745.480661] Modules linked in: vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) vmnet(OE) vsock(OE) vmw_vmci vmmon(OE) ts_bm nf
_log_ipv4 xt_string nf_log_ipv6 nf_log_common xt_LOG vfat fat nvidia(OE) brcmsmac cordic brcmutil x86_pkg_temp_thermal crct10dif_pclmul
 crc32_pclmul i8k crc32c_intel ghash_clmulni_intel cryptd bcma dell_smo8800 nfsd auth_rpcgss nfs_acl lockd grace sunrpc
[  745.480691] CPU: 0 PID: 5639 Comm: vmplayer Tainted: G           OE   4.0.0-rc3-next-20150310-dirty #22
[  745.480694] Hardware name: Dell Inc. Latitude E6530/07Y85M, BIOS A16 09/24/2014
[  745.480696] task: ffff88006b839310 ti: ffff88020d95c000 task.ti: ffff88020d95c000
[  745.480698] RIP: 0010:[<ffffffffc0c42807>]  [<ffffffffc0c42807>] VSockVmciStreamSendmsg+0x55/0x351 [vsock]
[  745.480702] RSP: 0018:ffff88020d95fca8  EFLAGS: 00010292
[  745.480704] RAX: ffff88020d95fce0 RBX: 0000000000000055 RCX: 0000000000000000
[  745.480705] RDX: 0000000000000055 RSI: ffff88020d95fd70 RDI: ffff88020d95fcf0
[  745.480707] RBP: ffff88020d95fd28 R08: 0000000000000000 R09: 0000000000000000
[  745.480709] R10: ffff88006b839310 R11: 0000000000000293 R12: ffff88020d95fd70
[  745.480710] R13: 0000000000000055 R14: 0000000000000055 R15: 0000000000000000
[  745.480712] FS:  00007f2b98bd9740(0000) GS:ffff88022dc00000(0000) knlGS:0000000000000000
[  745.480714] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  745.480715] CR2: 000000000000009d CR3: 000000019dc56000 CR4: 00000000001407f0
[  745.480716] Stack:
[  745.480718]  0000000000000000 0000000000000000 0000000000000000 0000000000000000
[  745.480722]  0000000000000000 ffff88006b839310 ffffffff9708032e 0000000000000000
[  745.480725]  0000000000000000 0000000018a5eaa3 ffff88020d95fd70 ffff8800bd654c00
[  745.480729] Call Trace:
[  745.480736]  [<ffffffff9708032e>] ? __wake_up_sync+0x12/0x12
[  745.480740]  [<ffffffff9751f9aa>] sock_sendmsg+0x34/0x3c
[  745.480742]  [<ffffffff9751fa36>] sock_write_iter+0x84/0xb0
[  745.480746]  [<ffffffff97169eae>] new_sync_write+0x8b/0xc3
[  745.480749]  [<ffffffff9716a658>] vfs_write+0xf1/0x15a
[  745.480751]  [<ffffffff9716aee0>] SyS_write+0x5d/0x9f
[  745.480755]  [<ffffffff9771fa39>] system_call_fastpath+0x12/0x17
[  745.480757] Code: 04 25 28 00 00 00 48 89 45 c8 31 c0 f3 ab 48 c7 45 b0 2e 03 08 97 65 48 8b 04 25 80 aa 00 00 48 89 45 a8 48 8d 45 
a0 48 83 c0 18 <f6> 42 48 01 48 89 45 b8 48 89 45 c0 b8 a1 ff ff ff 0f 85 c2 02 
[  745.480805] RIP  [<ffffffffc0c42807>] VSockVmciStreamSendmsg+0x55/0x351 [vsock]
[  745.480808]  RSP <ffff88020d95fca8>
[  745.480810] CR2: 000000000000009d
[  745.480812] ---[ end trace 3fa727c07fff3ac7 ]---

Splat number 2:

[ 3393.312753] BUG: sleeping function called from invalid context at kernel/locking/mutex.c:622
[ 3393.312759] in_atomic(): 1, irqs_disabled(): 0, pid: 5364, name: vmx-vcpu-0
[ 3393.312760] INFO: lockdep is turned off.
[ 3393.312763] CPU: 3 PID: 5364 Comm: vmx-vcpu-0 Tainted: G      D    OE   4.0.0-rc3-next-20150310-dirty #22
[ 3393.312765] Hardware name: Dell Inc. Latitude E6530/07Y85M, BIOS A16 09/24/2014
[ 3393.312767]  0000000000000000 00000000d1db2df5 ffff8800895d7a58 ffffffff8f715a95
[ 3393.312771]  ffff8800895cd290 00000000000014f4 ffff8800895d7a88 ffffffff8f06a69d
[ 3393.312775]  ffff8800ba72ac18 0000000000000000 ffff8801670af430 000000000000026e
[ 3393.312780] Call Trace:
[ 3393.312787]  [<ffffffff8f715a95>] dump_stack+0x50/0xa8
[ 3393.312791]  [<ffffffff8f06a69d>] ___might_sleep+0x1c6/0x1cf
[ 3393.312793]  [<ffffffff8f06a78d>] __might_sleep+0xe7/0xf6
[ 3393.312797]  [<ffffffff8f71ac72>] mutex_lock_nested+0x3e/0x5f3
[ 3393.312804]  [<ffffffffc0c2b7a5>] qp_acquire_queue_mutex.isra.7+0x20/0x22 [vmw_vmci]
[ 3393.312808]  [<ffffffffc0c2b7b9>] qp_lock.isra.8+0x12/0x14 [vmw_vmci]
[ 3393.312813]  [<ffffffffc0c2cb03>] vmci_qpair_consume_buf_ready+0x3b/0xa1 [vmw_vmci]
[ 3393.312817]  [<ffffffffc0cc072d>] VSockVmciStreamHasData+0x15/0x17 [vsock]
[ 3393.312820]  [<ffffffffc0cc0b9a>] VSockVmciHandleDetach+0x37/0x69 [vsock]
[ 3393.312824]  [<ffffffffc0cc0ca6>] VSockVmciPeerDetachCB+0x60/0x81 [vsock]
[ 3393.312828]  [<ffffffffc0c29719>] vmci_event_dispatch+0xe9/0x178 [vmw_vmci]
[ 3393.312832]  [<ffffffffc0c287c7>] dg_dispatch_as_host+0xf9/0x269 [vmw_vmci]
[ 3393.312836]  [<ffffffffc0c289a3>] vmci_datagram_dispatch+0x6c/0xd2 [vmw_vmci]
[ 3393.312840]  [<ffffffffc0c2b4fa>] qp_notify_peer+0x96/0xee [vmw_vmci]
[ 3393.312845]  [<ffffffffc0c2df72>] vmci_qp_broker_detach+0x29f/0x30c [vmw_vmci]
[ 3393.312849]  [<ffffffffc0c2abf1>] vmci_host_unlocked_ioctl+0x3ed/0x9e5 [vmw_vmci]
[ 3393.312853]  [<ffffffff8f26aafd>] ? inode_has_perm+0x63/0x6e
[ 3393.312856]  [<ffffffff8f17c5dd>] do_vfs_ioctl+0x421/0x4a3
[ 3393.312859]  [<ffffffff8f17c6b9>] SyS_ioctl+0x5a/0x7f
[ 3393.312862]  [<ffffffff8f71fa39>] system_call_fastpath+0x12/0x17
Last edited 3 years ago by valdis (previous) (diff)

comment:32 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.26. For further issues on Linux 4.0, please open a different ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use