VirtualBox

Ticket #13828 (new defect)

Opened 4 years ago

Last modified 4 years ago

Drag-and-drop not working in either direction

Reported by: gbartlett Owned by:
Component: clipboard Version: VirtualBox 4.3.22
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

Host: Windows 7, all latest updates Guest: XUbuntu 14.04.1, all latest updates

Drag-and-drop does not work in either direction. I have tried changing the menu option to enable it only in one direction, as well as bidirectional, but nothing works.

I've checked the manual, and it says drag-and-drop should work for a Windows host and Linux guest. But in this case it doesn't.

Shared folders do work, so that's my workaround for the moment. (Although there's another bug for shared folders to report separately.)

The clipboard does work for copying text in both directions. It does not let me copy files in either direction. It's not clear from the manual whether it should, but I have to assume it's text-only. (This is a shame, when VMware Player does it fairly seamlessly.)

Attachments

VBox.log Download (68.8 KB) - added by gbartlett 4 years ago.
VM log during drag-and-drop events

Change History

comment:1 Changed 4 years ago by gbartlett

I should also add that I've googled the problem and checked your forums. I've found numerous posts over the years from people where drag-and-drop hasn't worked for them, but I haven't found anything where anyone saw this happening with a similar setup and either couldn't get it working or got an official answer that it didn't work.

comment:2 Changed 4 years ago by gbartlett

Correction: I'm running VirtualBox v4.3.20.

comment:3 Changed 4 years ago by frank

I would like to see a VBox.log file of such a VM session.

Changed 4 years ago by gbartlett

VM log during drag-and-drop events

comment:4 Changed 4 years ago by gbartlett

I've upgraded to 4.3.22 and upgraded the guest additions as well. I've then tested drag-and-drop with all the following permutations:-

  • Drag-and-drop configuration set to host-to-guest, guest-to-host, or bidirectional.
  • Dragging files to/from host desktop or folder.
  • Dragging files to/from guest desktop, folder (in Thunar), or drag-and-drop-aware application (Geany).

The outcome:-

  • Dragging files from the host to the guest desktop works (with host-to-guest or bidirectional mode).
  • Dragging files from the host to Geany works (ditto).
  • Dragging files from the host to a folder open in Thunar does *NOT* work with either configuration.
  • Dragging files from the guest to the host does not work, for any configuration, any file, if the file is dragged from the desktop, or if the file is dragged from a folder open in Thunar.

So there may be a Thunar-specific problem for dragging from host to guest. I haven't tried with a distro using Nautilus (such as stock Ubuntu).

And dragging files from guest to host is simply dead. Unknown whether this is a single cause or multiple causes.

comment:5 Changed 4 years ago by frank

Please note that Drag and Drop is currently only implemented for the Host=>Guest direction.

comment:6 Changed 4 years ago by gbartlett

I have repeated this testing with VirtualBox v5.0. Thunar still does not allow files to be dragged from the host to a Thunar window in guest.

comment:7 Changed 4 years ago by giusi

hi win 10 host win xp guest guest add installed vb vers 5.0.2 latest stable drag n drop not workin at all any ideas..??

comment:8 Changed 4 years ago by Zian

I'm also having this problem.

Host: Windows 7 SP1 x64 running VirtualBox 5.0.2.

Guest: Ubuntu 15.04

Dragging stuff into the VM aborts the VM. Dragging out of the VM to the host results in the following error:

Drag and drop error from guest (VERR_NOT_SUPPORTED).

Result Code: VBOX_E_IPRT_ERROR (0x80BB0005) Component: GuestWrap Interface: IGuest {13a11514-402e-022e-6180-c3944de3f9c8}

comment:9 Changed 4 years ago by frank

Please don't forget to add VBox.log files of such VM sessions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use