VirtualBox

Ticket #13818 (closed defect: obsolete)

Opened 5 years ago

Last modified 21 months ago

USB printer not detected after wake up

Reported by: L. Owned by:
Component: USB Version: VirtualBox 4.3.20
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

Host: Win7 64Bit Guest: Win8 64Bit with guest additions installed

When I start the guest while a usb printer is in sleep mode, Windows thinks that the printer is offline (controlpanel->devices->printer settings) This is oke since the printer is in sleep mode.

However, when I power on the printer with the soft button on the printers panel, windows does not see the printer is.

When I shutdown the guest, restart the guest, the guest sees the printer as online.

This is the situation for which I attached logs files.

Another option to get it working, is disconnect power cord, and connect it again.

The printer is a brother DCP-195C, but I don't think its related to a manufacturer.

This is quite anyoing, its not specific to 4.3.20 but had it also with previous version.

Any idea how to solve this?

Attachments

VBox.log Download (106.5 KB) - added by L. 5 years ago.
VBox.log.1 Download (108.6 KB) - added by L. 5 years ago.
VBoxSVC.log Download (1.6 KB) - added by L. 5 years ago.
VBoxSVC.log.1 Download (2.1 KB) - added by L. 5 years ago.

Change History

Changed 5 years ago by L.

Changed 5 years ago by L.

Changed 5 years ago by L.

Changed 5 years ago by L.

comment:1 Changed 4 years ago by L.

Update 2015-07-06:

Found a problem, last weeks I struggled more and more with the problem that the network card on the host was not being initialized.

Users, belonging only to the 'user' account group, had no connection.

When I logged off the user and logged on myself, the only one belonging to the 'administrators' group, the network icon in the system tray immediately showed up as connected

However, when the other users waited for 3 min, the icon in the systemtray also showed up as connected. And it was always after 3 min.

Since the host boots within 15/20 seconds, the first logon for the user always showed a disconnected icon, and thus the VM guest cannot be started.

Google found some clues directing to a faulty service or application or apps taking a very long time to start.

And indeed I found the culprit: McAfee's Raptor which get installed when using stinger, which I use sometimes.

After removing it, everything works as expected.

Even turning on an usb printer who is offline, shows up in the VM as online within seconds.

For me, its unexplainable why it was working in the past, but giving me more and more problems over the time untill it was not workable anymore (started with the usb then the network card)

These problems are hard to find, don't think VirtualBox can detect such situations, or is this with software possible?

Let you now if the problem has gone forever.

comment:2 Changed 21 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent version of VirtualBox.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use