VirtualBox

Ticket #13782 (closed defect: worksforme)

Opened 6 years ago

Last modified 5 years ago

VERR_SYMBOL_NOT_FOUND on REMR3Init, VMR3Create

Reported by: mrubioroy Owned by:
Component: other Version: VirtualBox 4.3.20
Keywords: Cc:
Guest type: Linux Host type: Windows

Description (last modified by frank) (diff)

Dear developers,

Every time I launch my VM I get a VERR_SYMBOL_NOT_FOUND error. It's apparently linked to the function VMR3Create.

00:00:05.916005 REMR3Init rc=VERR_SYMBOL_NOT_FOUND
00:00:05.916157 VMSetError: F:\tinderbox\win-4.3\src\VBox\VMM\VMMR3\VM.cpp(365) int __cdecl VMR3Create(unsigned int,const struct VMM2USERMETHODS *,void (__cdecl *)(struct UVM *,void *,int,const char *,unsigned int,const char *,const char *,char *),void *,int (__cdecl *)(struct UVM *,struct VM *,void *),void *,struct VM **,struct UVM **); rc=VERR_SYMBOL_NOT_FOUND
00:00:05.916161 VMSetError: Symbol (export) not found.

I've managed to bypass this bug by unplugging the computer from its NAT switch. When unplugged, the VM launches correctly. I can plug it later on without problem.

I've tried different configurations of the VM and all expose the same issue. I send attached the two vbox files I've tested.

I'm using VirtualBox 4.3.20 on an up-to-date Windows XP SP3 host with a Red-Hat (64bit) guest (Scientific Linux 6.6). I will be able to try testbuilds in a couple of weeks.

Attachments

VBox.log Download (27.4 KB) - added by mrubioroy 6 years ago.
VBox.log
VBoxStartup.log Download (498.8 KB) - added by mrubioroy 6 years ago.
VBoxStartup.log
captinov.vbox Download (9.0 KB) - added by mrubioroy 6 years ago.
vbox file 1
uyu.vbox Download (6.7 KB) - added by mrubioroy 6 years ago.
vbox file 2

Change History

Changed 6 years ago by mrubioroy

VBox.log

Changed 6 years ago by mrubioroy

VBoxStartup.log

Changed 6 years ago by mrubioroy

vbox file 1

Changed 6 years ago by mrubioroy

vbox file 2

comment:1 Changed 6 years ago by mrubioroy

I'm using VirtualBox 4.3.20-r96997

comment:2 Changed 6 years ago by frank

  • Description modified (diff)

comment:3 Changed 6 years ago by frank

There is a fundamental problem in loading libraries at VM runtime on your system. The VBox.log file contains a few lines with "... is not available...VERR_SYMBOL_NOT_FOUND". That's not normal and I don't know any other case where this happens.

comment:4 Changed 6 years ago by bird

I think you have some kind of 3rd party antivirus/firewall/protection software installed on your system that does not work correctly with VBox. Would be great to know what it's called and we could maybe see if we can try work around the issues you are experiencing.

comment:5 Changed 5 years ago by William Newton

I solved absolutely identical issue by running followed command and rebooting PC:

netsh int ip reset reset.log

I found this advice here:

webxpert.ro/andrei/2009/03/02/how-to-reset-windows-xp-winsock-and-tcpip-stack-entries

(by Andrei Daneasa)

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use