VirtualBox

Ticket #13628 (closed enhancement: fixed)

Opened 4 years ago

Last modified 8 months ago

iPXE ROM missing HTTP feature

Reported by: linuxgod Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.18 Keywords: PXE
Cc: Guest type: all
Host type: other

Description

The iPXE ROM that is used in recent versions of VirtualBox has a limited feature set. Whereas we use iPXE with HTTP to build thousands of servers, the built-in iPXE ROM lacks this feature. Therefore when booting a VM, iPXE fails with "Could not start download: Operation not supported ( http://ipxe.org/3c092003)".

While there is a workaround of installing the VirtualBox Extensions Pack and then using the Intel PXE ROM instead of iPXE, this problem could be easily resolved by enabling the HTTP feature in the iPXE ROM.

Change History

comment:1 Changed 4 years ago by klaus

Note that the available ROM space is very tight, which is why we had to disable pretty much all convenience features going beyond the bare minimum required by the PXE spec.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Nevertheless we enabled this config option in VBox 4.3.20.

comment:3 Changed 4 years ago by socratis

That has got to be the fastest fix in VBox's history. 24 hours from filing to resolved and made it in the 4.3.20 in another hour! Wow! ;)

comment:4 Changed 4 years ago by kemad

FYI: the HTTP feature is disabled again in VBox 4.3.24.

comment:5 Changed 4 years ago by frank

kemad, weird. We didn't change anything in this regards. Which host are you using and which package did you install (exact package name please)?

comment:6 Changed 3 years ago by MyDogHasFleas

  • Status changed from closed to reopened
  • Resolution fixed deleted

Running VirtualBox 5.0.12r104815, removed the Extension Pack. Originally dowloaded from VirtualBox.org.

When I do a PXE boot, I see on the VM window:

IPXE 1.0.0.+ - Open Source Boot Firmware --  http://ipxe.org Features: DNS TFTP PXE PXEXT Menu

as you can see, no HTTP feature.

Please re-enable this config option for IPXE Boot ROM! thanks.

comment:7 Changed 3 years ago by MyDogHasFleas

Forgot to mention, if it matters, I'm running on OS X 10.11.3.

Just upgraded to latest 5.0.14r105127 and same issue.

comment:8 Changed 3 years ago by frank

Confirmed. This change was not intended. The latest test builds have the HTTP code re-enabled in iPXE.

comment:9 Changed 3 years ago by MyDogHasFleas

I installed the test build and indeed the HTTP feature is now enabled in iPXE, thanks.

However, still cannot boot Linux (specifically CoreOS Linux) because the bzimage feature is needed to support the CoreOS cpio.gz file.

Is it possible, please, to also enable the bzimage feature in your iPXE? Thanks.

here's my iPXE script if it matters:

kernel /assets/coreos/current/coreos_production_pxe.vmlinuz coreos.autologin coreos.config.url=http://10.3.0.154:8080/ignition?uuid=dontmatch coreos.first_boot=1
initrd /assets/coreos/current/coreos_production_pxe_image.cpio.gz
boot

comment:10 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.16.

comment:11 Changed 8 months ago by Attila123

As for the bzimage feature and CoreOS, as I also commented on https://www.virtualbox.org/ticket/15159:

I solved this issue with the ipxe.iso available from  https://boot.ipxe.org/ipxe.iso (see  https://ipxe.org/download).

Just download it and set it for your virtual Optical drive. Then in the "System" tab of your VM settings make sure to set the Boot Order so that "Optical" is below "Hard Disk" - to prevent from booting from this iso once your OS is already installed.

I also tried to compile this iso for myself with a recent versions of isolinux, which somehow did not work correctly (freezes half-way when loading the CoreOS kernel, or the next file). But the one linked above does work, so for the record, it is based on isolinux 3.83 and the iPXE version in it is iPXE 1.0.0+ (8c17). Hope it will help someone.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use