VirtualBox

Ticket #13617 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Startup fails if HDD image is immutable and not enough CPU power available

Reported by: mskov Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.18 Keywords:
Cc: Guest type: all
Host type: Windows

Description

When HDD image is set to "immutable" and there is not enough CPU power available - VirtualBox crases with

Fehlercode: VBOX_E_INVALID_OBJECT_STATE (0x80BB0007) Komponente: ProgressProxy Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}

The problem is independent of the guest type (startup with empty HDD images fails as well). I can always reproduce the problem when running a host with 1 CPU core without VT-x (don't know if the problem also occurs with VT-x).

The problem occurs (at least) for VirtualBox 4.3.12 - 4.3.18

In the VBoxSVC.log one can find:

ERROR [COM]: aRC=VBOX_E_INVALID_OBJECT_STATE (0x80bb0007) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Medium 'C:\Users\trusteddisk\VirtualBox VMs\test\Snapshots/{402ef805-c1e2-4022-a4b1-65d3c194dd61}.vdi' is locked for writing by another task}, preserve=false

So my guess is that the automatic resetting of the "diff" file for immutable images takes longer than it should if not enough CPU power is available and at the time of the actual startup the image is still being reset.

Attachments

VBox.log Download (938 bytes) - added by mskov 3 years ago.
VBoxStartup.log Download (265.2 KB) - added by mskov 3 years ago.
VBoxSVC.log Download (2.4 KB) - added by mskov 3 years ago.

Change History

Changed 3 years ago by mskov

Changed 3 years ago by mskov

Changed 3 years ago by mskov

comment:1 Changed 3 years ago by klaus

The guess should be wrong... VirtualBox is very patient with waiting for the disk image reset function to complete. Actually it doesn't do much: effectively the reset function deletes the old image and creates a new one. Deleting a file isn't expensive, and creating a new one also doesn't cost much (typically 1-2MB of data needs to be written). Never saw anything like this.

BTW, an error message is not the same thing as a crash, and in this case it's clearly the former. The message unfortunately doesn't give much hint what exactly failed and why, so it's a somewhat unhelpful one.

comment:2 Changed 3 years ago by mskov

Sorry for being imprecise. Indeed, my guess is probably wrong because the problem also occurs in case if the immutable image is restored to an "online" screenshot before startup and no image reset should be done at all.

comment:3 Changed 3 years ago by frank

I think we finally were able to reproduce and fix the problem you saw. Would you mind confirming that the most recent Windows test build from here fixes your problem?

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.28.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use