VirtualBox

Ticket #13612 (closed defect: fixed)

Opened 8 years ago

Last modified 6 years ago

Vboxmanage bandwidthctl disk does not work for Windows and Linux

Reported by: RohitJ Owned by:
Component: VM control Version: VirtualBox 4.3.18
Keywords: Cc:
Guest type: Linux Host type: Linux

Description (last modified by frank) (diff)

I have tried running as per the advice in the manual (of course replacing the appropriate "VM name" and ports):

VBoxManage bandwidthctl "VM name" add Limit --type disk --limit 20M
VBoxManage storageattach "VM name" --storagectl "SATA" --port 0 --device 0 --type hdd --medium disk1.vdi --bandwidthgroup Limit
VBoxManage storageattach "VM name" --storagectl "SATA" --port 1 --device 0 --type hdd --medium disk2.vdi --bandwidthgroup Limit

However, when I run fio benchmark to check I am always getting a bandwidth which is not related to the limit I set.

So, I ran the fio benchmark with ioengine=posixaio to make sure that the io is asynchronous, however I see no difference.

This runs fine on a host MAC and guest Ubuntu and there are issues with host Windows, Ubuntu and RHEL6.

The guest version on host Ubuntu:

Linux abcdef-VirtualBox 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:12 UTC 2014 i686 i686 i686 GNU/Linux

The host version on Ubuntu:

Linux cs736 3.13.0.37-generic #64-ubuntu SMP Mon Sep 22 21:30:01 UTC 2014 i686 i686 i686 GNU/Linux

The guest version on host Mac:

Linux shachi-VirtualBox 3.13.0-32-generic #57~precise1-Ubuntu SMP Tue Jul 15 03:51:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

The host version on host Mac:

Darwin Shachi.local 14.0.0 Darwin Kernel Version 14.0.0: Fri Sep 19 00:26:44 PDT 2014; root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64

Attachments

VBox.log.1 Download (83.5 KB) - added by RohitJ 8 years ago.
This is the log of the guest where we see that the bandwidthctl is not working

Change History

Changed 8 years ago by RohitJ

This is the log of the guest where we see that the bandwidthctl is not working

comment:1 Changed 8 years ago by frank

  • priority changed from blocker to major
  • Description modified (diff)

comment:2 Changed 6 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

The limit you set is not 20MB/s but merely 20KB/s as can be seen from the log. I don't think this was intended, however there is a fix in the most recent VirtualBox release which fixes bandwidth limits with very small values, so I'll mark this as fixed.

Btw., the bandwidth limit applies to the real I/O on the host for disk reads and writes. If the disk image has a lot of unallocated blocks reads will not produce any I/O and the benchmark in the guest will report much higer numbers if no data was written prior to the read.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use