VirtualBox

Ticket #13530 (closed defect: obsolete)

Opened 8 years ago

Last modified 6 years ago

Passed through USB keyboard is missing some random keystrokes when typing normally.

Reported by: acathla2 Owned by:
Component: USB Version: VirtualBox 4.3.18
Keywords: Cc:
Guest type: all Host type: Linux

Description

Take a virtualbox 4.3.14, 4.3.16, 4.3.18 on ubuntu 14.04 as a host and linux/windows as a guest. Pass the keyboard to the VM and try typing something : random letters will be missing.

Version 4.3.12 and before are working correctly.

Usually the keyboard is managed by the host but when it is equipped with a card reader, for example, someone could want it to be passed directly to the guest.

It's not critical but could be the source of problems for other devices.

Attachments

VBox.log Download (69.7 KB) - added by acathla2 8 years ago.
VM log file for normal start then plug in of the keyboard

Change History

comment:1 Changed 8 years ago by michael

Would you be interested in trying out different revisions to bisect this? You would have to be willing to install from shell script installers as described on the test build page<1>, and tell me whether you are running 32-bit or 64-bit Linux on your host. Posting a log file from a VM run would of course be highly appreciated too.

<1> https://www.virtualbox.org/wiki/Testbuilds

Changed 8 years ago by acathla2

VM log file for normal start then plug in of the keyboard

comment:2 Changed 8 years ago by acathla2

I just tried VirtualBox-4.3.21-97018-Linux_amd64.run with the right guest additions (only on windows 32bits this time) and Oracle extension pack and the problem is the same.
Logs attached

comment:3 Changed 6 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use