VirtualBox

Ticket #1347 (reopened defect)

Opened 6 years ago

Last modified 3 months ago

USB device reported working, but no communication

Reported by: mludwig Owned by:
Priority: major Component: USB
Version: VirtualBox 1.5.6 Keywords: USB appears working no communication
Cc: Guest type: other
Host type: other

Description

I would like to report a USB device that appears as working in the guest OS, but programs cannot communicate with it. I am using Vista 64-bit with XP 32-bit in VirtualBox. The main reason for using virtualization is the unavailability of a 64-bit driver for a reprogrammable USB FPGA board. This little board can be programmed using a utility (Adept Suite) of the manufacturer (Digilent). I added a USB filter for this device in VirtualBox and it got detected in the guest OS and installed the correct driver for it. It appears as enabled and working in Device Manager. The utility can also detect the board and its ID. However, when it tries to communicate with it (Initialize Chain) it fails. I can confirm that this same setup with another virtualization software works and the utility can communicate to the board. I would gladly provide any kind of dump, log or other debug data for investigation.

Attachments

Logs.tar.gz Download (280.0 KB) - added by andreweff 3 years ago.
Several Logs in which this problem occurs.

Change History

comment:1 Changed 6 years ago by cornbread

Same deal I have. Bug #1051. I talked to the devs on irc and they said don't hold your breath on usb working on my device any time soon.

comment:2 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with 1.6.0 and report back if it's still relevant. Thanks.

comment:3 Changed 6 years ago by mludwig

  • Status changed from closed to reopened
  • Resolution fixed deleted

I set up a new 32-bit XP SP3 VM in 1.6.0 and I got the same result, it appears working, but communication fails. Activating USB devices in the VM also fails sometimes with no error message ie. clicking on a device on the USB list does nothing. Other times I get a crash on the host: Product Sun xVM VirtualBox Interface

Problem Stopped working

Date 2008.05.03. 4:03

Status Not Reported

Problem signature Problem Event Name: APPCRASH Application Name: VBoxSVC.exe Application Version: 1.0.0.1 Application Timestamp: 4818d40b Fault Module Name: VBoxDDU.dll Fault Module Version: 0.0.0.0 Fault Module Timestamp: 4818d31d Exception Code: c0000005 Exception Offset: 00000000000196e4 OS Version: 6.0.6001.2.1.0.256.6 Locale ID: 1038 Additional Information 1: 80ad Additional Information 2: 922c9c6d5745beeb98fd45a7b83b0223 Additional Information 3: 5cb6 Additional Information 4: 57cd1eed70ec2a428d77631cff6b5e38

The problem seems not limited to my FPGA board, but also a "Mass storage device" (USB external hard drive). Let me know, if you need other debug data.

comment:4 Changed 6 years ago by frank

  • Component changed from other to USB

comment:5 Changed 6 years ago by mludwig

Just confirming that the the same issue is experienced in VirtualBox 2.0.2 and it is consistent with other user reports of not all USB working.

comment:6 Changed 5 years ago by ZhekaS

Same issue in VirtualBox 3.0.4 (and older). No progress since 2.0.1 .

comment:7 Changed 5 years ago by michael

Unfortunately, there will probably always be a number of unsupported USB devices in VirtualBox, since every device has a few quirks of its own, to which VirtualBox has to be adjusted. That said, VirtualBox USB support is being worked on continuously, and it is always worth checking whether new versions make unsupported devices work.

comment:8 Changed 4 years ago by xoby

The problem is still present with VirtualBox v3.1.8 (tested with Digilent Adept, Basys 2 board, a linux 64 bits host and a Windows XP guest).

comment:9 Changed 4 years ago by cgreco

Communication problem persists with VirtualBox 3.2.0, Digilent Adept 2-3-0, Basys2 board, Debian linux 64 bit (lenny) host and Window 7 Enterprise guest. Board recognized but cannot initialize. Apparently, reading from device is functional but cannot write to the device.

comment:10 Changed 4 years ago by jwcxz

Issue still exists with 3.2.8. Same behavior as above. Arch Linux, Kernel 2.6.35.3, Digilent Adept 2.4 with Nexys2 board on a Windows XP guest.

comment:11 Changed 3 years ago by erhardm

The same problem exist in version 4.0.4 r70112

comment:12 Changed 3 years ago by andreweff

This problem persists in version 4.0.10 with Arch Linux kernel 2.6.39 as the host and windows 7 32 bit as the guest.

comment:13 Changed 3 years ago by frank

andreweff, which package did you use? The official package from our website or an Arch Linux package?

comment:14 Changed 3 years ago by andreweff

I used this package:  http://www.archlinux.org/packages/community/x86_64/virtualbox/ I could try the package from the website but I'd imagine that the arch package is based on it.

comment:15 Changed 3 years ago by frank

That's easy to find out if you attach a VBox.log file from such a VM session to this ticket.

Changed 3 years ago by andreweff

Several Logs in which this problem occurs.

comment:16 Changed 3 years ago by frank

In that case the case is clear. The Arch Linux guys use the official source code for compiling their own package. For proper USB 2.0 support, the extension pack is required but due to a bug this does not help for VBox 4.0.10. I'm quite sure that your problems result from this bug. That bug will be fixed in the next maintenance release.

comment:17 Changed 3 years ago by andreweff

I think I have the extension pack installed as well. Does this bug mean that this issue will occur even with the extension pack? If I am somehow able to rollback to a version that doesn't have this bug should it work? What is the latest version that doesn't have this bug?

arch extension package:  http://aur.archlinux.org/packages.php?ID=44761

comment:18 Changed 3 years ago by frank

The Arch extension pack is just the official extension pack from the VirtualBox download site. Yes, even if the extension pack is installed you wouldn't be able to enable USB 2.0 devices. Either install the official package (the universal.run package in your case) or install any 3.2.x package.

comment:19 Changed 2 years ago by vollkorn

Same problem with 4.1.4. I'm using Max OS X 10.7.2 as host and Windows XP SP3 as guest. Digilents Adept is able to identify the device (Basys 2) but when I try to connect it reports "Initialization failed. Check connection and try again". Would be great if the bug gets fixed in near future :)

comment:20 Changed 3 months ago by rafoakwa

Same problem persists using MAC OS 10.9.1 as host and Windows 7 as guest on VB 4.3.2. A fix would be very much appreciated. Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use