VirtualBox

Ticket #13399 (closed defect: obsolete)

Opened 3 years ago

Last modified 13 months ago

Regression in 4.3.16 - full screen mode unusable

Reported by: Rafcio Owned by:
Priority: critical Component: VM control
Version: VirtualBox 4.3.16 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

There is a severe regression in 4.3.16 that makes the full screen mode unusable. The hosts is Red Hat Linux 6.4, the client is Windows 7. What happens is that in full screen mode the VM menu that pops up from the bottom (Machine, View, Devices, etc.) blocks the area, even after the menu hides. The menu area is always visible, even if the menu is hidden. It is frequently unpainted properly, leaving what was previously in that area still there, even though it wasn't the part of the menu. When the menu is brought up and then it hides, the painting occurs, but it just erases the remains of another window, but the area remains "blank" and it blocks the portion of the client's task bar, making the work in the client pretty much imposible. Again, the menu hides, but the menu area remains always visible blocking the portion of the client's window at the bottom. I had to remove 4.3.16 and install 4.3.14 to be able to use the full screen client session. I upgraded from 4.3.12 directly to 4.3.16, but I doubt that this matters. Regarding that menu bar in the versions prior to 4.3.16. There is a minor issue and I think I could mention this here. The VM has 2 screens. The menu bar on the secondary window, which happens to be on the primary window of the host machine has 2 issues. When the machine is started with both screens enabled in the client (available through Screen Resolution) the menu bar, which is just a narrow stripe at the bottom is about 25% of the full length of the entire menu bar. When the menu is then brought up with the mouse action and then it hides itself (even without any action on the menu itself) the entire length of the stripe is shown. However, if the client is started with just one screen enabled, and then subsequently the second screen is enabled (again through Screen Resolution), the narrow stripe on the secondary window bottom is not visible at all. This brings me to another, more serious issue with the menu bar. Frequently, but I can't find any pattern of when this happens, regardless whether the narrow stripe of the hidden menu is visible or not, bringing the mouse cursor over that stripe (or the place where it supposed to be) doesn't bring the VM menu up. I can keep that mouse cursor over the stripe or move it over the stripe, and still the menu won't pop up. I noticed that if I keep moving the mouse up and down, perhaps even clicking within the client window above, eventually after several attempts the VM menu will show up. I have to frequently minimize that secondary client window in order to gain access to the host's task bar and icons on the host's desktop, so this is really annoying. Both VM screens are always enabled in the VM definition, however I have to disable the secondary screen when working without the external monitor, because certain client applications (like Firefox) will always show up on the secondary screen, regardless of whether it is connected or not. The host machine is a laptop with external monitor connected, however if I undock the laptop (or just boot the VM without the external monitor attached) I have to disable the secondary screen in the client in order to see all client's applications on the remaining main screen. The VM is set to work in full screen mode, hence the regression is the latest release makes the work impossible with portion of the client window constantly blocked by the menu area, but the primary client window is set to be visible on the external monitor (which has a higher resolution than the laptop screen) and secondary window to show on the laptop screen, which is the main screen (with task bar, etc.) of the host OS (Linux). Another "issue" with the VM menu is that on the client's main screen (and the host's secondary screen) the VM menu pops up too quickly (opposite to what happens on the other screen). When I bring the mouse just a little too far to the bottom (to click on the client task bar) the menu immediately pops up making me click accidentally on something in the VM menu instead on the right icon on the client's task bar. This is annoying too. This isn't a rule however, sometimes the VM menu behaves exactly like on the secondary window, that it it won't pop up unless I move the mouse up and down may times, I mean many times.

Attachments

vbox.tar.gz Download (24.5 KB) - added by Rafcio 3 years ago.
Log

Change History

Changed 3 years ago by Rafcio

Log

comment:1 Changed 3 years ago by michael

Could you please try a recent test build<1> to see if the problem is still reproducible there?

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:2 Changed 3 years ago by rclocher3

I believe I'm also affected by this bug; see my  forum post.

comment:3 Changed 3 years ago by Rafcio

The regression is fixed in the test build, which is a major bug. However, the less severe bugs that I mentioned are still there. Well, at least one of them for sure. The mouse over the menu issue that doesn't pop up with mouse over the menu stripe and takes many mouse moves up and down for the menu to show. That's mostly the behavior, but sometimes the VM menu pops up immediately, in my opinion too early. Very inconsistent behavior, but this is not a regression in a recent build. I couldn't test the partial menu stripe on the secondary window, or the stripe that is initially invisible (also on secondary window) as my external monitor is at a different location.

comment:4 Changed 3 years ago by frank

When reporting problems please:

  1. Keep your report short and descriptive. The more time we need to read your report the less time we have for fixing.
  2. Open separate tickets for separate problems.

Thank you!

comment:5 Changed 13 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use