VirtualBox

Ticket #13367 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

[FIXED IN SVN] VirtualBox 4.3.16 got stuck when running any VM while previous versions were good

Reported by: VMAle Owned by:
Component: other Version: VirtualBox 4.3.16
Keywords: VirtualBox 4.3.16 Hang Stuck Not Able to Run VM Cc:
Guest type: Windows Host type: Windows

Description

After updating to release 4.3.16 VirtualBox got stuck when running any VM (Windwos 7-8.1-XP, Linux). I found No way to kill VirtualBox processes, even windows restart was not successful and I had to hardware reset the PC. This was the first time I found an issue with VirtualBox (also the first time I had to HW reset the PC that is really stable). I roll back to release 4.3.12 that was and still is perfectly stable. Also release 4.3.14 was working but I decided to skip it because of the conflict with antivirus (not seen on my PC with Avast but found on my notebook with Symantec EP).

PC details: Windows 7 64-bit Pro En, i7-3770k, z77, 16GB RAM, AMD HD7850, Avast Antivirus

VM Details: Guest Windows Xp-7-8.1 32-bit, 2/3 GB RAM, 4 CPU, Addons 4.12 installed

Change History

comment:1 Changed 5 years ago by smilzo

With 4.3.16 my virtual machines do not start, stuck on "Creating process for virtual machine xxx (GUI/QT) ... (1/2)"

OS: Windows 7 Pro 64bit. AntiVirus: Avast free

Replaced Avast with Comodo Antivirus and works fine. Before full O.S. reinstall, with avast installation, 4.3.14 was not working with Comodo, but solved with 4.3.15 update.

comment:2 Changed 5 years ago by Carlos Castaneda

I can confirm the very same behaviour with Avast. VirtualBox got stuck and the only way was to hard reset machine.

OS: Win7 Home Ed SP1 all updates Avast: latest Edition 2014.9.0.2021 VirtualBox 4.3.12 worked fine, 4.3.14 and 4.3.16 didn't.

Replaced Avast with Avira and VirtualBox 4.3.16 no works fine.

comment:3 Changed 5 years ago by fcporto

I too have this problem with version 4.3.16 running on window 7 x64, but not when i downgrade to version 4.3.12. I also have avast AV running.

Is there a solution other than running 4.3.12?

Also, i am able to stop the process virtualbox.exe, which in turn prevents windows from shutting down properly; i'm forced to do a hard reset (this only happens after i try to run a VM).

comment:4 Changed 5 years ago by fcporto

The latest build (Windows, r96235 or VirtualBox-4.3.17-96235-Win) worked for me; i was able to start the VMs without any issues.

THX :)

Running windows 7 Ultimate x64 SP1 with Avast AV

comment:5 Changed 5 years ago by bird

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from VirtualBox 4.3.16 got stuck when running any VM while previous versions were good to [FIXED IN SVN] VirtualBox 4.3.16 got stuck when running any VM while previous versions were good

This problem has been fixed in SVN. The test build https://www.virtualbox.org/download/testcase/VirtualBox-4.3.17-96101-Win.exe includes the fix.

We'll publishing 4.3.18 pretty soon to formally address this issue.

comment:6 Changed 5 years ago by dgc

This was fixed, but broke again in 4.3.20, with Symantec

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use