VirtualBox

Ticket #13365 (closed defect: fixed)

Opened 3 years ago

Last modified 23 months ago

Unity Launcher and top panel overlays full screen mode

Reported by: EarlsFurniture Owned by:
Priority: major Component: GUI/compiz
Version: VirtualBox 4.3.16 Keywords: Unity, Ubuntu, launcher, full screen
Cc: Guest type: other
Host type: Linux

Description

When running a guest in full screen mode, the Ubuntu Unity launcher and top panel overlay the guest screen. This behavior was introduced immediately with the 4.3.16 update. I discovered this issue right after an update to 4.3.16, tested on another machine before and after the update and was able to repeat the issue. The issue did not exist in 4.3.14.

Marked as GUI/Compiz since Unity is a compiz plugin. Otherwise devs would know better where this issue lives.

Marked as major because the left and upper portions of the underlying guest window (usually containing icons, menus, tools in some apps) are inaccessible in this state.

I'm not sure any particular log is relevant, but I'll be happy to upload one if needed.

I can also assist with testing if need be.

Attachments

windowed-maximized.jpg Download (423.3 KB) - added by S.O.E. Ansems 3 years ago.
Screenshot of the guest running in windowed-mode. (No issue here)
full-screen.jpg Download (321.7 KB) - added by S.O.E. Ansems 3 years ago.
Screenshot of the guest running in full-screen-mode (misalignment and overlays are visible)
win8.1.aug-2014-09-12-11-13-58.log Download (145.4 KB) - added by quickbooks 3 years ago.
30.jpg Download (205.3 KB) - added by quickbooks 3 years ago.

Change History

comment:1 follow-up: ↓ 18 Changed 3 years ago by michael

Confirmed. For now disabling the mini-tool-bar works around the problem.

Changed 3 years ago by S.O.E. Ansems

Screenshot of the guest running in windowed-mode. (No issue here)

Changed 3 years ago by S.O.E. Ansems

Screenshot of the guest running in full-screen-mode (misalignment and overlays are visible)

comment:2 Changed 3 years ago by S.O.E. Ansems

Some more relevant information: I too have this issue, but also the screen is misaligned in multi-monitor setup. (See the attached screenshots of a windowed and full-screen guest.)

comment:3 Changed 3 years ago by michael

The positioning is a bug in Compiz/Unity.

 https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1353675

comment:4 follow-up: ↓ 5 Changed 3 years ago by quickbooks

I am using Gnome Shell (Host = Fedora 20).

I seem to also have issues with full screen and seamless mode with the latest Vbox.

I have multi monitor setup, 1st monitor - 18" = 1360x768 ; 2nd monitor - 21" = 1920x1080.

If the guest starts in Windowed mode it works fine.

If I do CTRL+F I cannot use the guest. Getting back to windowed mode (after you try to put the vm in full screen or seamless mode) does not work as the guest goes outside the window area in the wrong monitor (primary) even though the window is in the secondary monitor.

Guest = Win 8.1.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 3 years ago by michael

Replying to quickbooks:

If I do CTRL+F I cannot use the guest. Getting back to windowed mode (after you try to put the vm in full screen or seamless mode) does not work as the guest goes outside the window area in the wrong monitor (primary) even though the window is in the secondary monitor.

Sorry for sounding dense, but could you please explain that again?

comment:6 in reply to: ↑ 5 Changed 3 years ago by quickbooks

Replying to michael:

Replying to quickbooks:

If I do CTRL+F I cannot use the guest. Getting back to windowed mode (after you try to put the vm in full screen or seamless mode) does not work as the guest goes outside the window area in the wrong monitor (primary) even though the window is in the secondary monitor.

Sorry for sounding dense, but could you please explain that again?

You cannot switch modes to full screen or seamless. It doesn't work.

Changed 3 years ago by quickbooks

comment:7 follow-up: ↓ 8 Changed 3 years ago by michael

Your comment sounded more to me like you could switch to that mode but couldn't get out of it again. It was the bit about the guest going into the wrong monitor that I did not get. Are you talking about the guest window moving? If so though what do you mean by the guest moving to the primary monitor while the window (the guest window?) is in the secondary?

comment:8 in reply to: ↑ 7 Changed 3 years ago by quickbooks

Replying to michael:

Your comment sounded more to me like you could switch to that mode but couldn't get out of it again. It was the bit about the guest going into the wrong monitor that I did not get. Are you talking about the guest window moving? If so though what do you mean by the guest moving to the primary monitor while the window (the guest window?) is in the secondary?

I am attaching a screenshot.

This is after switching back to windowed mode.

Window (inside is black) is in Monitor 2. Guest is outside the Window in Monitor 1.

Changed 3 years ago by quickbooks

comment:9 follow-up: ↓ 10 Changed 3 years ago by michael

Thank you. Are the black bars something you edited into the image manually or something on your screen?

comment:10 in reply to: ↑ 9 Changed 3 years ago by quickbooks

Replying to michael:

Thank you. Are the black bars something you edited into the image manually or something on your screen?

The black bars on the left came with the screen shot because the 1st monitor is smaller than the 2nd monitor.

1st monitor - 18" (or 19") = 1360x768 ; Left side ;

2nd monitor - 21" = 1920x1080 ; Right side ;

Last edited 3 years ago by quickbooks (previous) (diff)

comment:11 Changed 3 years ago by michael

By the way, anyone affected by the shifted-screen-position-under-Unity problem should feel free to add a "me too" to the Launchpad bug report I linked to above, or (better) select "this affects me too" on the bug report page.

comment:12 follow-up: ↓ 16 Changed 3 years ago by michael

quickbooks: I tried running a single-screen Fedora 21 guest under GNOME Shell started as "gnome-shell --replace" on a dual-screen Ubuntu 14.04 host with screen set-up as below. I was able to enter and exit full-screen with the mini-toolbar enabled or disabled without any problems. Admittedly this was with a development build and development Additions. Any thought about other potential relevant differences in your set-up?

$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 1200, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1920x1080      60.0*+   59.9  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 connected 1920x1200+1920+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      59.6*+
   1920x1080      60.2  
   1600x1200      60.1  
   1280x1024      76.0     75.0     60.0  
   1152x921       66.0  
   1152x864       75.0  
   1024x768       75.1     75.0     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

comment:13 Changed 3 years ago by Jeffska

I can confirm similar issues in a vanilla Gnome 3/Mutter environment (Arch Linux) as well. Whatever full-screen related changes that were made as part of 4.3.16 are causing all kinds of havoc.

comment:14 follow-up: ↓ 15 Changed 3 years ago by michael

Jeffska: similar to what quickbooks describes? And both, does disabling the mini-toolbar make any difference?

comment:15 in reply to: ↑ 14 Changed 3 years ago by quickbooks

Replying to michael:

And both, does disabling the mini-toolbar make any difference?

Mini-toolbar was already disabled.

comment:16 in reply to: ↑ 12 Changed 3 years ago by quickbooks

[me@h ~]$ xrandr 
Screen 0: minimum 8 x 8, current 3280 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected primary 1360x768+0+150 (normal left inverted right x axis y axis) 406mm x 229mm
   1360x768      60.02*+
   1280x768      59.87  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
DVI-I-1 connected 1920x1080+1360+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     59.93*+  60.00  
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
HDMI-0 disconnected (normal left inverted right x axis y axis)
[me@h ~]$

Can you try running Windows 8.1 guest?

Here is the ISO for F20 with updates to around September 2nd:  https://dl.fedoraproject.org/pub/alt/live-respins/F20-x86_64-LIVE-DESK-20140902.iso

comment:17 follow-up: ↓ 20 Changed 3 years ago by quickbooks

I have now downgraded to VBox 4.3.14.

If you want I can test a development build if it fixes this annoying issue: https://www.virtualbox.org/ticket/12610

:)

comment:18 in reply to: ↑ 1 Changed 3 years ago by EarlsFurniture

Replying to michael:

Confirmed. For now disabling the mini-tool-bar works around the problem.

It seems while this does work to enter full-screen mode, there is then no way out. The Host+F or any other Host+ combo to enter any other mode does not work. As well, and this may be of course another issue, the Host toggle to capture/release the keyboard does not work at all. (which may be why I can't switch modes) The keyboard is permanently captured by the VM, but does not function within the VM either - effectively a dead keyboard.

I tried Seamless and Scaled mode and had the same problems. Scaled has no menu, and Seamless won't work with the mini-toolbar. So I can enter the VM in any mode, I just can't switch back to my host after that, and no matter what, I don't get any keyboard functionality.

So this work-around is a no-go.

I've downgraded to 4.3.14 via debs from the virtualbox.org site, but can test other builds if need be.

comment:19 Changed 3 years ago by michael

I would also be interested to know whether disabling 3D, if it is enabled, makes a difference for anyone who commented here. EarlsFurniture: is the failure of host key combinations something reproducible? I am asking because I use Ubuntu with Unity on my development system and do not see this.

comment:20 in reply to: ↑ 17 ; follow-up: ↓ 21 Changed 3 years ago by quickbooks

Replying to quickbooks:

I have now downgraded to VBox 4.3.14.

If you want I can test a development build if it fixes this annoying issue: https://www.virtualbox.org/ticket/12610

:)

The Latest test build - 64-bit Linux, r96212 - still has the multiple monitor issue.

comment:21 in reply to: ↑ 20 Changed 3 years ago by michael

Replying to quickbooks:

The Latest test build - 64-bit Linux, r96212 - still has the multiple monitor issue.

Including with 3D disabled?

comment:22 Changed 3 years ago by frank

Still an issue with VBox 4.3.18? Actually VBox 4.3.18 contains a possible extradata setting which allow to change the behavior for Unity, please check the user manual.

Last edited 3 years ago by frank (previous) (diff)

comment:23 Changed 3 years ago by NSky

how do I turn on "extradata setting which allow to change the behavior for Unity"?? Was googling for 30 minutes but found nothing.

comment:24 follow-up: ↓ 25 Changed 3 years ago by michael

comment:25 in reply to: ↑ 24 Changed 3 years ago by NSky

Replying to michael:

See here:

https://www.virtualbox.org/ticket/13410#comment:4

Thanks, it works!

comment:26 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

There is a workaround in VBox and in the meantime, Unity is also fixed. Closing this ticket.

comment:27 Changed 3 years ago by michael

Ubuntu now have a fix available for testing for Ubuntu 14.04. Could someone using that test their package and update the Launchpad ticket? Thanks!

comment:28 Changed 2 years ago by Justice

Regression perhaps? With Ubuntu 15.04, I can still interact with the (initially hidden) launcher buttons at the extreme left edge of the screen.

To be clear, the buttons aren't visible, but a click there brings them to the foreground.

This happens for me whether or not the VB mini-toolbar is enabled.

comment:29 Changed 23 months ago by Justice

I am still seeing a variant of this issue with Virtualbox 5.0.6 on my asymmetric multimonitor setup on Ubuntu 15.04. The Unity launcher and menubar are hidden behind the fullscreen Guest screens, but accept clicks after working outside of VB for a few minutes and then returning.

I have filed launchpad bug 1503767 against Unity. If you observe similar issues, please indicate so on the Launchpad bug.

 https://bugs.launchpad.net/unity/+bug/1503767

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use