VirtualBox

Ticket #1336 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

VirtualBox crashes on Solaris host when using Share Folder on WinXP guest => Fixed in 1.6.4

Reported by: rmanus Owned by:
Priority: major Component: shared folders
Version: VirtualBox 1.6.0 Keywords: solaris, share, crash
Cc: Guest type: other
Host type: Solaris

Description (last modified by frank) (diff)

I've recompiled VirtualBox from Mar-15-2008 source trunk on Solaris Nevada build 82.

If I add a share folder to my WinXP guest, VB crashes with the following stack (see next comment).

It's 100% reproducible.

I believe this is happening when WinXP tries to reconnect the network drive.

Change History

comment:1 Changed 6 years ago by rmanus

> $c
libc.so.1`t_splay+0x27()
libc.so.1`t_delete+0x29()
libc.so.1`realfree+0x65()
libc.so.1`cleanfree+0x55()
libc.so.1`_malloc_unlocked+0xa7()
libc.so.1`malloc+0x2f()
VBoxRT.so`_Z12rtstrConvertPKvmPKcPPvmS2_j+0x1d0()
VBoxRT.so`RTStrCurrentCPToUtf8+0x76()
VBoxRT.so`_Z13rtDirReadMoreP5RTDIR+0x85()
VBoxRT.so`RTDirReadEx+0x112()
VBoxSharedFolders.so`_Z17vbsfBuildFullPathP15_SHFLCLIENTDATAjP11_SHFLSTRINGjPPcPjb+0x4ef()
VBoxSharedFolders.so`_Z10vbsfCreateP15_SHFLCLIENTDATAjP11_SHFLSTRINGjP16_SHFLCREATEPARMS+0x57()
VBoxSharedFolders.so`_Z7svcCallP26VBOXHGCMCALLHANDLE_TYPEDEFjPvjjP15VBOXHGCMSVCPARM+0x68a()
VBoxC.so`_Z17hgcmServiceThreadjPv+0x2a0()
VBoxC.so`_Z20hgcmWorkerThreadFuncP11RTTHREADINTPv+0x39()
VBoxRT.so`rtThreadMain+0x34()
VBoxRT.so`_Z18rtThreadNativeMainPv+0x6c()
libc.so.1`_thr_setup+0x67()
libc.so.1`_lwp_start()

> ::status
debugging core file of VirtualBox (64-bit) from solaris-devx
file: /opt/VirtualBox/vbox/out/solaris.amd64/release/bin/VirtualBox
initial argv: /opt/VirtualBox/vbox/out/solaris.amd64/release/bin/VirtualBox -comment winxp -s
threading model: native threads
status: process terminated by SIGSEGV (Segmentation Fault)

comment:2 Changed 6 years ago by frank

  • Description modified (diff)

comment:3 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with 1.6.0 and report back if it's still relevant. Thanks.

comment:4 Changed 6 years ago by rmanus

  • Status changed from closed to reopened
  • Resolution fixed deleted

Problem still exists with 1.6.0 although the stack trace is different:

> $c
VBoxXPCOMIPCC.so`_Z23PruneInstanceMapForPeerRKN19DConnectInstanceKey3KeyEP16DConnectInstancePv+0x2b()
VBoxXPCOMIPCC.so`_ZN15nsBaseHashtableI19DConnectInstanceKeyP16DConnectInstanceS2_E14s_EnumReadStubEP12PLDHashTableP15PLDHas
hEntryHdrjPv+0x12()
VBoxXPCOM.so`PL_DHashTableEnumerate+0x7f()
VBoxXPCOMIPCC.so`_ZNK15nsBaseHashtableI19DConnectInstanceKeyP16DConnectInstanceS2_E13EnumerateReadEPF15PLDHashOperatorRKNS0
_3KeyES2_PvES8_+0x20()
VBoxXPCOMIPCC.so`_ZN18ipcDConnectService19OnClientStateChangeEjj+0x8f()
VBoxXPCOMIPCC.so`_ZN20ipcEvent_ClientState11HandleEventEP7PLEvent+0x47()
VBoxXPCOM.so`PL_HandleEvent+0x1b()
VBoxXPCOM.so`_ZN16nsEventQueueImpl11HandleEventEP7PLEvent+0x26()
main+0x771()
_start+0x6c()

comment:5 Changed 6 years ago by sandervl73

Did you build it yourself again? If so please try our binary version to rule out an issue with self-building.

comment:6 Changed 6 years ago by sandervl73

  • Version changed from VirtualBox Solaris Beta 1 to VirtualBox 1.6.0

comment:7 Changed 6 years ago by rmanus

I didn't build it myself this time. I've tried the binary version 1.6.0. The crash occured when I double clicked on the network drive.

comment:8 Changed 6 years ago by ramshankar

Tried here with WinXP Pro and adding a shared folder. I'm unable to reproduce the crash. But also using "net x:\vboxwebsvr\<the-share-name>" doesn't work.

comment:9 Changed 6 years ago by ramshankar

This is fixed in internal SVN. Thank you for reporting.

comment:10 Changed 6 years ago by frank

  • Summary changed from VirtualBox crashes on Solaris host when using Share Folder on WinXP guest to VirtualBox crashes on Solaris host when using Share Folder on WinXP guest => Fixed in 1.6.4

comment:11 Changed 6 years ago by frank

  • Host type changed from other to Solaris

comment:12 Changed 6 years ago by frank

  • Component changed from other to shared folders

comment:13 Changed 6 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use