VirtualBox

Ticket #13319 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Virtual machine crashes on restart of Windows XP when more than 1 core specified.

Reported by: Squall Leonhart Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.14 Keywords:
Cc: Guest type: Windows
Host type: other

Description

First noticed in: 4.3.14 Also present in 4.3.15

Behaviour changes depending on whether you are Restarting or Shutting down.

Restarting will cause a screen with a black and yellow horizontal stripe to appear where the oracle boot screen should.

Shutting down will cause the Virtual machine to stop responding when the machine should "power off" requiring End Task.

Attachments

oddbehavior.jpg Download (97.7 KB) - added by Squall Leonhart 3 years ago.
screenshot of the issue
VBox.log Download (117.2 KB) - added by Squall Leonhart 3 years ago.
Vbox Log
VBoxStartup.zip Download (31.4 KB) - added by Squall Leonhart 3 years ago.
Vbox startup log
vbox_debug.7z Download (345.5 KB) - added by mhanor 3 years ago.
VBOX_LOG=+em.e.l.f.l2.l3.l4.l5.l6
VBox.2.log Download (59.3 KB) - added by mhanor 3 years ago.
4.3.16 OSE x64
Win732bclient_hangonreboot.png Download (83.9 KB) - added by jimav 3 years ago.
Screenshot of win7 hung at reboot (yellow & blue stripes)
Win732bclient_hangonreboot_Vbox.log Download (86.2 KB) - added by jimav 3 years ago.
VBox.log from Win7 32bit host reboot hang (see comment#8)

Change History

Changed 3 years ago by Squall Leonhart

screenshot of the issue

Changed 3 years ago by Squall Leonhart

Vbox Log

Changed 3 years ago by Squall Leonhart

Vbox startup log

comment:1 Changed 3 years ago by mhanor

Disable 3D acceleration and see if the VM still becomes unresponsive.
I can see that the guest OS hangs on reboot/shutdown commands, commands issued from withing the guest. The EMT threads are doing something. But the VM process itself doesn't crash/hang. I can issue a hard reboot/shutdown and the VM continues to run.

comment:2 Changed 3 years ago by Squall Leonhart

Already did all that, i wouldn't have reported it if it wasn't isolated down to the amount of cores by testing all variables.

FWIW, XP64 is not affected, only XP32 SP3, the only thing changed between it working and not working was an upgrade from 4.3.10 to 4.3.14+

Last edited 3 years ago by Squall Leonhart (previous) (diff)

comment:3 Changed 3 years ago by frank

Any improvement with VBox 4.3.16?

comment:4 Changed 3 years ago by mhanor

The two EMT threads are still spinning, eating 100% time of two CPU cores (host kernel time, from what I can see), after issuing a reboot or a shutdown command, from the guest. I have to issue a hard reset/shutdown, to reboot/shutdown the VM.

Last edited 3 years ago by mhanor (previous) (diff)

comment:5 Changed 3 years ago by Squall Leonhart

Afraid i cannot say the same mhanor, 4.3.16 appears to have resolved it.

edit woops

i failed hard there, i forgot to re-enable the second core.

yes, i can confirm that the issue is still present, as mhanor described.

Last edited 3 years ago by Squall Leonhart (previous) (diff)

Changed 3 years ago by mhanor

VBOX_LOG=+em.e.l.f.l2.l3.l4.l5.l6

Changed 3 years ago by mhanor

4.3.16 OSE x64

comment:6 Changed 3 years ago by mhanor

I've attached the last part of the debug log, along with the usual VM log, of the same session.

comment:7 Changed 3 years ago by Squall Leonhart

so its happening on XP x64 for you mhanor?

because i have no issues shutting down my XP64 guest here, only the 32bit XP guest.

comment:8 Changed 3 years ago by jimav

I get a similar problem with Win7 32-bit guest and Ubuntu 64bit host. However SHUTDOWN completes successfully, it is only RESTART which hangs. The hang is with strange stripes on the screen, and Machine->Reset succeeds. Happens only when #processors > 1.

Been like this in all recent updates. Currently on 4.3.18

I'll attach screen-shot and VBox.log files. The log file has "HANG HERE" inserted at the point where the hang occurred (the remaining lines were logged after doing a reset)

Last edited 3 years ago by jimav (previous) (diff)

Changed 3 years ago by jimav

Screenshot of win7 hung at reboot (yellow & blue stripes)

Changed 3 years ago by jimav

VBox.log from Win7 32bit host reboot hang (see comment#8)

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 4.3.20.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use