VirtualBox

Ticket #13287 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

second screen disappears -> fixed in 4.3.x and later releases after 28 Jan 2015

Reported by: Olivier Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I have 2 monitors on the host & guest. After number of idle minutes the second screen disappears, and I cannot get it back.

  • Host : Win 7, Aero disabled
  • Guest : Fedora 20 XFCE : Linux 3.15.7-200.fc20.x86_64

Screen saver is disabled on host & guest.

This is happening since I upgraded to 4.3.12. Had no such issue with previous version.

Thank you.

Change History

comment:1 Changed 3 years ago by Olivier

Also - but I'm not sure if it is related - the mouse behave strangely: seems like resolution in dual screen mode is scaled to single. This is intermittent, work-around is to reboot guest. Happened in previous version, was fine lately, seems to reappear with 4.3.12

comment:2 Changed 3 years ago by AlxShr

Same for me, but the guest is Ubuntu 12.04

comment:3 Changed 3 years ago by capintxu

Same here.

host: windows 7 64 bit professional using virtual box 4.3.18.r96516

guest: $ uname -a Linux host-VirtualBox 3.11.0-15-generic #25~precise1-Ubuntu SMP Thu Jan 30 17:39:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

comment:4 Changed 3 years ago by Olivier

I have a workaround to this. It seems to be a DPMS issue.

Running this after X session start works for me : xset -dpms s noblank

See:  http://forums.fedoraforum.org/archive/index.php/t-242247.html

comment:5 Changed 3 years ago by frank

I tried 'xset dpms force off' here and the 2nd screen (Ubuntu 12.04 guest) indeed disappears. When I move the move over the first screen or press a key, the 2nd screen re-appears. So when you say that you cannot get your 2nd screen back, terminating the screen saver from the 1st screen does not help?

comment:6 Changed 3 years ago by michael

Could you please give the latest test build<1> a try? I think that this problem may be fixed there. 'xset dpms force off' still behaves in a strange way as the code path in the X server which it triggers is hard-coded to always do a DPMS power off.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:7 Changed 3 years ago by Olivier

To Frank : indeed, after 'xset dpms force off' reactivating the 1st screen doesn't bring back the 2nd one.

To Michael : willdo when possible (couple of weeks).

comment:8 Changed 3 years ago by michael

  • Summary changed from second screen disappears to second screen disappears -> fixed in 4.3.x and later releases after 28 Jan 2015

Please give the most recent test builds<1> a try, I have done additional fixing here, and I think some very old issues are now cleaned up. If you don't reply I will assume this is fixed.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.22.

comment:10 Changed 3 years ago by Olivier

I confirm this is fixed in 4.3.22 - Many thanks.

FYI, the virtual screens are now called 'VGA-1,VGA-2,...' vs. 'VBOX1,VBOX2,...'. Could be good to mention this in the change logs.

Last edited 3 years ago by Olivier (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use