VirtualBox

Ticket #1322 (closed defect: obsolete)

Opened 6 years ago

Last modified 3 months ago

Seamless: on secondary TwinView monitor not working -> Fixed in SVN

Reported by: jbowen Owned by:
Priority: major Component: GUI/multiview
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Under Ubuntu Gutsy using the NVIDIA 1.0-9639 driver (NVidia Quadro FX550 w/128MB), seamless mode is not working.

If I start the VM and move the VM window to the secondary monitor then enter seamless mode, the VM window disappears and no client windows are displayed. Pressing <Ctrl><Home> will allow me to disable seamless mode and restore the VM window to its original state.

If I move the VM back to the primary display and enter seamless mode, then everything works fine.

Attachments

VBox.log Download (29.9 KB) - added by jbowen 6 years ago.
Log file

Change History

Changed 6 years ago by jbowen

Log file

comment:1 Changed 6 years ago by jbowen

Neglected to specify that the VM client is Windows XP Pro SP2.

comment:2 Changed 6 years ago by agaffney

I can confirm this issue with virtualbox-1.6.4 nvidia binary drivers 173.14.09 and xorg-server-1.4.2. The guest is Windows XP Pro SP3. This makes seamless mode a bit useless to me, since I use it to put Windows apps on my second display (currently using vmware-server and a seamless rdp hack).

comment:3 in reply to: ↑ description Changed 6 years ago by rfm

I have the same symptoms, but a different configuration. My host OS is Windows XP SP3, guest is Ubuntu 8.04, VirtualBox 2.0.0 (PUEL.) Not opening another ticket on the suspicion it's all the same underlying problem.

comment:4 Changed 6 years ago by frank

  • Component changed from other to GUI/multiview

comment:5 Changed 5 years ago by frank

  • Summary changed from Seamless mode on secondary TwinView monitor not working to Seamless: on secondary TwinView monitor not working

comment:6 Changed 4 years ago by clacombe

I have the same issue on WinXP with Fedora as Guest. Strange that this issue is open since 2 years without any fixe ! May be VBox gyes are not using dual screen? I hope there will be a fix one day...

comment:7 Changed 4 years ago by poetzsch

  • Summary changed from Seamless: on secondary TwinView monitor not working to Seamless: on secondary TwinView monitor not working -> Fixed in SVN

Fixed in the next major release.

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 Changed 3 years ago by jpierre

  • Status changed from closed to reopened
  • Resolution fixed deleted

This is still broken in 4.0.0 . What "next major release" is the fix in ?

comment:10 Changed 3 years ago by Bausparfuchs

I am very interested in that too. Which "next major release" will be the "next" you mentioned above? I pray for seamless mode on two monitors for years.

comment:11 Changed 3 years ago by rfm

Works for me in 4.0.0, after creating two virtual monitors, assigning one virtual monitor to each real monitor, entering seamless mode, and configuring monitors in guest. There is a visual glitch when guest windows are deleted on the secondary monitor, the guest background shows until the next time a guest window is moved/created on the secondary monitor (this was reported in the beta forums, don't see a separate ticket on it.)

comment:12 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use